summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-03-30 05:38:28 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-03-30 05:38:28 +0000
commit2600d37177c6d176136d3b1799a742d5a9a67cc9 (patch)
treea921457adda7b01eac93733ca8f8da712a720723 /app-misc/rox
parentUpdate to 2.0.9 (diff)
downloadgentoo-2-2600d37177c6d176136d3b1799a742d5a9a67cc9.tar.gz
gentoo-2-2600d37177c6d176136d3b1799a742d5a9a67cc9.tar.bz2
gentoo-2-2600d37177c6d176136d3b1799a742d5a9a67cc9.zip
libxml2 header fix
Diffstat (limited to 'app-misc/rox')
-rw-r--r--app-misc/rox/ChangeLog10
-rw-r--r--app-misc/rox/files/digest-rox-1.1.8-r32
-rw-r--r--app-misc/rox/rox-1.1.8-r3.ebuild42
3 files changed, 52 insertions, 2 deletions
diff --git a/app-misc/rox/ChangeLog b/app-misc/rox/ChangeLog
index bc1261702eca..92489d899cd3 100644
--- a/app-misc/rox/ChangeLog
+++ b/app-misc/rox/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for app-misc/rox
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rox/ChangeLog,v 1.2 2002/02/28 07:32:39 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rox/ChangeLog,v 1.3 2002/03/30 05:38:28 blocke Exp $
+
+*rox-1.1.8-r3 (30 Mar 2002)
+
+ 30 Mar 2002; Bruce A. Locke <blocke@shivan.org> rox-1.1.8-r3.ebuild :
+
+ Added libxml2 header fix
*rox-1.1.8-r1 (28 Feb 2002)
- 28 Feb 2002; Bruce A. Locke <blocke@gentoo.org> ChangeLog :
+ 28 Feb 2002; Bruce A. Locke <blocke@shivan.org> rox-1.1.8-r1.ebuild :
Added libxml2 as a dependency
diff --git a/app-misc/rox/files/digest-rox-1.1.8-r3 b/app-misc/rox/files/digest-rox-1.1.8-r3
new file mode 100644
index 000000000000..b7265c968865
--- /dev/null
+++ b/app-misc/rox/files/digest-rox-1.1.8-r3
@@ -0,0 +1,2 @@
+MD5 3147cfa3ebf18dbe84e8dce4f8d89951 rox-base-1.0.1.tgz 151699
+MD5 7308e0f7b5b0a04c5ad9cb0f11504c3a rox-1.1.8.tgz 773558
diff --git a/app-misc/rox/rox-1.1.8-r3.ebuild b/app-misc/rox/rox-1.1.8-r3.ebuild
new file mode 100644
index 000000000000..172bd9452b84
--- /dev/null
+++ b/app-misc/rox/rox-1.1.8-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bart Verwilst <verwilst@gentoo.org>
+# /home/cvsroot/gentoo-x86/app-misc/rox/rox-1.1.8.ebuild $
+
+HOMEPAGE="http://rox.sourceforge.net"
+DESCRIPTION="ROX-Filer is a fast and powerful graphical file manager"
+
+S=${WORKDIR}/${P}
+SRC_URI="http://prdownloads.sourceforge.net/rox/rox-base-1.0.1.tgz
+ http://prdownloads.sourceforge.net/rox/${P}.tgz"
+
+DEPEND="virtual/glibc
+ >=x11-base/xfree-4.0.3
+ >=x11-libs/gtk+-1.2.10
+ >=media-libs/gdk-pixbuf-0.13
+ dev-libs/libxml2"
+
+RDEPEND="${DEPEND}"
+
+src_install() {
+
+ # libxml2 header fix
+ CFLAGS="${CFLAGS} -I/usr/include/libxml2/libxml -I/usr/include/libxml2"
+
+ cd ${WORKDIR}/rox-base-1.0.1/Choices
+ mkdir -p ${D}/usr/share/Choices
+ cp -rf MIME-icons/ ${D}/usr/share/Choices/
+ cp -rf MIME-info/ ${D}/usr/share/Choices/
+ cp -rf MIME-types/ ${D}/usr/share/Choices/
+
+ cd ${WORKDIR}/${P}
+ doman rox.1
+ mkdir -p ${D}/usr/share/rox
+ mkdir -p ${D}/usr/bin
+ cp -rf ROX-Filer/ ${D}/usr/share/
+ ${D}/usr/share/ROX-Filer/AppRun --compile
+ echo "#!/bin/sh" > "${D}/usr/bin/rox"
+ echo "exec /usr/share/ROX-Filer/AppRun \"\$@\"" >> "${D}/usr/bin/rox"
+ chmod a+x ${D}/usr/bin/rox
+
+}