summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2001-11-21 00:27:04 +0000
committerBart Verwilst <verwilst@gentoo.org>2001-11-21 00:27:04 +0000
commit5872a632a2e3dc9e20fa9f8f0f3c9a34d4ccf4c6 (patch)
tree28085a2ed2ae05d54514887f5ffd3e5827fdb28e /app-misc/rox
parentNew Proggie, Rox, Filemanager... Masked because not fully finished yet, (diff)
downloadgentoo-2-5872a632a2e3dc9e20fa9f8f0f3c9a34d4ccf4c6.tar.gz
gentoo-2-5872a632a2e3dc9e20fa9f8f0f3c9a34d4ccf4c6.tar.bz2
gentoo-2-5872a632a2e3dc9e20fa9f8f0f3c9a34d4ccf4c6.zip
I finished the package after all... removed from package.mask... Must
... Sleep... ;o)
Diffstat (limited to 'app-misc/rox')
-rw-r--r--app-misc/rox/rox-1.1.8.ebuild26
1 files changed, 21 insertions, 5 deletions
diff --git a/app-misc/rox/rox-1.1.8.ebuild b/app-misc/rox/rox-1.1.8.ebuild
index bc069ee532e8..7e014e867052 100644
--- a/app-misc/rox/rox-1.1.8.ebuild
+++ b/app-misc/rox/rox-1.1.8.ebuild
@@ -1,19 +1,35 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bart Verwilst <verwilst@gentoo.org>
+# /home/cvsroot/gentoo-x86/app-misc/rox/rox-1.1.8.ebuild $
+
HOMEPAGE="http://rox.sourceforge.net"
+DESCRIPTION="ROX-Filer is a fast and powerful graphical file manager"
S=${WORKDIR}/${P}
SRC_URI="http://prdownloads.sourceforge.net/rox/rox-base-1.0.1.tgz
http://prdownloads.sourceforge.net/rox/${P}.tgz"
DEPEND="virtual/glibc
- >=x11-base/xfree-4.0.3"
+ >=x11-base/xfree-4.0.3
+ >=x11-libs/gtk+-1.2.10
+ >=media-libs/gdk-pixbuf-0.13"
-src_unpack() {
+src_install() {
- unpack rox-base-1.0.1.tgz
- cd ${WORKDIR}/rox-base-1.0.1
+ cd ${WORKDIR}/rox-base-1.0.1/Choices
mkdir -p ${D}/usr/share/Choices
cp -rf MIME-icons/ ${D}/usr/share/Choices/
cp -rf MIME-info/ ${D}/usr/share/Choices/
cp -rf MIME-types/ ${D}/usr/share/Choices/
-
+
+ cd ${WORKDIR}/${P}
+ doman rox.1
+ mkdir -p /usr/share/rox
+ cp -rf ROX-Filer/ /usr/share/
+ /usr/share/ROX-Filer/AppRun --compile
+ echo "#!/bin/sh" > "/usr/bin/rox"
+ echo "exec /usr/share/ROX-Filer/AppRun \"\$@\"" >> "/usr/bin/rox"
+ chmod a+x /usr/bin/rox
+
}