summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-12-22 16:55:06 +0000
committerHans de Graaff <graaff@gentoo.org>2013-12-22 16:55:06 +0000
commit7eac06610a128cc320716570bce8e86edcffc52e (patch)
tree28d3d1f27eb750bc1881d20156a9654e669228ad /app-misc/sphinx
parentpreliminary support for newer EAPIs (diff)
downloadgentoo-2-7eac06610a128cc320716570bce8e86edcffc52e.tar.gz
gentoo-2-7eac06610a128cc320716570bce8e86edcffc52e.tar.bz2
gentoo-2-7eac06610a128cc320716570bce8e86edcffc52e.zip
Version bump. Depend on dev-libs/snowball-stemmer instead of compiling the library as part of sphinx.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'app-misc/sphinx')
-rw-r--r--app-misc/sphinx/ChangeLog8
-rw-r--r--app-misc/sphinx/sphinx-2.1.4.ebuild95
2 files changed, 102 insertions, 1 deletions
diff --git a/app-misc/sphinx/ChangeLog b/app-misc/sphinx/ChangeLog
index 1b50746062e1..d38dfb093ccb 100644
--- a/app-misc/sphinx/ChangeLog
+++ b/app-misc/sphinx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/sphinx
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.69 2013/11/27 07:05:20 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.70 2013/12/22 16:55:06 graaff Exp $
+
+*sphinx-2.1.4 (22 Dec 2013)
+
+ 22 Dec 2013; Hans de Graaff <graaff@gentoo.org> +sphinx-2.1.4.ebuild:
+ Version bump. Depend on dev-libs/snowball-stemmer instead of compiling the
+ library as part of sphinx.
*sphinx-2.1.3 (27 Nov 2013)
diff --git a/app-misc/sphinx/sphinx-2.1.4.ebuild b/app-misc/sphinx/sphinx-2.1.4.ebuild
new file mode 100644
index 000000000000..331f3e3a4b94
--- /dev/null
+++ b/app-misc/sphinx/sphinx-2.1.4.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-2.1.4.ebuild,v 1.1 2013/12/22 16:55:06 graaff Exp $
+
+EAPI=5
+inherit eutils autotools toolchain-funcs
+
+#MY_P=${P/_/-}
+MY_P=${P}-release
+
+# This has been added by Gentoo, to explicitly version libstemmer.
+# It is the date that http://snowball.tartarus.org/dist/libstemmer_c.tgz was
+# fetched.
+#STEMMER_PV="20091122"
+DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
+HOMEPAGE="http://www.sphinxsearch.com/"
+SRC_URI="http://sphinxsearch.com/files/${MY_P}.tar.gz"
+# stemmer? ( mirror://gentoo/libstemmer_c-${STEMMER_PV}.tgz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug id64 mysql odbc postgres stemmer syslog test xml"
+
+RDEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ odbc? ( dev-db/unixODBC )
+ stemmer? ( dev-libs/snowball-stemmer )
+ xml? ( dev-libs/expat )
+ virtual/libiconv"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.1_beta-darwin8.patch
+
+ # drop nasty hardcoded search path breaking Prefix
+ # We patch configure directly since otherwise we need to run
+ # eautoreconf twice and that causes problems, bug 425380
+ sed -i -e 's/\/usr\/local\//\/someplace\/nonexisting\//g' configure || die
+
+ # Fix QA compilation warnings.
+ sed -i -e '19i#include <string.h>' api/libsphinxclient/test.c || die
+
+ pushd api/libsphinxclient || die
+ eautoreconf
+ popd || die
+}
+
+src_configure() {
+ # fix libiconv detection
+ use !elibc_glibc && export ac_cv_search_iconv=-liconv
+
+ econf \
+ --sysconfdir="${EPREFIX}/etc/${PN}" \
+ $(use_enable id64) \
+ $(use_with debug) \
+ $(use_with mysql) \
+ $(use_with odbc unixodbc) \
+ $(use_with postgres pgsql) \
+ $(use_with stemmer libstemmer) \
+ $(use_with syslog syslog) \
+ $(use_with xml libexpat )
+
+ cd api/libsphinxclient || die
+ econf STRIP=:
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" || die "emake failed"
+
+ emake -j 1 -C api/libsphinxclient || die "emake libsphinxclient failed"
+}
+
+src_test() {
+ elog "Tests require access to a live MySQL database and may require configuration."
+ elog "You will find them in /usr/share/${PN}/test and they require dev-lang/php"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" -C api/libsphinxclient install || die "install libsphinxclient failed"
+
+ dodoc doc/*
+
+ dodir /var/lib/sphinx
+ dodir /var/log/sphinx
+
+ newinitd "${FILESDIR}"/searchd.rc searchd
+
+ if use test; then
+ insinto /usr/share/${PN}
+ doins -r test
+ fi
+}