summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-08 15:12:29 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-08 15:12:29 +0000
commit2cce8a756dd73be380bf13766472b83a0fbd13e9 (patch)
tree67bab119458570ffba8d87311c2c72c8cdc28636 /app-misc/tmux/tmux-1.7-r1.ebuild
parentapp-misc/grc: Add support for ipv6, #450324; use python-r1.eclass (diff)
downloadgentoo-2-2cce8a756dd73be380bf13766472b83a0fbd13e9.tar.gz
gentoo-2-2cce8a756dd73be380bf13766472b83a0fbd13e9.tar.bz2
gentoo-2-2cce8a756dd73be380bf13766472b83a0fbd13e9.zip
app-misc/tmux: Install bashcompletion file, #450896
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'app-misc/tmux/tmux-1.7-r1.ebuild')
-rw-r--r--app-misc/tmux/tmux-1.7-r1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-misc/tmux/tmux-1.7-r1.ebuild b/app-misc/tmux/tmux-1.7-r1.ebuild
new file mode 100644
index 000000000000..6f3b23ace857
--- /dev/null
+++ b/app-misc/tmux/tmux-1.7-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.7-r1.ebuild,v 1.1 2013/01/08 15:12:29 jlec Exp $
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.sourceforge.net"
+SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="vim-syntax"
+
+COMMON_DEPEND="
+ >=dev-libs/libevent-2.0.10
+ sys-libs/ncurses"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ vim-syntax? ( || (
+ app-editors/vim
+ app-editors/gvim ) )"
+
+DOCS=( CHANGES FAQ NOTES TODO )
+
+pkg_setup() {
+ if has_version "<app-misc/tmux-1.7"; then
+ echo
+ ewarn "Some configuration options changed in this release."
+ ewarn "Please read the CHANGES file in /usr/share/doc/${PF}/"
+ ewarn
+ ewarn "WARNING: after updating to ${P} you will _not_ be able to connect to any"
+ ewarn "running 1.6 tmux server instances. You'll have to use an existing client to"
+ ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
+ ewarn "to temporarily downgrade to tmux 1.6 to access them."
+ echo
+ fi
+}
+
+src_prepare() {
+ # look for config file in the prefix
+ sed -i -e '/SYSTEM_CFG/s:"/etc:"'"${EPREFIX}"'/etc:' tmux.h || die
+ # and don't just add some includes
+ sed -i -e 's:-I/usr/local/include::' Makefile.in || die
+}
+
+src_install() {
+ default
+
+ newbashcomp examples/bash_completion_tmux.sh ${PN}
+
+ docinto examples
+ dodoc examples/*.conf
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/tmux.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/tmux.vim
+ fi
+}