summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-07-13 09:20:03 +0000
committerTim Harder <radhermit@gentoo.org>2011-07-13 09:20:03 +0000
commit672aeee8c5947654be7f64b7734401f4e580aea4 (patch)
tree582178f2b42c6c9fd292aad576e31e7ca4da50c3 /app-misc/tmux
parentadded patch required for interix prefix build - upstream committed already. (diff)
downloadgentoo-2-672aeee8c5947654be7f64b7734401f4e580aea4.tar.gz
gentoo-2-672aeee8c5947654be7f64b7734401f4e580aea4.tar.bz2
gentoo-2-672aeee8c5947654be7f64b7734401f4e580aea4.zip
Version bump (acked by wired). Update to EAPI 4.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/tmux')
-rw-r--r--app-misc/tmux/ChangeLog7
-rw-r--r--app-misc/tmux/tmux-1.5.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/app-misc/tmux/ChangeLog b/app-misc/tmux/ChangeLog
index 3e0e0b6ab638..7d2300db39dc 100644
--- a/app-misc/tmux/ChangeLog
+++ b/app-misc/tmux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/tmux
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.63 2011/07/02 20:15:33 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/ChangeLog,v 1.64 2011/07/13 09:20:03 radhermit Exp $
+
+*tmux-1.5 (13 Jul 2011)
+
+ 13 Jul 2011; Tim Harder <radhermit@gentoo.org> +tmux-1.5.ebuild:
+ Version bump (acked by wired). Update to EAPI 4.
02 Jul 2011; nixnut <nixnut@gentoo.org> tmux-1.4.ebuild:
ppc stable #361163
diff --git a/app-misc/tmux/tmux-1.5.ebuild b/app-misc/tmux/tmux-1.5.ebuild
new file mode 100644
index 000000000000..8784145b049f
--- /dev/null
+++ b/app-misc/tmux/tmux-1.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tmux/tmux-1.5.ebuild,v 1.1 2011/07/13 09:20:03 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="Terminal multiplexer"
+HOMEPAGE="http://tmux.sourceforge.net"
+SRC_URI="mirror://sourceforge/tmux/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="vim-syntax"
+
+DEPEND="
+ || ( >=dev-libs/libevent-2.0.10 <dev-libs/libevent-2 )
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ vim-syntax? ( || (
+ app-editors/vim
+ app-editors/gvim ) )"
+
+DOCS=( CHANGES FAQ NOTES TODO )
+
+pkg_setup() {
+ if has_version "<app-misc/tmux-1.3"; then
+ echo
+ ewarn "Commands 'up-pane', 'down-pane' and 'select-prompt' were removed in version 1.3."
+ ewarn "You may want to update your configuration file accordingly to avoid errors on"
+ ewarn "tmux startup."
+ ewarn
+ ewarn "For the full Changelog, together with details on what replaced the above"
+ ewarn "commands, visit http://tmux.cvs.sourceforge.net/viewvc/tmux/tmux/CHANGES."
+ ewarn
+ ewarn "WARNING: after updating to ${P} you will _not_ be able to connect to any"
+ ewarn "running 1.2 tmux server instances. You'll have to use an existing client to"
+ ewarn "end your old sessions or kill the old server instances. Otherwise you'll have"
+ ewarn "to temporarily downgrade to tmux 1.2 to access them."
+ echo
+ fi
+}
+
+src_install() {
+ default
+
+ docinto examples
+ dodoc examples/*.conf
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins examples/tmux.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}"/tmux.vim
+ fi
+}