summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-03-31 06:34:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-03-31 06:34:28 +0000
commit1f8235bd46334e2d341dd64284c93d97148d79c3 (patch)
tree1a9a9ed855d852089cd5270b7408c464cb829b82 /app-misc
parentBump #505506 (diff)
downloadgentoo-2-1f8235bd46334e2d341dd64284c93d97148d79c3.tar.gz
gentoo-2-1f8235bd46334e2d341dd64284c93d97148d79c3.tar.bz2
gentoo-2-1f8235bd46334e2d341dd64284c93d97148d79c3.zip
Bump for #505828
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/beanstalkd/ChangeLog10
-rw-r--r--app-misc/beanstalkd/beanstalkd-1.9.ebuild51
-rw-r--r--app-misc/beanstalkd/files/conf-1.921
-rw-r--r--app-misc/beanstalkd/files/init-1.926
4 files changed, 106 insertions, 2 deletions
diff --git a/app-misc/beanstalkd/ChangeLog b/app-misc/beanstalkd/ChangeLog
index 994775db8375..74c361f03f79 100644
--- a/app-misc/beanstalkd/ChangeLog
+++ b/app-misc/beanstalkd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/beanstalkd
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/beanstalkd/ChangeLog,v 1.31 2013/03/17 15:03:16 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beanstalkd/ChangeLog,v 1.32 2014/03/31 06:34:28 patrick Exp $
+
+*beanstalkd-1.9 (31 Mar 2014)
+
+ 31 Mar 2014; Patrick Lauer <patrick@gentoo.org> +beanstalkd-1.9.ebuild,
+ +files/conf-1.9, +files/init-1.9:
+ Bump for #505828
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/app-misc/beanstalkd/beanstalkd-1.9.ebuild b/app-misc/beanstalkd/beanstalkd-1.9.ebuild
new file mode 100644
index 000000000000..457e430923d8
--- /dev/null
+++ b/app-misc/beanstalkd/beanstalkd-1.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beanstalkd/beanstalkd-1.9.ebuild,v 1.1 2014/03/31 06:34:28 patrick Exp $
+
+EAPI=5
+
+inherit eutils systemd user
+
+DESCRIPTION="A simple, fast work queue"
+HOMEPAGE="http://kr.github.io/beanstalkd/"
+SRC_URI="https://github.com/kr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x64-macos ~x86-macos"
+
+RDEPEND=""
+DEPEND=""
+
+IUSE=""
+
+DOCS=( README News docs/protocol.txt )
+
+pkg_setup() {
+ enewuser beanstalk -1 -1 /var/lib/beanstalkd daemon
+}
+
+src_prepare() {
+ sed -i -e "s/CFLAGS=/CFLAGS?=/" \
+ -e "s/LDLIBS/LDFLAGS/" \
+ -e "s/LDFLAGS=/LDFLAGS?=/" Makefile
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin beanstalkd
+
+ DATADIR=/var/lib/${PN}
+ dodir ${DATADIR}
+ fowners beanstalk:daemon ${DATADIR}
+
+ doman doc/"${PN}".1
+
+ newconfd "${FILESDIR}/conf-${PV}" beanstalkd
+ newinitd "${FILESDIR}/init-${PV}" beanstalkd
+
+ systemd_dounit "${S}/adm/systemd/${PN}".{service,socket}
+}
diff --git a/app-misc/beanstalkd/files/conf-1.9 b/app-misc/beanstalkd/files/conf-1.9
new file mode 100644
index 000000000000..47a42c75c112
--- /dev/null
+++ b/app-misc/beanstalkd/files/conf-1.9
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beanstalkd/files/conf-1.9,v 1.1 2014/03/31 06:34:28 patrick Exp $
+
+BEANSTALKD_BINARY="/usr/bin/beanstalkd"
+PIDFILE="/run/beanstalkd.pid"
+
+# User to run as
+USER="beanstalk"
+
+# Port to listen on
+PORT="11300"
+
+# Address to listen on
+ADDR="127.0.0.1"
+
+# Datadir (where to store queue)
+DATADIR="/var/lib/beanstalkd"
+
+# Max job size
+JOB_SIZE="65536"
diff --git a/app-misc/beanstalkd/files/init-1.9 b/app-misc/beanstalkd/files/init-1.9
new file mode 100644
index 000000000000..d5cd06d856ef
--- /dev/null
+++ b/app-misc/beanstalkd/files/init-1.9
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of MIT
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beanstalkd/files/init-1.9,v 1.1 2014/03/31 06:34:28 patrick Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting beanstalkd"
+ /sbin/start-stop-daemon --start \
+ --background \
+ --pidfile ${PIDFILE} --make-pidfile \
+ --exec ${BEANSTALKD_BINARY} \
+ -- -b ${DATADIR} -p ${PORT} -l ${ADDR} -u ${USER} -z ${JOB_SIZE}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping beanstalkd"
+ start-stop-daemon --stop --quiet \
+ --pidfile ${PIDFILE} \
+ --exec ${BEANSTALKD_BINARY}
+ eend $?
+}