summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-17 05:53:38 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-17 05:53:38 +0000
commit5e187cc439de115d4eaf79e35080045cf19ae48d (patch)
tree48483847c7cae6e384ebab2b7c6f594c7357ff85 /app-misc
parentversion bump (diff)
downloadgentoo-2-5e187cc439de115d4eaf79e35080045cf19ae48d.tar.gz
gentoo-2-5e187cc439de115d4eaf79e35080045cf19ae48d.tar.bz2
gentoo-2-5e187cc439de115d4eaf79e35080045cf19ae48d.zip
Bump
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/anki/ChangeLog7
-rw-r--r--app-misc/anki/anki-2.0.8.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/app-misc/anki/ChangeLog b/app-misc/anki/ChangeLog
index 33f39209af7a..742b8b2833ff 100644
--- a/app-misc/anki/ChangeLog
+++ b/app-misc/anki/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/anki
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.52 2013/02/06 08:52:06 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/ChangeLog,v 1.53 2013/02/17 05:53:38 patrick Exp $
+
+*anki-2.0.8 (17 Feb 2013)
+
+ 17 Feb 2013; Patrick Lauer <patrick@gentoo.org> +anki-2.0.8.ebuild:
+ Bump
*anki-2.0.7 (06 Feb 2013)
diff --git a/app-misc/anki/anki-2.0.8.ebuild b/app-misc/anki/anki-2.0.8.ebuild
new file mode 100644
index 000000000000..6bcd89d09ac4
--- /dev/null
+++ b/app-misc/anki/anki-2.0.8.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/anki/anki-2.0.8.ebuild,v 1.1 2013/02/17 05:53:38 patrick Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="sqlite"
+
+inherit eutils python
+
+DESCRIPTION="A spaced-repetition memory training program (flash cards)"
+HOMEPAGE="http://ichi2.net/anki/"
+SRC_URI="http://ankisrs.net/download/mirror/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="latex +recording +sound"
+
+RDEPEND="dev-python/PyQt4[X,svg,webkit]
+ >=dev-python/httplib2-0.7.4
+ dev-python/beautifulsoup:python-2
+ recording? ( media-sound/lame
+ >=dev-python/pyaudio-0.2.4 )
+ sound? ( media-video/mplayer )
+ latex? ( app-text/texlive
+ app-text/dvipng )"
+DEPEND=""
+
+pkg_setup(){
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ rm -r thirdparty || die
+ python_convert_shebangs -r 2 .
+}
+
+# Nothing to configure or compile
+src_configure() {
+ true;
+}
+
+src_compile() {
+ true;
+}
+
+src_install() {
+ exeinto /usr/bin/
+ doexe anki/anki
+
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ doman ${PN}.1
+
+ dodoc README README.development
+ insinto "$(python_get_sitedir)"
+ doins -r aqt anki
+}
+
+pkg_preinst() {
+ if has_version "<app-misc/anki-2" ; then
+ elog "Anki 2 is a rewrite of Anki with many new features and"
+ elog "a new database format. On the first run your decks are"
+ elog "converted to the new format and a backup of your Anki-1"
+ elog "decks is created. Please read the following:"
+ elog "http://ankisrs.net/anki2.html"
+ elog "The mobile clients for Anki 2 are still under development."
+ fi
+}