summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-11-15 11:00:22 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-11-15 11:00:22 +0000
commit74acc441479365491ca163c1d136a5169ae42206 (patch)
treee6a1500fe6cd4893b6ed1cfe9c351ebec306b0cc /app-misc
parentPunt revisions using old eclasses. (diff)
downloadgentoo-2-74acc441479365491ca163c1d136a5169ae42206.tar.gz
gentoo-2-74acc441479365491ca163c1d136a5169ae42206.tar.bz2
gentoo-2-74acc441479365491ca163c1d136a5169ae42206.zip
Adding bash 3.2 compatibility patch from bug #153925 thanks to mehmetkemal@gmx.net
(Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/mc/ChangeLog9
-rw-r--r--app-misc/mc/files/digest-mc-4.6.1-r39
-rw-r--r--app-misc/mc/files/mc-4.6.1-bash-all.patch33
-rw-r--r--app-misc/mc/mc-4.6.1-r3.ebuild147
4 files changed, 197 insertions, 1 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index 0cbfd98c7393..23827a8fc3b5 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/mc
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.110 2006/10/06 15:58:59 exg Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.111 2006/11/15 11:00:22 jokey Exp $
+
+*mc-4.6.1-r3 (15 Nov 2006)
+
+ 15 Nov 2006; Markus Ullmann <jokey@gentoo.org>
+ +files/mc-4.6.1-bash-all.patch, +mc-4.6.1-r3.ebuild:
+ Adding bash 3.2 compatibility patch from bug #153925 thanks to
+ mehmetkemal@gmx.net
06 Oct 2006; Emanuele Giaquinta <exg@gentoo.org> -mc-4.6.1-r1.ebuild,
mc-4.6.1-r2.ebuild:
diff --git a/app-misc/mc/files/digest-mc-4.6.1-r3 b/app-misc/mc/files/digest-mc-4.6.1-r3
new file mode 100644
index 000000000000..baa6422df472
--- /dev/null
+++ b/app-misc/mc/files/digest-mc-4.6.1-r3
@@ -0,0 +1,9 @@
+MD5 6d7be5691380d03be44829e78a04e68a mc-4.6.1-utf8-r1.patch.bz2 30427
+RMD160 43f246e3bce44e526fb8d69c095afce34d73d64d mc-4.6.1-utf8-r1.patch.bz2 30427
+SHA256 19c8728220ec52849daded5d58eddbd712a2ccc84b11aed41c3916248545df44 mc-4.6.1-utf8-r1.patch.bz2 30427
+MD5 18b20db6e40480a53bac2870c56fc3c4 mc-4.6.1.tar.gz 3928370
+RMD160 d565ee95a8916d73fad5e0defeb9f2f57e50962b mc-4.6.1.tar.gz 3928370
+SHA256 086ab03daaac28a28c0ddb9a709040b59e1322f6bfa68e39d004d9c66b119e7e mc-4.6.1.tar.gz 3928370
+MD5 d63ffd21654bfa965b5c19b845cb7b34 u7z-4.29.tar.bz2 2951
+RMD160 1ab0cfea1563e81bdde9c0552d37efe710ea14bf u7z-4.29.tar.bz2 2951
+SHA256 0d046e76fade7c7e31be01626bb3fcb0afcb5f62809733d0c70e0e12c655348d u7z-4.29.tar.bz2 2951
diff --git a/app-misc/mc/files/mc-4.6.1-bash-all.patch b/app-misc/mc/files/mc-4.6.1-bash-all.patch
new file mode 100644
index 000000000000..e3e2afc344ca
--- /dev/null
+++ b/app-misc/mc/files/mc-4.6.1-bash-all.patch
@@ -0,0 +1,33 @@
+--- /src/subshell.c.000 2006-05-08 23:11:48.000000000 +0200
++++ /src/subshell.c 2006-10-28 15:40:46.000000000 +0200
+@@ -745,29 +745,13 @@ subshell_name_quote (const char *s)
+ memcpy (d, cmd_start, len);
+ d += len;
+
+- /*
+- * Print every character in octal format with the leading backslash.
+- * tcsh and zsh may require 4-digit octals, bash < 2.05b doesn't like them.
+- */
+- if (subshell_type == BASH) {
+ for (; *s; s++) {
+- /* Must quote numbers, so that they are not glued to octals */
+ if (isalpha ((unsigned char) *s)) {
+ *d++ = (unsigned char) *s;
+ } else {
+- sprintf (d, "\\%03o", (unsigned char) *s);
+- d += 4;
+- }
+- }
+- } else {
+- for (; *s; s++) {
+- if (isalnum ((unsigned char) *s)) {
+- *d++ = (unsigned char) *s;
+- } else {
+ sprintf (d, "\\0%03o", (unsigned char) *s);
+ d += 5;
+ }
+- }
+ }
+
+ memcpy (d, common_end, sizeof (common_end));
+
diff --git a/app-misc/mc/mc-4.6.1-r3.ebuild b/app-misc/mc/mc-4.6.1-r3.ebuild
new file mode 100644
index 000000000000..6c37e2114a65
--- /dev/null
+++ b/app-misc/mc/mc-4.6.1-r3.ebuild
@@ -0,0 +1,147 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.1-r3.ebuild,v 1.1 2006/11/15 11:00:22 jokey Exp $
+
+inherit flag-o-matic eutils
+
+U7Z_PV="4.29"
+U7Z="u7z-${U7Z_PV}.tar.bz2"
+DESCRIPTION="GNU Midnight Commander cli-based file manager"
+HOMEPAGE="http://www.ibiblio.org/mc/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/file/managers/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-utf8-r1.patch.bz2
+ 7zip? ( http://sgh-punk.narod.ru/files/u7z/${U7Z} )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="7zip X gpm ncurses nls pam samba slang unicode"
+
+PROVIDE="virtual/editor"
+
+RDEPEND="kernel_linux? ( >=sys-fs/e2fsprogs-1.19 )
+ ncurses? ( >=sys-libs/ncurses-5.2-r5 )
+ =dev-libs/glib-2*
+ pam? ( >=sys-libs/pam-0.72 )
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ slang? ( ~sys-libs/slang-1.4.9 )
+ samba? ( >=net-fs/samba-3.0.0 )
+ X? ( || ( (
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libSM
+ )
+ virtual/x11
+ )
+ )
+ x86? ( 7zip? ( >=app-arch/p7zip-4.16 ) )
+ ppc? ( 7zip? ( >=app-arch/p7zip-4.16 ) )
+ amd64? ( 7zip? ( >=app-arch/p7zip-4.16 ) )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ if ( use x86 || use amd64 || use ppc ) && use 7zip; then
+ unpack ${U7Z}
+ fi
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-find.patch
+ if ( use x86 || use amd64 || use ppc ) && use 7zip; then
+ epatch ${FILESDIR}/${PN}-4.6.0-7zip.patch
+ fi
+ epatch ${FILESDIR}/${P}-largefile.patch
+ if use slang && use unicode; then
+ epatch ${DISTDIR}/${P}-utf8-r1.patch.bz2
+ fi
+ epatch ${FILESDIR}/${P}-nonblock.patch
+ epatch ${FILESDIR}/${P}-bash-all.patch
+
+ # Prevent lazy bindings in cons.saver binary. (bug #135009)
+ # - not using bindnow-flags() because cons.saver is only built on GNU/Linux
+ sed -i -e "s:^\(cons_saver_LDADD = .*\):\1 -Wl,-z,now:" \
+ src/Makefile.in
+}
+
+src_compile() {
+ append-flags -I/usr/include/gssapi
+
+ filter-flags -malign-double
+
+ local myconf=""
+
+ if ! use slang && ! use ncurses ; then
+ myconf="${myconf} --with-screen=mcslang"
+ elif use ncurses && ! use slang ; then
+ myconf="${myconf} --with-screen=ncurses"
+ else
+ use slang && myconf="${myconf} --with-screen=slang"
+ fi
+
+ myconf="${myconf} `use_with gpm gpm-mouse`"
+
+ use nls \
+ && myconf="${myconf} --with-included-gettext" \
+ || myconf="${myconf} --disable-nls"
+
+ myconf="${myconf} `use_with X x`"
+
+ use samba \
+ && myconf="${myconf} --with-samba --with-configdir=/etc/samba --with-codepagedir=/var/lib/samba/codepages --with-privatedir=/etc/samba/private" \
+ || myconf="${myconf} --without-samba"
+
+ econf \
+ --with-vfs \
+ --with-ext2undel \
+ --with-edit \
+ --enable-charset \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ cat ${FILESDIR}/chdir-4.6.0.gentoo >>\
+ ${S}/lib/mc-wrapper.sh
+
+ make install DESTDIR="${D}" || die
+
+ # install cons.saver setuid, to actually work
+ chmod u+s ${D}/usr/lib/mc/cons.saver
+
+ dodoc ChangeLog AUTHORS MAINTAINERS FAQ INSTALL* NEWS README*
+
+ insinto /usr/share/mc
+ doins ${FILESDIR}/mc.gentoo
+ doins ${FILESDIR}/mc.ini
+
+ if ( use x86 || use amd64 || use ppc ) && use 7zip; then
+ cd ../${U7Z_PV}
+ exeinto /usr/share/mc/extfs
+ doexe u7z
+ dodoc readme.u7z
+ newdoc ChangeLog ChangeLog.u7z
+ fi
+
+ insinto /usr/share/mc/syntax
+ doins ${FILESDIR}/ebuild.syntax
+ cd ${D}/usr/share/mc/syntax
+ epatch ${FILESDIR}/${PN}-4.6.0-ebuild-syntax.patch
+
+ # http://bugs.gentoo.org/show_bug.cgi?id=71275
+ rm -f ${D}/usr/share/locale/locale.alias
+}
+
+pkg_postinst() {
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "allow mc to chdir to its latest working dir at exit"
+ einfo ""
+ einfo "# Midnight Commander chdir enhancement"
+ einfo "if [ -f /usr/share/mc/mc.gentoo ]; then"
+ einfo " . /usr/share/mc/mc.gentoo"
+ einfo "fi"
+}