summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-01 05:33:31 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-01 05:33:31 +0000
commit7887da70cfc373b3771525cfadd0174ba4b7976e (patch)
tree2ae5826ef590c9ab82510f397c25321a5a68d683 /app-misc
parentinitial ebuild #48508 (diff)
downloadgentoo-2-7887da70cfc373b3771525cfadd0174ba4b7976e.tar.gz
gentoo-2-7887da70cfc373b3771525cfadd0174ba4b7976e.tar.bz2
gentoo-2-7887da70cfc373b3771525cfadd0174ba4b7976e.zip
Version bump #52590 by Redeeman.
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/twin/ChangeLog7
-rw-r--r--app-misc/twin/files/digest-twin-0.4.61
-rw-r--r--app-misc/twin/twin-0.4.6.ebuild85
3 files changed, 92 insertions, 1 deletions
diff --git a/app-misc/twin/ChangeLog b/app-misc/twin/ChangeLog
index 064d6b033b7a..2d1ffaa65753 100644
--- a/app-misc/twin/ChangeLog
+++ b/app-misc/twin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/twin
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/twin/ChangeLog,v 1.11 2004/02/17 23:00:34 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/twin/ChangeLog,v 1.12 2004/06/01 05:33:31 vapier Exp $
+
+*twin-0.4.6 (01 Jun 2004)
+
+ 01 Jun 2004; Mike Frysinger <vapier@gentoo.org> +twin-0.4.6.ebuild:
+ Version bump #52590 by Redeeman.
17 Feb 2004; Aron Griffis <agriffis@gentoo.org> twin-0.3.8-r1.ebuild,
twin-0.4.4.ebuild, twin-0.4.5.ebuild:
diff --git a/app-misc/twin/files/digest-twin-0.4.6 b/app-misc/twin/files/digest-twin-0.4.6
new file mode 100644
index 000000000000..209e52fd1bef
--- /dev/null
+++ b/app-misc/twin/files/digest-twin-0.4.6
@@ -0,0 +1 @@
+MD5 92429bb5550a4c231085585a3473bf4d twin-0.4.6.tar.gz 1139714
diff --git a/app-misc/twin/twin-0.4.6.ebuild b/app-misc/twin/twin-0.4.6.ebuild
new file mode 100644
index 000000000000..af4b0c7a7f9b
--- /dev/null
+++ b/app-misc/twin/twin-0.4.6.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/twin/twin-0.4.6.ebuild,v 1.1 2004/06/01 05:33:31 vapier Exp $
+
+inherit fixheadtails
+
+DESCRIPTION="A text-mode window environment"
+HOMEPAGE="http://twin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/twin/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64"
+IUSE="X gtk ggi gpm"
+
+DEPEND="X? ( virtual/x11 )
+ ggi? ( >=media-libs/libggi-1.9 )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ >=sys-libs/ncurses-5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ ht_fix_file configure
+}
+
+src_compile() {
+ local myconf
+
+ use X \
+ && myconf="--with-x --enable-hw-x11=yes"
+ use ggi \
+ && myconf="${myconf} --enable-hw-ggi=yes" \
+ || myconf="${myconf} --enable-hw-ggi=no"
+ use gtk \
+ && myconf="${myconf} --enable-tt-hw-gtk=yes" \
+ || myconf="${myconf} --enable-tt-hw-gtk=no"
+ use gpm \
+ && myconf="${myconf} --enable-hw-tty-linux=yes" \
+ || myconf="${myconf} --enable-hw-tty-linux=no"
+ econf \
+ --enable-shlibs=yes \
+ --enable-modules=yes \
+ --enable-unicode=yes \
+ --enable-socket=yes \
+ --enable-socket-gz=yes \
+ --enable-socket-pthreads=yes \
+ --enable-socket-alien=yes \
+ --enable-h2-tty-termcap=yes \
+ --enable-term=yes \
+ ${myconf} \
+ || die
+ emake -j1 || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+
+ if use X ; then
+ insinto /usr/X11R6/lib/X11/fonts/misc
+ doins fonts/vga.pcf.gz
+ fi
+
+ rm -rf ${D}/usr/share/twin/{BUGS,docs,COP*,READ*,Change*,INSTALL*}
+
+ dodoc BUGS COPYING* Change* README* TODO/TODO TODO/twin-thoughts
+ doman docs/twin.1; rm -rf docs/twin.1
+ dodoc docs/*
+
+}
+
+pkg_postinst() {
+ if use X ; then
+ /usr/X11R6/bin/mkfontdir /usr/X11R6/lib/X11/fonts/misc
+ /usr/X11R6/bin/xset fp rehash
+ fi
+}
+
+pkg_postrm() {
+ if use X ; then
+ /usr/X11R6/bin/mkfontdir /usr/X11R6/lib/X11/fonts/misc
+ /usr/X11R6/bin/xset fp rehash
+ fi
+}