summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-05 14:54:42 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-05 14:54:42 +0000
commit8239755bf26e9fdef3df608ee3d41151b939c029 (patch)
tree22f5b50d1c4773e0a8280119f0b374a38085261c /app-misc
parentAdd github to remote-id in metadata.xml (diff)
downloadgentoo-2-8239755bf26e9fdef3df608ee3d41151b939c029.tar.gz
gentoo-2-8239755bf26e9fdef3df608ee3d41151b939c029.tar.bz2
gentoo-2-8239755bf26e9fdef3df608ee3d41151b939c029.zip
Bump to EAPI=5; import fedora patches, bug #521088
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/fsniper/ChangeLog9
-rw-r--r--app-misc/fsniper/files/fsniper-1.3.1-format-security.patch26
-rw-r--r--app-misc/fsniper/files/fsniper-1.3.1-umask.patch18
-rw-r--r--app-misc/fsniper/fsniper-1.3.1-r1.ebuild26
4 files changed, 78 insertions, 1 deletions
diff --git a/app-misc/fsniper/ChangeLog b/app-misc/fsniper/ChangeLog
index e2bc4e652723..0e18f4067b8c 100644
--- a/app-misc/fsniper/ChangeLog
+++ b/app-misc/fsniper/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/fsniper
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/fsniper/ChangeLog,v 1.9 2015/06/05 14:48:12 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fsniper/ChangeLog,v 1.10 2015/06/05 14:54:42 jlec Exp $
+
+*fsniper-1.3.1-r1 (05 Jun 2015)
+
+ 05 Jun 2015; Justin Lecher <jlec@gentoo.org>
+ +files/fsniper-1.3.1-format-security.patch, +files/fsniper-1.3.1-umask.patch,
+ +fsniper-1.3.1-r1.ebuild:
+ Bump to EAPI=5; import fedora patches, bug #521088
05 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/app-misc/fsniper/files/fsniper-1.3.1-format-security.patch b/app-misc/fsniper/files/fsniper-1.3.1-format-security.patch
new file mode 100644
index 000000000000..70c9460f97d2
--- /dev/null
+++ b/app-misc/fsniper/files/fsniper-1.3.1-format-security.patch
@@ -0,0 +1,26 @@
+From d15abeb19d1692698e0ec8a9f4a764a210e57a2b Mon Sep 17 00:00:00 2001
+From: Jakub Hrozek <jhrozek@redhat.com>
+Date: Tue, 3 Dec 2013 10:50:29 +0100
+Subject: [PATCH] Fix an error message
+
+This patch fixes https://bugzilla.redhat.com/show_bug.cgi?id=1037073
+---
+ src/handle_event.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/handle_event.c b/src/handle_event.c
+index 22f35f10ea3a6083c2ef933f794b529b8879a1ed..cac004b76917c192ad9bf8801062d701e4dc18c6 100644
+--- a/src/handle_event.c
++++ b/src/handle_event.c
+@@ -313,7 +313,7 @@ void handle_event(struct inotify_event* event, int writefd)
+ if (sysret == 127)
+ {
+ temp = malloc(27 + strlen(handler->value) + 20 + 1);
+- sprintf("Could not execute handler \"%s\", trying next one.\n", handler->value);
++ sprintf(temp, "Could not execute handler \"%s\", trying next one.\n", handler->value);
+ write_out(writefd, temp);
+
+ free(temp);
+--
+1.8.4.2
+
diff --git a/app-misc/fsniper/files/fsniper-1.3.1-umask.patch b/app-misc/fsniper/files/fsniper-1.3.1-umask.patch
new file mode 100644
index 000000000000..39aecaa3e0d1
--- /dev/null
+++ b/app-misc/fsniper/files/fsniper-1.3.1-umask.patch
@@ -0,0 +1,18 @@
+X-Git-Url: http://code.l3ib.org/?p=fsniper.git;a=blobdiff_plain;f=src%2Fmain.c;fp=src%2Fmain.c;h=cd49dffebe4b4c728b62c28c1381c4fb6f5ad87d;hp=03a8d701d6f9802ba346b591429e58741ca53479;hb=82cb0b46c48485fd4f6231ce3169c7be87d1ea07;hpb=2bbeb5d6e6b55bb9692c043fcdbeab15d9723c9e
+
+diff --git a/src/main.c b/src/main.c
+index 03a8d70..cd49dff 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -153,7 +153,10 @@ char *get_pid_filename()
+ void write_pid_file(char *pidfilename)
+ {
+ FILE *pidfile;
++ mode_t umask_old;
++ umask_old = umask(0177);
+ pidfile = fopen(pidfilename, "w");
++ umask(umask_old);
+ fprintf(pidfile, "%d", getpid());
+ fclose(pidfile);
+ }
+
diff --git a/app-misc/fsniper/fsniper-1.3.1-r1.ebuild b/app-misc/fsniper/fsniper-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..113b9fedeac0
--- /dev/null
+++ b/app-misc/fsniper/fsniper-1.3.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/fsniper/fsniper-1.3.1-r1.ebuild,v 1.1 2015/06/05 14:54:42 jlec Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Tool that monitors a given set of directories for new files"
+HOMEPAGE="https://github.com/l3ib/fsniper/"
+SRC_URI="http://projects.l3ib.org/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libpcre
+ sys-apps/file"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-umask.patch
+)