summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2010-03-21 20:59:38 +0000
committerSerkan Kaba <serkan@gentoo.org>2010-03-21 20:59:38 +0000
commitd7efd146af9fa1d12e3dbcd7fb34d6e793bf3511 (patch)
treeb05266498e31772fcbfd63a9aeb137cd07c2e6f5 /app-mobilephone/anyremote
parentSign Manifest (diff)
downloadgentoo-2-d7efd146af9fa1d12e3dbcd7fb34d6e793bf3511.tar.gz
gentoo-2-d7efd146af9fa1d12e3dbcd7fb34d6e793bf3511.tar.bz2
gentoo-2-d7efd146af9fa1d12e3dbcd7fb34d6e793bf3511.zip
Version bump. Remove old. Change herd and category.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'app-mobilephone/anyremote')
-rw-r--r--app-mobilephone/anyremote/ChangeLog45
-rw-r--r--app-mobilephone/anyremote/anyremote-5.1.1.ebuild38
-rw-r--r--app-mobilephone/anyremote/anyremote-5.1.2.ebuild38
-rw-r--r--app-mobilephone/anyremote/metadata.xml10
4 files changed, 131 insertions, 0 deletions
diff --git a/app-mobilephone/anyremote/ChangeLog b/app-mobilephone/anyremote/ChangeLog
new file mode 100644
index 000000000000..6a5f634ea863
--- /dev/null
+++ b/app-mobilephone/anyremote/ChangeLog
@@ -0,0 +1,45 @@
+# ChangeLog for app-mobilephone/anyremote
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/anyremote/ChangeLog,v 1.1 2010/03/21 20:59:38 serkan Exp $
+
+*anyremote-5.1.2 (21 Mar 2010)
+
+ 21 Mar 2010; <firari@gentoo.org> +anyremote-5.1.1.ebuild,
+ +anyremote-5.1.2.ebuild, +metadata.xml:
+ Version bump. Remove old. Change herd and category.
+
+*anyremote-5.1.1 (19 Feb 2010)
+
+ 19 Feb 2010; Serkan Kaba <serkan@gentoo.org> +anyremote-5.1.1.ebuild,
+ metadata.xml:
+ Version bump. Take over the package.
+
+*anyremote-5.1 (11 Jan 2010)
+
+ 11 Jan 2010; Markos Chandras <hwoarang@gentoo.org> +anyremote-5.1.ebuild:
+ version bump. Fixes bug #300478
+
+*anyremote-5.0-r1 (26 Dec 2009)
+
+ 26 Dec 2009; Markos Chandras <hwoarang@gentoo.org> -anyremote-5.0.ebuild,
+ +anyremote-5.0-r1.ebuild:
+ Fixed documentation path wrt bug #298317
+
+*anyremote-5.0 (15 Oct 2009)
+
+ 15 Oct 2009; Markos Chandras <hwoarang@gentoo.org> +anyremote-5.0.ebuild:
+ Version bump ( fixes bug #289052 )
+
+ 26 Jul 2009; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
+ Add net-p2p herd on metadata.xml. Fixes bug 279158
+
+ 12 May 2009; Peter Alfredsen <loki_val@gentoo.org>
+ anyremote-4.18.1.ebuild:
+ List net-wireless/bluez first in ( a b ) dependency w.r.t. bug 269519.
+
+*anyremote-4.18.1 (21 Apr 2009)
+
+ 21 Apr 2009; Markos Chandras <hwoarang@gentoo.org> +metadata.xml,
+ +anyremote-4.18.1.ebuild:
+ Initial commit of anyremote program. Fixes bug #209686
+
diff --git a/app-mobilephone/anyremote/anyremote-5.1.1.ebuild b/app-mobilephone/anyremote/anyremote-5.1.1.ebuild
new file mode 100644
index 000000000000..47da4392cb0a
--- /dev/null
+++ b/app-mobilephone/anyremote/anyremote-5.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/anyremote/anyremote-5.1.1.ebuild,v 1.1 2010/03/21 20:59:38 serkan Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="Anyremote provides wireless bluetooth, infrared or cable remote control service"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth dbus"
+
+RDEPEND="bluetooth? ( || ( net-wireless/bluez ( net-wireless/bluez-libs net-wireless/bluez-utils ) ) )
+ dbus? ( sys-apps/dbus )
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ #workaround to badly broken autotools scripts by upstream
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am \
+ || die "failed to fix documentation path"
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${PF}/" $(use_enable bluetooth) $(use_enable dbus)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "install doc failed"
+}
diff --git a/app-mobilephone/anyremote/anyremote-5.1.2.ebuild b/app-mobilephone/anyremote/anyremote-5.1.2.ebuild
new file mode 100644
index 000000000000..aa135ec2de07
--- /dev/null
+++ b/app-mobilephone/anyremote/anyremote-5.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/anyremote/anyremote-5.1.2.ebuild,v 1.1 2010/03/21 20:59:38 serkan Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="Anyremote provides wireless bluetooth, infrared or cable remote control service"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth dbus"
+
+RDEPEND="bluetooth? ( || ( net-wireless/bluez ( net-wireless/bluez-libs net-wireless/bluez-utils ) ) )
+ dbus? ( sys-apps/dbus )
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ #workaround to badly broken autotools scripts by upstream
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am \
+ || die "failed to fix documentation path"
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${PF}/" $(use_enable bluetooth) $(use_enable dbus)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "install doc failed"
+}
diff --git a/app-mobilephone/anyremote/metadata.xml b/app-mobilephone/anyremote/metadata.xml
new file mode 100644
index 000000000000..b5f4ebcc7992
--- /dev/null
+++ b/app-mobilephone/anyremote/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>mobile-phone</herd>
+<maintainer>
+<email>serkan@gentoo.org</email>
+<name>Serkan Kaba</name>
+</maintainer>
+</pkgmetadata>
+