summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-11-08 10:06:04 +0000
committerAlin Năstac <mrness@gentoo.org>2006-11-08 10:06:04 +0000
commit29d9d889e4aeff0d90be3bfe6a54fc33d8265394 (patch)
treecd9278bdc5072075f703cb97007b09411be21623 /app-mobilephone
parentadded a '+' to the DESCRIPTION (diff)
downloadgentoo-2-29d9d889e4aeff0d90be3bfe6a54fc33d8265394.tar.gz
gentoo-2-29d9d889e4aeff0d90be3bfe6a54fc33d8265394.tar.bz2
gentoo-2-29d9d889e4aeff0d90be3bfe6a54fc33d8265394.zip
Remove obsolete version. Fix improper processing of the command line arguments (#154078).
(Portage version: 2.1.1-r1)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/bitpim/ChangeLog10
-rw-r--r--app-mobilephone/bitpim/bitpim-0.9.07-r1.ebuild163
-rw-r--r--app-mobilephone/bitpim/files/bitpim-0.9.07-gentoo.patch28
-rw-r--r--app-mobilephone/bitpim/files/digest-bitpim-0.9.07-r13
4 files changed, 195 insertions, 9 deletions
diff --git a/app-mobilephone/bitpim/ChangeLog b/app-mobilephone/bitpim/ChangeLog
index 7abc93c739bf..dbe26849382f 100644
--- a/app-mobilephone/bitpim/ChangeLog
+++ b/app-mobilephone/bitpim/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-mobilephone/bitpim
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/ChangeLog,v 1.14 2006/09/15 15:51:44 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/ChangeLog,v 1.15 2006/11/08 10:06:04 mrness Exp $
+
+*bitpim-0.9.07-r1 (08 Nov 2006)
+
+ 08 Nov 2006; Alin Nastac <mrness@gentoo.org>
+ -files/bitpim-0.9.00-gentoo.patch, files/bitpim-0.9.07-gentoo.patch,
+ -bitpim-0.9.00.ebuild, -bitpim-0.9.07.ebuild, +bitpim-0.9.07-r1.ebuild:
+ Remove obsolete version. Fix improper processing of the command line
+ arguments (#154078).
*bitpim-0.9.07 (15 Sep 2006)
diff --git a/app-mobilephone/bitpim/bitpim-0.9.07-r1.ebuild b/app-mobilephone/bitpim/bitpim-0.9.07-r1.ebuild
new file mode 100644
index 000000000000..38acb8e745d1
--- /dev/null
+++ b/app-mobilephone/bitpim/bitpim-0.9.07-r1.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/bitpim-0.9.07-r1.ebuild,v 1.1 2006/11/08 10:06:04 mrness Exp $
+
+inherit distutils
+
+DESCRIPTION="This program allows you to view and manipulate data on LG VX4400/VX6000 and many Sanyo Sprint mobile phones"
+HOMEPAGE="http://www.bitpim.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt usb evo"
+
+DEPEND=">=dev-python/wxpython-2.6.3.2
+ >=dev-python/apsw-3
+ >=dev-python/python-dsv-1.4.0
+ >=dev-python/pyserial-2.0
+ crypt? ( >=dev-python/paramiko-1.5.4 )
+ usb? ( >=dev-lang/swig-1.3.21 >=dev-libs/libusb-0.1.10a )"
+RDEPEND="${DEPEND}
+ media-video/ffmpeg
+ media-libs/netpbm"
+
+#For Gentoo devs only: uncomment this line when you want to make the tarball
+#then COMMENT IT BACK!
+#pkg_setup() { maketarball; }
+maketarball() { #For building the tarball. To be used only by ebuild maintainers
+ local x svnrev
+ svnrev=$(svn log -q --limit 1 https://svn.sourceforge.net/svnroot/${PN}/releases/${PV} | sed -r '/^[^r]/d;s/^r([0-9]+) .*$/\1/')
+ [ $? = 0 ] || return 1
+
+ #Fetch the source (only those directories that are needed)
+ cd "${DISTDIR}" && mkdir ${P} || return 1
+ for x in resources packaging src ; do
+ svn export https://svn.sourceforge.net/svnroot/${PN}/releases/${PV}/${x} ${P}/${x} || return 1
+ done
+
+ #Remove unneeded stuff
+ rm ${P}/resources/*.chm ${P}/src/package.py
+
+ #Freeze version and set vendor name to Gentoo
+ sed -i -e 's/\(^__FROZEN__="[$]Id: \).*\( $"\)/\1'${svnrev}'\2/' \
+ -e 's/^vendor=".*"/vendor="Gentoo"/' \
+ ${P}/src/version.py || return 1
+
+ #Make the tarball
+ tar -cjf ${P}.tar.bz2 ${P}
+ rm -r ${P}
+}
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ sed -i "s/python2.3/${python}/" "${S}/src/native/usb/build.sh"
+}
+
+src_compile() {
+ # USB stuff
+ if use usb; then
+ cd "${S}/src/native/usb" || die "compilation of native/usb failed"
+ sh ./build.sh
+ fi
+
+ # strings
+ cd "${S}/src/native/strings"
+ ${python} setup.py build || die "compilation of native/strings failed"
+
+ # bmp2avi
+ cd "${S}/src/native/av/bmp2avi"
+ PLATFORM=linux make || die "compilation of native/bmp2avi failed"
+}
+
+src_install() {
+ cd "${S}"
+
+ # Install files into right place
+ #
+ # BitPim is a self-contained app, so jamming it into
+ # Python's site-packages might not be worthwhile. We'll
+ # Put it in its own home, and add the PYTHONPATH in the
+ # wrapper executables below.
+ distutils_python_version
+ local RLOC=/usr/lib/${P}
+
+ # Main Python source
+ insinto ${RLOC}
+ doins src/*.py
+
+ # Phone specifics
+ insinto ${RLOC}/phones
+ doins src/phones/*.py
+
+ # Native products
+ insinto ${RLOC}/native
+ doins src/native/*.py
+ insinto ${RLOC}/native/qtopiadesktop
+ doins src/native/qtopiadesktop/*.py
+ insinto ${RLOC}/native/outlook
+ doins src/native/outlook/*.py
+ insinto ${RLOC}/native/egroupware
+ doins src/native/egroupware/*.py
+ if use evo ; then
+ insinto ${RLOC}/native/evolution
+ doins src/native/evolution/*.py
+ fi
+
+ # strings
+ cd "${S}/src/native/strings"
+ ${python} setup.py install --root="${D}" --no-compile "$@" || die "install of native/strings failed"
+ cd "${S}"
+ insinto $RLOC/native/strings
+ doins src/native/strings/__init__.py src/native/strings/jarowpy.py
+
+ # usb
+ if use usb; then
+ insinto ${RLOC}/native/usb
+ doins src/native/usb/*.py
+ doins src/native/usb/*.so
+ fi
+
+ # Helpers and resources
+ dobin src/native/av/bmp2avi/bmp2avi
+ insinto ${RLOC}/resources
+ doins resources/*
+
+ # Bitfling
+ if use crypt; then
+ FLINGDIR="${RLOC}/bitfling"
+ insinto $FLINGDIR
+ cd "${S}/src/bitfling"
+ doins *.py
+ cd "${S}"
+ fi
+
+ # Creating scripts
+ echo '#!/bin/sh' > "${T}/bitpim"
+ echo "exec python ${RLOC}/bp.py bitpim \"\$@\"" >> "${T}/bitpim"
+ dobin "${T}/bitpim"
+ if use crypt; then
+ echo '#!/bin/sh' > "${T}/bitfling"
+ echo "exec python ${RLOC}/bp.py bitfling \"\$@\"" >> "${T}/bitfling"
+ dobin "${T}/bitfling"
+ fi
+
+ # Desktop file
+ insinto /usr/share/applications
+ sed -i -e "s|%%INSTALLBINDIR%%|/usr/bin|" -e "s|%%INSTALLLIBDIR%%|${RLOC}|" \
+ packaging/bitpim.desktop
+ doins packaging/bitpim.desktop
+}
+
+pkg_postinst() {
+ # Optimize in installed directory
+ python_mod_optimize "${ROOT}/usr/lib/${P}"
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup "${ROOT}/usr/lib/${P}"
+}
diff --git a/app-mobilephone/bitpim/files/bitpim-0.9.07-gentoo.patch b/app-mobilephone/bitpim/files/bitpim-0.9.07-gentoo.patch
index 569b6b847e26..50a7c24eb82a 100644
--- a/app-mobilephone/bitpim/files/bitpim-0.9.07-gentoo.patch
+++ b/app-mobilephone/bitpim/files/bitpim-0.9.07-gentoo.patch
@@ -1,6 +1,18 @@
+diff -Nru bitpim-0.9.07.orig/src/bp.py bitpim-0.9.07/src/bp.py
+--- bitpim-0.9.07.orig/src/bp.py 2006-09-02 08:20:47.000000000 +0300
++++ bitpim-0.9.07/src/bp.py 2006-11-08 11:55:33.337514250 +0200
+@@ -52,7 +52,7 @@
+ if sys.platform=="darwin" and len(sys.argv)>1 and sys.argv[1].startswith("-psn_"):
+ # get rid of the process serial number on mac
+ sys.argv=sys.argv[:1]+sys.argv[2:]
+- _options, _args=getopt.getopt(sys.argv[1:], 'c:d:')
++ _options, _args=getopt.gnu_getopt(sys.argv[1:], 'c:d:')
+ _kwargs={}
+ # check for debug flag
+ _debug=__debug__ or bool(_args and 'debug' in _args)
diff -Nru bitpim-0.9.07.orig/src/common.py bitpim-0.9.07/src/common.py
---- bitpim-0.9.07.orig/src/common.py 2006-09-15 18:41:32.734807000 +0300
-+++ bitpim-0.9.07/src/common.py 2006-09-15 18:41:12.801561250 +0300
+--- bitpim-0.9.07.orig/src/common.py 2006-08-27 01:44:28.000000000 +0300
++++ bitpim-0.9.07/src/common.py 2006-11-08 11:55:08.355953000 +0200
@@ -854,4 +854,4 @@
# windows running from exe, return as is
return os.path.abspath(os.path.dirname(sys.executable))
@@ -8,8 +20,8 @@ diff -Nru bitpim-0.9.07.orig/src/common.py bitpim-0.9.07/src/common.py
- return os.path.split(os.path.abspath(os.path.dirname(sys.argv[0])))[0]
+ return os.path.abspath(os.path.dirname(sys.argv[0]))
diff -Nru bitpim-0.9.07.orig/src/conversions.py bitpim-0.9.07/src/conversions.py
---- bitpim-0.9.07.orig/src/conversions.py 2006-09-15 18:41:32.734807000 +0300
-+++ bitpim-0.9.07/src/conversions.py 2006-09-15 18:41:12.801561250 +0300
+--- bitpim-0.9.07.orig/src/conversions.py 2006-05-28 06:10:52.000000000 +0300
++++ bitpim-0.9.07/src/conversions.py 2006-11-08 11:55:08.355953000 +0200
@@ -20,11 +20,11 @@
class ConversionFailed(Exception): pass
@@ -42,8 +54,8 @@ diff -Nru bitpim-0.9.07.orig/src/conversions.py bitpim-0.9.07/src/conversions.py
pngtopnmbin=gethelperbinary('pngtopnm')
ppmquantbin=gethelperbinary('ppmquant')
diff -Nru bitpim-0.9.07.orig/src/native/av/bmp2avi/Makefile bitpim-0.9.07/src/native/av/bmp2avi/Makefile
---- bitpim-0.9.07.orig/src/native/av/bmp2avi/Makefile 2006-09-15 18:41:32.734807000 +0300
-+++ bitpim-0.9.07/src/native/av/bmp2avi/Makefile 2006-09-15 18:41:12.801561250 +0300
+--- bitpim-0.9.07.orig/src/native/av/bmp2avi/Makefile 2006-05-05 10:10:08.000000000 +0300
++++ bitpim-0.9.07/src/native/av/bmp2avi/Makefile 2006-11-08 11:55:08.355953000 +0200
@@ -13,6 +13,6 @@
SRC=avi_file.cxx bmp_file.cxx b2a.cxx
@@ -53,8 +65,8 @@ diff -Nru bitpim-0.9.07.orig/src/native/av/bmp2avi/Makefile bitpim-0.9.07/src/na
$(CXX) $(EXTRADEFINES) -O2 -o $@ $(SRC)
diff -Nru bitpim-0.9.07.orig/src/native/usb/build.sh bitpim-0.9.07/src/native/usb/build.sh
---- bitpim-0.9.07.orig/src/native/usb/build.sh 2006-09-15 18:41:12.000000000 +0300
-+++ bitpim-0.9.07/src/native/usb/build.sh 2006-09-15 18:42:03.296717000 +0300
+--- bitpim-0.9.07.orig/src/native/usb/build.sh 2006-03-04 06:57:24.000000000 +0200
++++ bitpim-0.9.07/src/native/usb/build.sh 2006-11-08 11:55:08.355953000 +0200
@@ -4,4 +4,4 @@
swig -python -I/usr/include libusb.i
diff --git a/app-mobilephone/bitpim/files/digest-bitpim-0.9.07-r1 b/app-mobilephone/bitpim/files/digest-bitpim-0.9.07-r1
new file mode 100644
index 000000000000..54dff5798fa1
--- /dev/null
+++ b/app-mobilephone/bitpim/files/digest-bitpim-0.9.07-r1
@@ -0,0 +1,3 @@
+MD5 cfe1cdeeb955582c746fd5c8ceb05ece bitpim-0.9.07.tar.bz2 3833224
+RMD160 fcee72015ada5623185e145f8b1703e29409c7fd bitpim-0.9.07.tar.bz2 3833224
+SHA256 159faac3ebb0685a30207b592c631b53ad83843a6a8103d5dca9d95a78e5f0df bitpim-0.9.07.tar.bz2 3833224