summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-05 00:15:55 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-05 00:15:55 +0000
commit38da2d3e2d02db2a822de415ff5ddcb223099db1 (patch)
tree06e089582b7615435dc1f1fa3dd446aff4723a7c /app-mobilephone
parentVersion bump (fixes bug #407243, patch by Matti Bickel). (diff)
downloadgentoo-2-38da2d3e2d02db2a822de415ff5ddcb223099db1.tar.gz
gentoo-2-38da2d3e2d02db2a822de415ff5ddcb223099db1.tar.bz2
gentoo-2-38da2d3e2d02db2a822de415ff5ddcb223099db1.zip
NMU: Update ebuild to work with ruby 1.9 only. Fixes bug #483096.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/obexftp/ChangeLog8
-rw-r--r--app-mobilephone/obexftp/files/obexftp-0.23-fix-ruby19.patch37
-rw-r--r--app-mobilephone/obexftp/obexftp-0.23-r2.ebuild106
3 files changed, 150 insertions, 1 deletions
diff --git a/app-mobilephone/obexftp/ChangeLog b/app-mobilephone/obexftp/ChangeLog
index 2de7845a2cb0..238a371d59ef 100644
--- a/app-mobilephone/obexftp/ChangeLog
+++ b/app-mobilephone/obexftp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-mobilephone/obexftp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/ChangeLog,v 1.64 2013/08/21 19:34:38 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/ChangeLog,v 1.65 2013/11/05 00:15:54 mrueg Exp $
+
+*obexftp-0.23-r2 (05 Nov 2013)
+
+ 05 Nov 2013; Manuel Rüger <mrueg@gentoo.org>
+ +files/obexftp-0.23-fix-ruby19.patch, +obexftp-0.23-r2.ebuild:
+ NMU: Update ebuild to work with ruby 1.9 only. Fixes bug #483096.
21 Aug 2013; Chris Reffett <creffett@gentoo.org> obexftp-0.23-r1.ebuild:
Update to distutils-r1. Fix bugs 312725 and 398113.
diff --git a/app-mobilephone/obexftp/files/obexftp-0.23-fix-ruby19.patch b/app-mobilephone/obexftp/files/obexftp-0.23-fix-ruby19.patch
new file mode 100644
index 000000000000..a2ed681125cd
--- /dev/null
+++ b/app-mobilephone/obexftp/files/obexftp-0.23-fix-ruby19.patch
@@ -0,0 +1,37 @@
+Replace functions removed with ruby 1.9
+See also http://dev.zuckschwerdt.org/openobex/ticket/49
+
+
+diff --git a/swig/charmap.i b/swig/charmap.i
+index e1f1fc1..b8e17de 100644
+--- a/swig/charmap.i
++++ b/swig/charmap.i
+@@ -89,8 +89,8 @@
+ $2 = PyString_Size($input);
+ #elif defined SWIGRUBY
+ /* VALUE str = StringValue($input); // perhaps better? */
+- $1 = STR2CSTR($input);
+- $2 = (int) RSTRING($input)->len;
++ $1 = StringValuePtr($input);
++ $2 = (int) RSTRING_LEN($input);
+ #elif defined SWIGTCL
+ $1 = Tcl_GetStringFromObj($input,&$2);
+ #else
+diff --git a/swig/ruby/ruby_wrap.c b/swig/ruby/ruby_wrap.c
+index 57e40bf..31b1a9d 100644
+--- a/swig/ruby/ruby_wrap.c
++++ b/swig/ruby/ruby_wrap.c
+@@ -2579,8 +2579,8 @@ _wrap_Client_put_data(int argc, VALUE *argv, VALUE self) {
+
+
+ /* VALUE str = StringValue(argv[0]); // perhaps better? */
+- arg2 = STR2CSTR(argv[0]);
+- arg3 = (int) RSTRING(argv[0])->len;
++ arg2 = StringValuePtr(argv[0]);
++ arg3 = (int) RSTRING_LEN(argv[0]);
+
+
+
+--
+1.8.4.2
+
diff --git a/app-mobilephone/obexftp/obexftp-0.23-r2.ebuild b/app-mobilephone/obexftp/obexftp-0.23-r2.ebuild
new file mode 100644
index 000000000000..1efa5c1b908f
--- /dev/null
+++ b/app-mobilephone/obexftp/obexftp-0.23-r2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/obexftp/obexftp-0.23-r2.ebuild,v 1.1 2013/11/05 00:15:54 mrueg Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+GENTOO_DEPEND_ON_PERL=no
+
+inherit distutils-r1 eutils perl-module flag-o-matic autotools
+
+DESCRIPTION="File transfer over OBEX for mobile phones"
+HOMEPAGE="http://dev.zuckschwerdt.org/openobex/wiki/ObexFtp"
+SRC_URI="mirror://sourceforge/openobex/${P}.tar.bz2"
+SLOT="0"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="bluetooth debug perl python ruby tcl"
+
+RDEPEND="dev-libs/openobex
+ bluetooth? ( net-wireless/bluez )
+ perl? ( dev-lang/perl )
+ ruby? ( dev-lang/ruby:1.9 )
+ tcl? ( dev-lang/tcl )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fixruby.patch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-fix-ruby19.patch
+ # Python bindings are built/installed manually.
+ sed -e "/MAYBE_PYTHON_ = python/d" -i swig/Makefile.am || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ if use debug ; then
+ strip-flags
+ append-flags "-g -DOBEXFTP_DEBUG=5"
+ fi
+
+ local MYRUBY
+ use ruby && MYRUBY="RUBY=/usr/bin/ruby19"
+
+ econf \
+ $(use_enable bluetooth) \
+ $(use_enable perl) \
+ $(use_enable python) \
+ $(use_enable tcl) \
+ $(use_enable ruby) \
+ ${MYRUBY}
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ pushd swig/python/
+ distutils-r1_src_compile
+ popd
+ fi
+}
+
+src_install() {
+ # -j1 because "make -fMakefile.ruby install" fails
+ # upstream added -j1 to that command so it should be removed
+ # from here in the next version bump
+ emake -j1 DESTDIR="${D}" INSTALLDIRS=vendor install
+
+ if use python; then
+ pushd swig/python/
+ distutils-r1_src_install
+ popd
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
+ dohtml doc/*.html
+
+ # Install examples
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ use perl && doins examples/*.pl
+ use python && doins examples/*.py
+ use ruby && doins examples/*.rb
+ use tcl && doins examples/*.tcl
+
+ if use perl ; then
+ perl_delete_localpod
+ perl_delete_packlist
+ fi
+}
+
+pkg_postinst() {
+ use perl && perl-module_pkg_postinst
+ use python && distutils-r1_pkg_postinst
+}
+
+pkg_postrm() {
+ use perl && perl-module_pkg_postrm
+ use python && distutils-r1_pkg_postrm
+}