summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-12-20 03:55:59 +0000
committerHanno Böck <hanno@gentoo.org>2005-12-20 03:55:59 +0000
commitae1c23e290e532003f6b6198aee18399eae86ba2 (patch)
treee9d5f3d79f1bd34940857565d7fc93ab0a963298 /app-office/abiword-plugins
parentFor sci-chemistry/caver. (diff)
downloadgentoo-2-ae1c23e290e532003f6b6198aee18399eae86ba2.tar.gz
gentoo-2-ae1c23e290e532003f6b6198aee18399eae86ba2.tar.bz2
gentoo-2-ae1c23e290e532003f6b6198aee18399eae86ba2.zip
gcc41 fix for abiword-plugins
(Portage version: 2.1_pre1)
Diffstat (limited to 'app-office/abiword-plugins')
-rw-r--r--app-office/abiword-plugins/ChangeLog6
-rw-r--r--app-office/abiword-plugins/abiword-plugins-2.4.1-r2.ebuild8
-rw-r--r--app-office/abiword-plugins/files/abiword-plugins-2.4.2-gcc41.patch11
3 files changed, 23 insertions, 2 deletions
diff --git a/app-office/abiword-plugins/ChangeLog b/app-office/abiword-plugins/ChangeLog
index dadb9ddf5e2f..8d38936b8a80 100644
--- a/app-office/abiword-plugins/ChangeLog
+++ b/app-office/abiword-plugins/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/abiword-plugins
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword-plugins/ChangeLog,v 1.7 2005/11/02 10:52:47 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword-plugins/ChangeLog,v 1.8 2005/12/20 03:55:59 hanno Exp $
+
+ 20 Dec 2005; Hanno Boeck <hanno@gentoo.org>
+ +files/abiword-plugins-2.4.2-gcc41.patch, abiword-plugins-2.4.1-r2.ebuild:
+ Fix for gcc 4.1.
02 Nov 2005; Herbie Hopkins <herbs@gentoo.org>
abiword-plugins-2.4.1-r2.ebuild:
diff --git a/app-office/abiword-plugins/abiword-plugins-2.4.1-r2.ebuild b/app-office/abiword-plugins/abiword-plugins-2.4.1-r2.ebuild
index 0b2c83318f7d..292edfb262f2 100644
--- a/app-office/abiword-plugins/abiword-plugins-2.4.1-r2.ebuild
+++ b/app-office/abiword-plugins/abiword-plugins-2.4.1-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword-plugins/abiword-plugins-2.4.1-r2.ebuild,v 1.2 2005/11/02 10:52:47 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword-plugins/abiword-plugins-2.4.1-r2.ebuild,v 1.3 2005/12/20 03:55:59 hanno Exp $
+
+inherit eutils
DESCRIPTION="Set of plugins for abiword"
HOMEPAGE="http://www.abisource.com/"
@@ -39,6 +41,10 @@ RDEPEND="=app-office/abiword-${PV}
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9"
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/abiword-plugins-2.4.2-gcc41.patch
+}
src_compile() {
local myconf="--enable-all \
diff --git a/app-office/abiword-plugins/files/abiword-plugins-2.4.2-gcc41.patch b/app-office/abiword-plugins/files/abiword-plugins-2.4.2-gcc41.patch
new file mode 100644
index 000000000000..db3b3df0f07d
--- /dev/null
+++ b/app-office/abiword-plugins/files/abiword-plugins-2.4.2-gcc41.patch
@@ -0,0 +1,11 @@
+--- abiword-2.4.1/abiword-plugins/wp/impexp/OpenDocument/xp/OD_Style_Style.h 2005-09-28 15:02:36.000000000 +0200
++++ abiword-2.4.1-gcc41/abiword-plugins/wp/impexp/OpenDocument/xp/OD_Style_Style.h 2005-12-10 18:41:51.771910750 +0100
+@@ -77,7 +77,7 @@
+ * @param rProps The string that will have appended to it the properties of this
+ * style.
+ */
+- void OD_Style_Style::getAbiPropsAttrString(UT_UTF8String& rProps) const;
++ void getAbiPropsAttrString(UT_UTF8String& rProps) const;
+
+
+ const UT_UTF8String& getParentStyleName() const {