summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2011-12-04 14:18:51 +0000
committerCédric Krier <cedk@gentoo.org>2011-12-04 14:18:51 +0000
commit3c41e20c37dccaa5d141ebb4e64f35ec3a6c9922 (patch)
treef4dc1c285edd14fa2e2ca0cbb3ef4321179554c5 /app-office/calcurse
parentAdd ~x86-fbsd. (diff)
downloadgentoo-2-3c41e20c37dccaa5d141ebb4e64f35ec3a6c9922.tar.gz
gentoo-2-3c41e20c37dccaa5d141ebb4e64f35ec3a6c9922.tar.bz2
gentoo-2-3c41e20c37dccaa5d141ebb4e64f35ec3a6c9922.zip
Version bump
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'app-office/calcurse')
-rw-r--r--app-office/calcurse/ChangeLog9
-rw-r--r--app-office/calcurse/calcurse-2.9.2.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/app-office/calcurse/ChangeLog b/app-office/calcurse/ChangeLog
index 49cd0667c460..5820d9cb561d 100644
--- a/app-office/calcurse/ChangeLog
+++ b/app-office/calcurse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/calcurse
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/calcurse/ChangeLog,v 1.15 2010/05/18 17:44:18 ken69267 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/calcurse/ChangeLog,v 1.16 2011/12/04 14:18:51 cedk Exp $
+
+*calcurse-2.9.2 (04 Dec 2011)
+
+ 04 Dec 2011; Cédric Krier <cedk@gentoo.org> +calcurse-2.9.2.ebuild:
+ Version bump
18 May 2010; Kenneth Prugh <ken69267@gentoo.org> calcurse-2.7.ebuild:
amd64 stable, bug #318783
diff --git a/app-office/calcurse/calcurse-2.9.2.ebuild b/app-office/calcurse/calcurse-2.9.2.ebuild
new file mode 100644
index 000000000000..f10b1bdda2d1
--- /dev/null
+++ b/app-office/calcurse/calcurse-2.9.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/calcurse/calcurse-2.9.2.ebuild,v 1.1 2011/12/04 14:18:51 cedk Exp $
+
+inherit eutils
+
+DESCRIPTION="a text-based personal organizer"
+HOMEPAGE="http://calcurse.org"
+SRC_URI="http://calcurse.org/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_en linguas_fr linguas_de linguas_es linguas_nl linguas_ru"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm po/LINGUAS
+}
+
+src_compile() {
+ local ALL_LINGUAS=""
+
+ use linguas_en && ALL_LINGUAS="${ALL_LINGUAS} en"
+ use linguas_fr && ALL_LINGUAS="${ALL_LINGUAS} fr"
+ use linguas_de && ALL_LINGUAS="${ALL_LINGUAS} de"
+ use linguas_es && ALL_LINGUAS="${ALL_LINGUAS} es"
+ use linguas_nl && ALL_LINGUAS="${ALL_LINGUAS} nl"
+
+ ALL_LINGUAS="${ALL_LINGUAS}" econf || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README TODO
+}