summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Joly <csjoly@gentoo.org>2001-08-06 06:15:08 +0000
committerCraig Joly <csjoly@gentoo.org>2001-08-06 06:15:08 +0000
commitb818499865c06b523673843ff53096842ab93ca9 (patch)
tree2c8db6afec9a3e37ba5aea511d9eff2344f320d2 /app-office/gaby
parentfix (diff)
downloadgentoo-2-b818499865c06b523673843ff53096842ab93ca9.tar.gz
gentoo-2-b818499865c06b523673843ff53096842ab93ca9.tar.bz2
gentoo-2-b818499865c06b523673843ff53096842ab93ca9.zip
fixed the problems with the gaby ebuild (links being created and nls
ignoring {DESTDIR} moved gaby from incoming to app-office
Diffstat (limited to 'app-office/gaby')
-rw-r--r--app-office/gaby/files/Makefile.in216
-rw-r--r--app-office/gaby/files/digest-gaby-2.0.21
-rw-r--r--app-office/gaby/gaby-2.0.2.ebuild80
3 files changed, 297 insertions, 0 deletions
diff --git a/app-office/gaby/files/Makefile.in b/app-office/gaby/files/Makefile.in
new file mode 100644
index 000000000000..3f14c13c296a
--- /dev/null
+++ b/app-office/gaby/files/Makefile.in
@@ -0,0 +1,216 @@
+# Makefile for directory with message catalog handling in GNU NLS Utilities.
+# Copyright (C) 1995, 1996, 1997 Free Software Foundation, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+PACKAGE = @PACKAGE@
+VERSION = @VERSION@
+
+SHELL = /bin/sh
+
+srcdir = @srcdir@
+top_srcdir = @top_srcdir@
+top_builddir = ..
+VPATH = @srcdir@
+
+prefix = @prefix@
+exec_prefix = @exec_prefix@
+transform = @program_transform_name@
+libdir = $(exec_prefix)/lib
+includedir = $(prefix)/include
+datadir = $(prefix)/@DATADIRNAME@
+localedir = $(datadir)/locale
+gnulocaledir = $(prefix)/share/locale
+gettextsrcdir = $(datadir)/gettext/intl
+aliaspath = $(localedir):.
+subdir = intl
+
+DESTDIR =
+
+INSTALL = @INSTALL@
+INSTALL_DATA = @INSTALL_DATA@
+MKINSTALLDIRS = @MKINSTALLDIRS@
+
+l = @l@
+
+AR = ar
+CC = @CC@
+LIBTOOL = @LIBTOOL@
+RANLIB = @RANLIB@
+
+DEFS = -DLOCALEDIR=\"$(localedir)\" -DGNULOCALEDIR=\"$(gnulocaledir)\" \
+-DLOCALE_ALIAS_PATH=\"$(aliaspath)\" @DEFS@
+CPPFLAGS = @CPPFLAGS@
+CFLAGS = @CFLAGS@
+LDFLAGS = @LDFLAGS@
+
+COMPILE = $(CC) -c $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $(XCFLAGS)
+
+HEADERS = $(COMHDRS) libgettext.h loadinfo.h
+COMHDRS = gettext.h gettextP.h hash-string.h
+SOURCES = $(COMSRCS) intl-compat.c cat-compat.c
+COMSRCS = bindtextdom.c dcgettext.c dgettext.c gettext.c \
+finddomain.c loadmsgcat.c localealias.c textdomain.c l10nflist.c \
+explodename.c
+OBJECTS = @INTLOBJS@ bindtextdom.$lo dcgettext.$lo dgettext.$lo gettext.$lo \
+finddomain.$lo loadmsgcat.$lo localealias.$lo textdomain.$lo l10nflist.$lo \
+explodename.$lo
+CATOBJS = cat-compat.$lo ../po/cat-id-tbl.$lo
+GETTOBJS = intl-compat.$lo
+DISTFILES.common = ChangeLog Makefile.in linux-msg.sed po2tbl.sed.in \
+xopen-msg.sed $(HEADERS) $(SOURCES)
+DISTFILES.normal = VERSION
+DISTFILES.gettext = libintl.glibc intlh.inst.in
+
+.SUFFIXES:
+.SUFFIXES: .c .o .lo
+.c.o:
+ $(COMPILE) $<
+.c.lo:
+ $(LIBTOOL) --mode=compile $(COMPILE) $<
+
+INCLUDES = -I.. -I. -I$(top_srcdir)/intl -I$(top_srcdir)/lib
+
+all: all-@USE_INCLUDED_LIBINTL@
+
+all-yes: libintl.$la intlh.inst
+all-no:
+
+libintl.a: $(OBJECTS)
+ rm -f $@
+ $(AR) cru $@ $(OBJECTS)
+ $(RANLIB) $@
+
+libintl.la: $(OBJECTS)
+ $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $@ $(OBJECTS) \
+ -version-info 1:0 -rpath $(libdir)
+
+../po/cat-id-tbl.$lo: ../po/cat-id-tbl.c $(top_srcdir)/po/$(PACKAGE).pot
+ cd ../po && $(MAKE) cat-id-tbl.$lo
+
+check: all
+
+# This installation goal is only used in GNU gettext. Packages which
+# only use the library should use install instead.
+
+# We must not install the libintl.h/libintl.a files if we are on a
+# system which has the gettext() function in its C library or in a
+# separate library or use the catgets interface. A special case is
+# where configure found a previously installed GNU gettext library.
+# If you want to use the one which comes with this version of the
+# package, you have to use `configure --with-included-gettext'.
+install: install-exec install-data
+install-exec: all
+ if test "$(PACKAGE)" = "gettext" \
+ && test '@INTLOBJS@' = '$(GETTOBJS)'; then \
+ if test -r $(MKINSTALLDIRS); then \
+ $(MKINSTALLDIRS) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir); \
+ else \
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)$(libdir) $(DESTDIR)$(includedir); \
+ fi; \
+ $(INSTALL_DATA) intlh.inst $(DESTDIR)$(includedir)/libintl.h; \
+ $(INSTALL_DATA) libintl.a $(DESTDIR)$(libdir)/libintl.a; \
+ else \
+ : ; \
+ fi
+install-data: all
+ if test "$(PACKAGE)" = "gettext"; then \
+ if test -r $(MKINSTALLDIRS); then \
+ $(MKINSTALLDIRS) $(DESTDIR)$(gettextsrcdir); \
+ else \
+ $(top_srcdir)/mkinstalldirs $(DESTDIR)$(gettextsrcdir); \
+ fi; \
+ $(INSTALL_DATA) VERSION $(DESTDIR)$(gettextsrcdir)/VERSION; \
+ dists="$(DISTFILES.common)"; \
+ for file in $$dists; do \
+ $(INSTALL_DATA) $(srcdir)/$$file $(DESTDIR)$(gettextsrcdir)/$$file; \
+ done; \
+ else \
+ : ; \
+ fi
+
+# Define this as empty until I found a useful application.
+installcheck:
+
+uninstall:
+ dists="$(DISTFILES.common)"; \
+ for file in $$dists; do \
+ rm -f $(DESTDIR)$(gettextsrcdir)/$$file; \
+ done
+
+info dvi:
+
+$(OBJECTS): ../config.h libgettext.h
+bindtextdom.$lo finddomain.$lo loadmsgcat.$lo: gettextP.h gettext.h loadinfo.h
+dcgettext.$lo: gettextP.h gettext.h hash-string.h loadinfo.h
+
+tags: TAGS
+
+TAGS: $(HEADERS) $(SOURCES)
+ here=`pwd`; cd $(srcdir) && etags -o $$here/TAGS $(HEADERS) $(SOURCES)
+
+id: ID
+
+ID: $(HEADERS) $(SOURCES)
+ here=`pwd`; cd $(srcdir) && mkid -f$$here/ID $(HEADERS) $(SOURCES)
+
+
+mostlyclean:
+ rm -f *.a *.o *.lo core core.*
+
+clean: mostlyclean
+
+distclean: clean
+ rm -f Makefile ID TAGS po2msg.sed po2tbl.sed
+
+maintainer-clean: distclean
+ @echo "This command is intended for maintainers to use;"
+ @echo "it deletes files that may require special tools to rebuild."
+
+
+# GNU gettext needs not contain the file `VERSION' but contains some
+# other files which should not be distributed in other packages.
+distdir = ../$(PACKAGE)-$(VERSION)/$(subdir)
+dist distdir: Makefile $(DISTFILES)
+ if test "$(PACKAGE)" = gettext; then \
+ additional="$(DISTFILES.gettext)"; \
+ else \
+ additional="$(DISTFILES.normal)"; \
+ fi; \
+ for file in $(DISTFILES.common) $$additional; do \
+ ln $(srcdir)/$$file $(distdir) 2> /dev/null \
+ || cp -p $(srcdir)/$$file $(distdir); \
+ done
+
+dist-libc:
+ tar zcvf intl-glibc.tar.gz $(COMSRCS) $(COMHDRS) libintl.h.glibc
+
+Makefile: Makefile.in ../config.status
+ cd .. \
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+# The dependency for intlh.inst is different in gettext and all other
+# packages. Because we cannot you GNU make features we have to solve
+# the problem while rewriting Makefile.in.
+@GT_YES@intlh.inst: intlh.inst.in ../config.status
+@GT_YES@ cd .. \
+@GT_YES@ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= \
+@GT_YES@ $(SHELL) ./config.status
+@GT_NO@.PHONY: intlh.inst
+@GT_NO@intlh.inst:
+
+# Tell versions [3.59,3.63) of GNU make not to export all variables.
+# Otherwise a system limit (for SysV at least) may be exceeded.
+.NOEXPORT:
diff --git a/app-office/gaby/files/digest-gaby-2.0.2 b/app-office/gaby/files/digest-gaby-2.0.2
new file mode 100644
index 000000000000..3645407c2efa
--- /dev/null
+++ b/app-office/gaby/files/digest-gaby-2.0.2
@@ -0,0 +1 @@
+MD5 1203f7a548e46bc0bf5987fb2e1508ee gaby-2.0.2.tar.gz
diff --git a/app-office/gaby/gaby-2.0.2.ebuild b/app-office/gaby/gaby-2.0.2.ebuild
new file mode 100644
index 000000000000..99073c0c20a9
--- /dev/null
+++ b/app-office/gaby/gaby-2.0.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Craig Joly <joly@ee.ualberta.ca>
+# $Header: /var/cvsroot/gentoo-x86/app-office/gaby/gaby-2.0.2.ebuild,v 1.1 2001/08/06 06:15:08 csjoly Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A small personal databases manager for Linux"
+SRC_URI="http://gaby.sourceforge.net/archives/${P}.tar.gz"
+HOMEPAGE="http://gaby.sourceforge.net"
+
+DEPEND=">=x11-libs/gtk+-1.2.8
+ virtual/python
+ >=gnome-base/gdk-pixbuf-0.7.0
+ gnome-base/libxml
+ dev-python/gnome-python
+ gnome-base/libglade
+ gnome? ( >=gnome-base/gnome-libs-1.2.8 )
+ esd? ( >=media-sound/esound-0.2.8 )
+ nls? ( sys-devel/gettext )"
+
+# Image fields require ( >= (media-libs/imlib-1.9.3 ||
+# gnome-base/gdk-pixbuf-0.7.0 ))
+# Sound fields require ( >=media-sound/esound-0.2.8 )
+# form layout requires ( gnome-base/libglade )
+
+src_compile() {
+
+ local myopts
+
+ if [ "`use gnome`" ]
+ then
+ prefix="/opt/gnome"
+ myopts="--enable-gnome"
+ else
+ prefix="/usr/X11R6"
+ myopts="--disable-gnome"
+ fi
+
+ if [ -z "`use nls`" ]
+ then
+ myopts="$myopts --disable-nls"
+ fi
+
+ cp ${FILESDIR}/Makefile.in intl/Makefile.in
+
+ cp configure configure.orig
+ sed -e "7293 c\ if test -f /usr/include/pygtk/pygtk.h; then" \
+ < configure.orig > configure
+
+ try ./configure --host=${CHOST} ${myopts} --prefix=${prefix}
+
+ cd src
+ cp Makefile Makefile.orig
+ sed -e "s:install-exec-local::" \
+ -e "s:^\::gentoo change\::" Makefile.orig > Makefile
+ cd ..
+
+ try emake
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+
+ dosym gaby ${prefix}/bin/gbc
+ dosym gaby ${prefix}/bin/gcd
+ dosym gaby ${prefix}/bin/videobase
+ dosym gaby ${prefix}/bin/gnomecard
+ dosym gaby ${prefix}/bin/appindex
+
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS
+ dodoc README TODO TODO.more
+
+ insinto ${prefix}/share/pixmaps
+ insopt -m 0644
+ doins gnome-gaby-builder.png gnome-gaby.png
+
+}
+