summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarl Perry <edolnx@gentoo.org>2003-03-17 07:23:34 +0000
committerCarl Perry <edolnx@gentoo.org>2003-03-17 07:23:34 +0000
commit0b783f1f07a7520d7f9ac1c2c6d5bff0fe1635bf (patch)
tree573693b908db7626e0bfc8f78a1888d7c40a9e63 /app-office/gnucash
parentfixed dep for selinux-sources-2.4.20-r1 (diff)
downloadgentoo-2-0b783f1f07a7520d7f9ac1c2c6d5bff0fe1635bf.tar.gz
gentoo-2-0b783f1f07a7520d7f9ac1c2c6d5bff0fe1635bf.tar.bz2
gentoo-2-0b783f1f07a7520d7f9ac1c2c6d5bff0fe1635bf.zip
Added gnucash 1.8.1 which contains many bug fixes and more small
business support
Diffstat (limited to 'app-office/gnucash')
-rw-r--r--app-office/gnucash/ChangeLog8
-rw-r--r--app-office/gnucash/files/digest-gnucash-1.8.11
-rw-r--r--app-office/gnucash/gnucash-1.8.1.ebuild60
3 files changed, 68 insertions, 1 deletions
diff --git a/app-office/gnucash/ChangeLog b/app-office/gnucash/ChangeLog
index c22e19fb6e7a..d6315aa99a23 100644
--- a/app-office/gnucash/ChangeLog
+++ b/app-office/gnucash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/gnucash
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.13 2003/03/16 22:35:48 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/ChangeLog,v 1.14 2003/03/17 07:23:34 edolnx Exp $
+
+*gnucash-1.8.1 (17 Mar 2003)
+
+ 17 Mar 2003; Carl Perry <edolnx@gentoo.org> gnucash-1.8.1.ebuild:
+ Added new release of gnucash for testing, contains many bug fixes and
+ start of small business support.
*gnucash-1.6.8 (05 Sep 2002)
diff --git a/app-office/gnucash/files/digest-gnucash-1.8.1 b/app-office/gnucash/files/digest-gnucash-1.8.1
new file mode 100644
index 000000000000..859374e2473c
--- /dev/null
+++ b/app-office/gnucash/files/digest-gnucash-1.8.1
@@ -0,0 +1 @@
+MD5 b7f4601d91c66b00dfa3c76e00c02819 gnucash-1.8.1.tar.gz 6454992
diff --git a/app-office/gnucash/gnucash-1.8.1.ebuild b/app-office/gnucash/gnucash-1.8.1.ebuild
new file mode 100644
index 000000000000..c912158243be
--- /dev/null
+++ b/app-office/gnucash/gnucash-1.8.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnucash/gnucash-1.8.1.ebuild,v 1.1 2003/03/17 07:23:34 edolnx Exp $
+
+inherit flag-o-matic
+inherit libtool
+
+DESCRIPTION="A personal finance manager"
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnucash.org/"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="nls postgres"
+
+RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ >=dev-libs/libxml-1.8.3
+ >=gnome-extra/gtkhtml-0.14.0-r1
+ >=gnome-extra/gal-0.13-r1
+ >=gnome-extra/guppi-0.35.5-r2
+ >=gnome-base/gnome-print-0.21
+ postgres? ( dev-db/postgresql )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=dev-libs/slib-2.3.8
+ >=dev-lang/swig-1.3_alpha4
+ >=dev-libs/g-wrap-1.1.5
+ <gnome-base/libglade-2
+ media-libs/gdk-pixbuf
+ <dev-util/guile-1.4.1
+ gnome-base/libghttp
+ nls? ( sys-devel/gettext )"
+
+# these flags to GCC interfere with G_INLINE_FUNC usage in this package
+filter-flags "-fno-inline -finline-functions"
+
+src_unpack() {
+ unpack ${A}
+
+}
+
+src_compile() {
+ elibtoolize
+ local myconf=""
+
+ use nls || myconf="--disable-nls"
+ use postgres && myconf="$myconf --enable-sql"
+
+ econf ${myconf}
+
+ make || die # Doesn't work with make -j 4 (hallski)
+}
+
+src_install() {
+ einstall \
+ pkgdatadir=${D}/usr/share/gnucash
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog HACKING NEWS README* TODO
+}