summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2012-12-15 15:53:48 +0000
committerDenis Dupeyron <calchan@gentoo.org>2012-12-15 15:53:48 +0000
commite383e1cf78dfe28408646071c28d3c8145439716 (patch)
treef95f28e85db04bd919318df1249d28f0f6d07d51 /app-office/homebank
parentUpdate LICENSE, HPND according to README file, bug 445876. (diff)
downloadgentoo-2-e383e1cf78dfe28408646071c28d3c8145439716.tar.gz
gentoo-2-e383e1cf78dfe28408646071c28d3c8145439716.tar.bz2
gentoo-2-e383e1cf78dfe28408646071c28d3c8145439716.zip
Fix bug 423463.
(Portage version: 2.1.11.37/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-office/homebank')
-rw-r--r--app-office/homebank/ChangeLog6
-rw-r--r--app-office/homebank/files/homebank-4.4-fix_tests.patch20
-rw-r--r--app-office/homebank/homebank-4.4.ebuild8
3 files changed, 31 insertions, 3 deletions
diff --git a/app-office/homebank/ChangeLog b/app-office/homebank/ChangeLog
index 2b27f76d6f98..38c82d396fdf 100644
--- a/app-office/homebank/ChangeLog
+++ b/app-office/homebank/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/homebank
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/ChangeLog,v 1.26 2012/05/03 20:00:41 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/ChangeLog,v 1.27 2012/12/15 15:53:48 calchan Exp $
+
+ 15 Dec 2012; Denis Dupeyron <calchan@gentoo.org> homebank-4.4.ebuild,
+ +files/homebank-4.4-fix_tests.patch:
+ Fix bug 423463.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> homebank-4.3.ebuild,
homebank-4.4.ebuild:
diff --git a/app-office/homebank/files/homebank-4.4-fix_tests.patch b/app-office/homebank/files/homebank-4.4-fix_tests.patch
new file mode 100644
index 000000000000..041bad49ae5a
--- /dev/null
+++ b/app-office/homebank/files/homebank-4.4-fix_tests.patch
@@ -0,0 +1,20 @@
+diff --git a/po/POTFILES.in b/po/POTFILES.in
+index 7a1dc7f..4ea6ca3 100644
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
+@@ -3,6 +3,7 @@
+ data/homebank.desktop.in.in
+
+ # Main application
++src/da_encoding.c
+ src/def_archive.c
+ src/def_budget.c
+ src/def_filter.c
+@@ -13,6 +14,7 @@ src/dsp_account.c
+ src/dsp_wallet.c
+ src/homebank.c
+ src/hb_category.c
++src/hb_transaction.c
+ src/import.c
+ src/list_account.c
+ src/list_operation.c
diff --git a/app-office/homebank/homebank-4.4.ebuild b/app-office/homebank/homebank-4.4.ebuild
index 7f61675172bf..e2738e1bbf43 100644
--- a/app-office/homebank/homebank-4.4.ebuild
+++ b/app-office/homebank/homebank-4.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/homebank-4.4.ebuild,v 1.2 2012/05/03 20:00:41 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/homebank/homebank-4.4.ebuild,v 1.3 2012/12/15 15:53:48 calchan Exp $
EAPI="4"
-inherit fdo-mime
+inherit fdo-mime eutils
DESCRIPTION="Free, easy, personal accounting for everyone"
HOMEPAGE="http://homebank.free.fr/index.php"
@@ -21,6 +21,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
>=dev-util/intltool-0.40.5"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix_tests.patch"
+}
+
src_configure() {
econf $(use_with ofx)
}