summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2009-01-23 16:30:11 +0000
committerChristoph Mende <angelos@gentoo.org>2009-01-23 16:30:11 +0000
commit89e79526318b49cd715768870b43b5e6b1f0544a (patch)
treec515d55731fd9b677764817137e0c3775eebf4f0 /app-office/orage
parentFix build with test features reported in stabilization bug #254833 (diff)
downloadgentoo-2-89e79526318b49cd715768870b43b5e6b1f0544a.tar.gz
gentoo-2-89e79526318b49cd715768870b43b5e6b1f0544a.tar.bz2
gentoo-2-89e79526318b49cd715768870b43b5e6b1f0544a.zip
Fixed building on on BSD, bug 255840
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-office/orage')
-rw-r--r--app-office/orage/ChangeLog8
-rw-r--r--app-office/orage/files/orage-4.5.14.0-bsd.patch58
-rw-r--r--app-office/orage/orage-4.5.14.0.ebuild12
3 files changed, 73 insertions, 5 deletions
diff --git a/app-office/orage/ChangeLog b/app-office/orage/ChangeLog
index e44442ca7a98..f88b1bed26e9 100644
--- a/app-office/orage/ChangeLog
+++ b/app-office/orage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/orage
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.11 2008/12/22 17:08:57 angelos Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/ChangeLog,v 1.12 2009/01/23 16:30:11 angelos Exp $
+
+ 23 Jan 2009; Christoph Mende <angelos@gentoo.org>
+ +files/orage-4.5.14.0-bsd.patch, orage-4.5.14.0.ebuild:
+ Fixed building on on BSD, bug 255840
22 Dec 2008; Christoph Mende <angelos@gentoo.org> -orage-4.4.2.ebuild:
Removed old
diff --git a/app-office/orage/files/orage-4.5.14.0-bsd.patch b/app-office/orage/files/orage-4.5.14.0-bsd.patch
new file mode 100644
index 000000000000..0c9f2ff3105d
--- /dev/null
+++ b/app-office/orage/files/orage-4.5.14.0-bsd.patch
@@ -0,0 +1,58 @@
+diff -u -r a/configure.in b/configure.in
+--- a/configure.in 2009-01-23 17:22:08.468513692 +0100
++++ b/configure.in 2009-01-23 17:24:07.636680538 +0100
+@@ -172,6 +172,21 @@
+ esac
+ AC_SUBST([PTHREAD_LIBS])
+
++dnl **********************************
++dnl *** check if we have _NL_TIME_FIRST_WEEKDAY
++dnl *** note that it is an enum and not a define
++dnl **********************************
++AC_MSG_CHECKING([for _NL_TIME_FIRST_WEEKDAY])
++AC_TRY_LINK([#include <langinfo.h>], [
++char c;
++c = *((unsigned char *) nl_langinfo(_NL_TIME_FIRST_WEEKDAY));
++], nl_ok=yes, nl_ok=no)
++AC_MSG_RESULT($nl_ok)
++if test "$nl_ok" = "yes"; then
++ AC_DEFINE([HAVE__NL_TIME_FIRST_WEEKDAY], [1],
++ [Define if _NL_TIME_FIRST_WEEKDAY is available])
++fi
++
+ AM_CONDITIONAL([INCLUDED_LIBICAL], [test x"$ac_INCLUDED_LIBICAL" = x"yes"])
+ AM_CONDITIONAL([HAVE_PTHREAD], [test x"$have_pthread" = x"yes"])
+ AM_CONDITIONAL([WITH_BDB4], [test x"$WITH_BDB4" = x"yes"])
+diff -u -r a/src/parameters.c b/src/parameters.c
+--- a/src/parameters.c 2009-01-23 17:22:08.529511185 +0100
++++ b/src/parameters.c 2009-01-23 17:23:43.167509746 +0100
+@@ -30,7 +30,10 @@
+
+ #include <stdio.h>
+ #include <locale.h>
++
++#ifdef HAVE__NL_TIME_FIRST_WEEKDAY
+ #include <langinfo.h>
++#endif
+
+ #include <glib.h>
+ #include <glib/gprintf.h>
+@@ -129,6 +132,7 @@
+ * to return 0..6 mon..sun, which is what libical uses */
+ int get_first_weekday_from_locale()
+ {
++#ifdef HAVE__NL_TIME_FIRST_WEEKDAY
+ union { unsigned int word; char *string; } langinfo;
+ int week_1stday = 0;
+ int first_weekday = 1;
+@@ -147,6 +151,10 @@
+ orage_message(150, "get_first_weekday: unknown value of _NL_TIME_WEEK_1STDAY.");
+
+ return((week_1stday + first_weekday - 2 + 7) % 7);
++#else
++ orage_message(150, "get_first_weekday: Can not find first weekday. Using default: Monday=0. If this is wrong guess. please set undocumented parameter: Ical week start day (Sunday=6)");
++ return(0);
++#endif
+ }
+
+ static void dialog_response(GtkWidget *dialog, gint response_id
diff --git a/app-office/orage/orage-4.5.14.0.ebuild b/app-office/orage/orage-4.5.14.0.ebuild
index a2cf6accb713..a8b5927cb30e 100644
--- a/app-office/orage/orage-4.5.14.0.ebuild
+++ b/app-office/orage/orage-4.5.14.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/orage/orage-4.5.14.0.ebuild,v 1.1 2008/09/19 16:07:18 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/orage/orage-4.5.14.0.ebuild,v 1.2 2009/01/23 16:30:11 angelos Exp $
-inherit gnome2-utils
+inherit eutils gnome2-utils
DESCRIPTION="Calendar suite for Xfce4"
HOMEPAGE="http://www.kolumbus.fi/~w408237/orage"
@@ -27,6 +27,12 @@ DEPEND="${RDEPEND}
dev-util/intltool
sys-devel/gettext"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-bsd.patch
+}
+
src_compile() {
econf $(use_enable dbus) \
$(use_enable debug) \