summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-12-04 15:35:15 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-12-04 15:35:15 +0000
commit20bf30f3ea5333134a00cc68ce15872a3bea4f9c (patch)
treebc2b51cad4abd8a56d9e9f97ccbee77f09a52c8f /app-office/planner
parentFix bug #249806. Remove old with huge patch. (diff)
downloadgentoo-2-20bf30f3ea5333134a00cc68ce15872a3bea4f9c.tar.gz
gentoo-2-20bf30f3ea5333134a00cc68ce15872a3bea4f9c.tar.bz2
gentoo-2-20bf30f3ea5333134a00cc68ce15872a3bea4f9c.zip
Allow planner to select specific libgda and fix build with newer glib/gcc, bug #231823
(Portage version: 2.2_rc16/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'app-office/planner')
-rw-r--r--app-office/planner/ChangeLog12
-rw-r--r--app-office/planner/files/planner-0.14.3-build-failure.patch19
-rw-r--r--app-office/planner/files/planner-0.14.3-configure.patch76
-rw-r--r--app-office/planner/planner-0.14.3-r1.ebuild81
-rw-r--r--app-office/planner/planner-0.14.3-r2.ebuild81
5 files changed, 268 insertions, 1 deletions
diff --git a/app-office/planner/ChangeLog b/app-office/planner/ChangeLog
index 60426f4bcf0b..361104a7c95e 100644
--- a/app-office/planner/ChangeLog
+++ b/app-office/planner/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-office/planner
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/planner/ChangeLog,v 1.44 2008/05/25 12:38:21 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/planner/ChangeLog,v 1.45 2008/12/04 15:35:15 eva Exp $
+
+*planner-0.14.3-r2 (04 Dec 2008)
+*planner-0.14.3-r1 (04 Dec 2008)
+
+ 04 Dec 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/planner-0.14.3-build-failure.patch,
+ +files/planner-0.14.3-configure.patch, +planner-0.14.3-r1.ebuild,
+ +planner-0.14.3-r2.ebuild:
+ Allow planner to select specific libgda and fix build with newer glib/gcc,
+ bug #231823
25 May 2008; Markus Meier <maekke@gentoo.org> planner-0.14.3.ebuild:
amd64/x86 stable, bug #223297
diff --git a/app-office/planner/files/planner-0.14.3-build-failure.patch b/app-office/planner/files/planner-0.14.3-build-failure.patch
new file mode 100644
index 000000000000..1317a2cb6d27
--- /dev/null
+++ b/app-office/planner/files/planner-0.14.3-build-failure.patch
@@ -0,0 +1,19 @@
+#
+# Gentoo: https://bugs.gentoo.org/show_bug.cgi?id=231823
+# Upstream: http://bugzilla.gnome.org/show_bug.cgi?id=539993
+#
+--- a/libplanner/mrp-sql.c 2008/07/15 01:17:58 1.1
++++ b/libplanner/mrp-sql.c 2008/07/15 01:19:28
+@@ -2405,9 +2405,9 @@ mrp_sql_load_project (MrpStorageSQL *sto
+ }
+
+ #define WRITE_ERROR(e,c) \
+-G_STMT_START \
+-g_set_error(e,MRP_ERROR,MRP_ERROR_SAVE_WRITE_FAILED, sql_get_last_error (c)) \
+-G_STMT_END
++G_STMT_START { \
++g_set_error(e,MRP_ERROR,MRP_ERROR_SAVE_WRITE_FAILED, sql_get_last_error (c)); \
++} G_STMT_END
+
+
+ /*************************
diff --git a/app-office/planner/files/planner-0.14.3-configure.patch b/app-office/planner/files/planner-0.14.3-configure.patch
new file mode 100644
index 000000000000..f59454f03fe4
--- /dev/null
+++ b/app-office/planner/files/planner-0.14.3-configure.patch
@@ -0,0 +1,76 @@
+#
+# Upstream: https://bugzilla.gnome.org/show_bug.cgi?id=562984
+#
+Index: b/configure.in
+===================================================================
+--- a/configure.in (révision 940)
++++ b/configure.in (copie de travail)
+@@ -80,28 +81,40 @@
+ dnl -----------
+ dnl | Database/GDA check |----------------------------------------------
+ dnl -----------
+-AC_ARG_ENABLE(database, [ --enable-database=[no/yes] enable database support [default=no]], enable_database="$enableval", enable_database=no)
++AC_ARG_WITH(database,
++ AS_HELP_STRING([--with-database],
++ [enable database support @<:@default=no@:>@ (auto/no/gda1/gda2/gda3)]),
++ with_database="$withval", with_database=no)
+
+-if test "x$enable_database" = "xyes" ; then
++GDA_VER=
++use_gda=no
+
+- PKG_CHECK_MODULES(GDA, libgda-3.0 >= 1.0,
+- [
+- GDA_VER=30
+- ],
+- [
+- PKG_CHECK_MODULES(GDA, libgda-2.0 >= 1.0,
+- [
+- GDA_VER=20
+- ],
+- [
+- PKG_CHECK_MODULES(GDA, libgda >= 1.0)
+- GDA_VER=10
+- ])
+- ])
+- use_gda=yes
+-else
+- use_gda=no
++case "$with_database" in
++auto|yes)
++ PKG_CHECK_MODULES(GDA, libgda-3.0 >= 1.0, [GDA_VER=30],
++ [PKG_CHECK_MODULES(GDA, libgda-2.0 >= 1.0, [GDA_VER=20],
++ [PKG_CHECK_MODULES(GDA, libgda >= 1.0, [GDA_VER=10])
++ ])
++ ])
++ ;;
++*gda3*)
++ PKG_CHECK_MODULES(GDA, libgda-3.0 >= 1.0, [GDA_VER=30])
++ ;;
++*gda2*)
++ PKG_CHECK_MODULES(GDA, libgda-2.0 >= 1.0, [GDA_VER=20])
++ ;;
++*gda1*)
++ PKG_CHECK_MODULES(GDA, libgda >= 1.0, [GDA_VER=10])
++ ;;
++*)
++ use_gda=no
++ ;;
++esac
++
++if test x$GDA_VER != x; then
++ use_gda=yes
+ fi
++
+ AC_SUBST(GDA_VER)
+ AM_CONDITIONAL(HAVE_GDA, test x$use_gda = xyes)
+ dnl -----------------------------------------------------------
+@@ -351,7 +364,7 @@
+ echo "Python plugin : $enable_python_plugin"
+ #echo "Dotnet bindings : $have_dotnet"
+ echo "Simple priority scheduling : $use_simple_priority_scheduling"
+-echo "Database/GDA support : $use_gda"
++echo "Database/GDA support : $use_gda, $GDA_VER"
+ echo "Evolution Data Server import : $use_eds"
+ echo "Evolution Data Server backend: $use_eds_backend"
+ echo
diff --git a/app-office/planner/planner-0.14.3-r1.ebuild b/app-office/planner/planner-0.14.3-r1.ebuild
new file mode 100644
index 000000000000..933086712e9c
--- /dev/null
+++ b/app-office/planner/planner-0.14.3-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/planner/planner-0.14.3-r1.ebuild,v 1.1 2008/12/04 15:35:15 eva Exp $
+
+EAPI="1"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Project manager for Gnome2"
+HOMEPAGE="http://live.gnome.org/Planner/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc eds libgda python examples"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libgnomecanvas-2.10
+ >=gnome-base/libgnomeui-2.10
+ >=gnome-base/libglade-2.4
+ >=gnome-base/gnome-vfs-2.10
+ >=gnome-base/libgnomeprintui-2.10
+ >=gnome-base/gconf-2.6
+ >=dev-libs/libxml2-2.6.27
+ >=dev-libs/libxslt-1.1.23
+ libgda? ( gnome-extra/libgda:1 )
+ python? ( >=dev-python/pygtk-2.6 )
+ eds? (
+ >=gnome-extra/evolution-data-server-1.1
+ >=mail-client/evolution-2.1.3 )"
+
+# FIXME: disable eds backend for now, its experimental
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.35.5
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.0 )"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with libgda database gda1)
+ $(use_enable python)
+ $(use_enable python python-plugin)
+ $(use_enable eds)
+ --disable-update-mimedb"
+# $(use_enable eds eds-backend)
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix parallel build issues
+ epatch "${FILESDIR}/${P}-parallel-build.patch"
+
+ # Fix compile failure with eds-plugin
+ epatch "${FILESDIR}/${P}-eds-plugin.patch"
+
+ # Fix compilation failure with recent glib/gcc, bug #231823
+ epatch "${FILESDIR}/${P}-build-failure.patch"
+
+ # Fix libgda selection
+ epatch "${FILESDIR}/${P}-configure.patch"
+
+ intltoolize --force || die "intltoolize failed"
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install \
+ sqldocdir="\$(datadir)/doc/${PF}" \
+ sampledir="\$(datadir)/doc/${PF}/examples"
+
+ if ! use examples; then
+ rm -rf "${D}/usr/share/doc/${PF}/examples"
+ fi
+}
diff --git a/app-office/planner/planner-0.14.3-r2.ebuild b/app-office/planner/planner-0.14.3-r2.ebuild
new file mode 100644
index 000000000000..d04f5857d73c
--- /dev/null
+++ b/app-office/planner/planner-0.14.3-r2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/planner/planner-0.14.3-r2.ebuild,v 1.1 2008/12/04 15:35:15 eva Exp $
+
+EAPI="1"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Project manager for Gnome2"
+HOMEPAGE="http://live.gnome.org/Planner/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc eds libgda python examples"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libgnomecanvas-2.10
+ >=gnome-base/libgnomeui-2.10
+ >=gnome-base/libglade-2.4
+ >=gnome-base/gnome-vfs-2.10
+ >=gnome-base/libgnomeprintui-2.10
+ >=gnome-base/gconf-2.6
+ >=dev-libs/libxml2-2.6.27
+ >=dev-libs/libxslt-1.1.23
+ libgda? ( gnome-extra/libgda:3 )
+ python? ( >=dev-python/pygtk-2.6 )
+ eds? (
+ >=gnome-extra/evolution-data-server-1.1
+ >=mail-client/evolution-2.1.3 )"
+
+# FIXME: disable eds backend for now, its experimental
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.35.5
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.0 )"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with libgda database gda3)
+ $(use_enable python)
+ $(use_enable python python-plugin)
+ $(use_enable eds)
+ --disable-update-mimedb"
+# $(use_enable eds eds-backend)
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix parallel build issues
+ epatch "${FILESDIR}/${P}-parallel-build.patch"
+
+ # Fix compile failure with eds-plugin
+ epatch "${FILESDIR}/${P}-eds-plugin.patch"
+
+ # Fix compilation failure with recent glib/gcc, bug #231823
+ epatch "${FILESDIR}/${P}-build-failure.patch"
+
+ # Fix libgda selection
+ epatch "${FILESDIR}/${P}-configure.patch"
+
+ intltoolize --force || die "intltoolize failed"
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install \
+ sqldocdir="\$(datadir)/doc/${PF}" \
+ sampledir="\$(datadir)/doc/${PF}/examples"
+
+ if ! use examples; then
+ rm -rf "${D}/usr/share/doc/${PF}/examples"
+ fi
+}