summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-06-08 15:45:26 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-06-08 15:45:26 +0000
commit3d1952e4ba235e41a18fce2f9adda3ea47e8434d (patch)
tree0961e2eedc706434c679e3f96492aedb39b5bca2 /app-office
parentremove left over files (diff)
downloadgentoo-2-3d1952e4ba235e41a18fce2f9adda3ea47e8434d.tar.gz
gentoo-2-3d1952e4ba235e41a18fce2f9adda3ea47e8434d.tar.bz2
gentoo-2-3d1952e4ba235e41a18fce2f9adda3ea47e8434d.zip
add missing icon cache update, fix other ebuilds too
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/lyx/ChangeLog6
-rw-r--r--app-office/lyx/lyx-1.6.10.ebuild11
-rw-r--r--app-office/lyx/lyx-2.0.1.ebuild15
-rw-r--r--app-office/lyx/lyx-2.0.2.ebuild15
-rw-r--r--app-office/lyx/lyx-2.0.3.ebuild11
5 files changed, 45 insertions, 13 deletions
diff --git a/app-office/lyx/ChangeLog b/app-office/lyx/ChangeLog
index cf7d81aa6342..2750d8d26675 100644
--- a/app-office/lyx/ChangeLog
+++ b/app-office/lyx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/lyx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.264 2012/06/08 15:37:08 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.265 2012/06/08 15:45:26 hasufell Exp $
+
+ 08 Jun 2012; Julian Ospald <hasufell@gentoo.org> lyx-1.6.10.ebuild,
+ lyx-2.0.1.ebuild, lyx-2.0.2.ebuild, lyx-2.0.3.ebuild:
+ add missing icon cache update, fix other ebuilds too
08 Jun 2012; Alexis Ballier <aballier@gentoo.org>
-files/lyx-1.5.0-gentoo.patch, -files/lyx.desktop:
diff --git a/app-office/lyx/lyx-1.6.10.ebuild b/app-office/lyx/lyx-1.6.10.ebuild
index ecb179a5b655..ee6c7c8404fc 100644
--- a/app-office/lyx/lyx-1.6.10.ebuild
+++ b/app-office/lyx/lyx-1.6.10.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.6.10.ebuild,v 1.11 2012/06/08 15:06:55 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.6.10.ebuild,v 1.12 2012/06/08 15:45:26 hasufell Exp $
EAPI=2
PYTHON_DEPEND="2"
-inherit qt4-r2 eutils flag-o-matic font python toolchain-funcs
+inherit gnome2-utils qt4-r2 eutils flag-o-matic font python toolchain-funcs
MY_P="${P/_}"
@@ -138,8 +138,13 @@ src_install() {
python_convert_shebangs -r 2 "${D}"/usr/share/${PN}
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
font_pkg_postinst
+ gnome2_icon_cache_update
# fix for bug 91108
if use latex ; then
@@ -159,6 +164,8 @@ pkg_postinst() {
}
pkg_postrm() {
+ gnome2_icon_cache_update
+
if use latex ; then
texhash
fi
diff --git a/app-office/lyx/lyx-2.0.1.ebuild b/app-office/lyx/lyx-2.0.1.ebuild
index 2a254901463f..e815c9803c98 100644
--- a/app-office/lyx/lyx-2.0.1.ebuild
+++ b/app-office/lyx/lyx-2.0.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-2.0.1.ebuild,v 1.9 2012/05/03 20:00:39 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-2.0.1.ebuild,v 1.10 2012/06/08 15:45:26 hasufell Exp $
EAPI=3
PYTHON_DEPEND="2"
-inherit qt4-r2 eutils flag-o-matic font python toolchain-funcs
+inherit gnome2-utils qt4-r2 eutils flag-o-matic font python toolchain-funcs
MY_P="${P/_}"
@@ -136,8 +136,8 @@ src_install() {
doins "${T}"/hebrew.bind || die
fi
- doicon ${PN} "$S/development/Win32/packaging/icons/lyx_32x32.png"
- make_desktop_entry ${PN} "LyX" "/usr/share/pixmaps/lyx_32x32.png" "Office" "MimeType=application/x-lyx;"
+ newicon -s 32 "${S}"/development/Win32/packaging/icons/lyx_32x32.png ${PN}.png
+ make_desktop_entry ${PN} "LyX" "${PN}" "Office" "MimeType=application/x-lyx;"
# fix for bug 91108
if use latex ; then
@@ -155,8 +155,13 @@ src_install() {
fi
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
font_pkg_postinst
+ gnome2_icon_cache_update
# fix for bug 91108
if use latex ; then
@@ -176,6 +181,8 @@ pkg_postinst() {
}
pkg_postrm() {
+ gnome2_icon_cache_update
+
if use latex ; then
texhash
fi
diff --git a/app-office/lyx/lyx-2.0.2.ebuild b/app-office/lyx/lyx-2.0.2.ebuild
index f604c937077b..bedcbfb5684b 100644
--- a/app-office/lyx/lyx-2.0.2.ebuild
+++ b/app-office/lyx/lyx-2.0.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-2.0.2.ebuild,v 1.7 2012/05/03 20:00:39 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-2.0.2.ebuild,v 1.8 2012/06/08 15:45:26 hasufell Exp $
EAPI=3
PYTHON_DEPEND="2"
-inherit qt4-r2 eutils flag-o-matic font python toolchain-funcs
+inherit gnome2-utils qt4-r2 eutils flag-o-matic font python toolchain-funcs
MY_P="${P/_}"
@@ -138,8 +138,8 @@ src_install() {
doins "${T}"/hebrew.bind || die
fi
- doicon ${PN} "$S/development/Win32/packaging/icons/lyx_32x32.png"
- make_desktop_entry ${PN} "LyX" "/usr/share/pixmaps/lyx_32x32.png" "Office" "MimeType=application/x-lyx;"
+ newicon -s 32 "${S}"/development/Win32/packaging/icons/lyx_32x32.png ${PN}.png
+ make_desktop_entry ${PN} "LyX" "${PN}" "Office" "MimeType=application/x-lyx;"
# fix for bug 91108
if use latex ; then
@@ -157,8 +157,13 @@ src_install() {
fi
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
font_pkg_postinst
+ gnome2_icon_cache_update
# fix for bug 91108
if use latex ; then
@@ -178,6 +183,8 @@ pkg_postinst() {
}
pkg_postrm() {
+ gnome2_icon_cache_update
+
if use latex ; then
texhash
fi
diff --git a/app-office/lyx/lyx-2.0.3.ebuild b/app-office/lyx/lyx-2.0.3.ebuild
index ff410b4d494e..d048cb424e5f 100644
--- a/app-office/lyx/lyx-2.0.3.ebuild
+++ b/app-office/lyx/lyx-2.0.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-2.0.3.ebuild,v 1.11 2012/06/08 15:06:55 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-2.0.3.ebuild,v 1.12 2012/06/08 15:45:26 hasufell Exp $
EAPI=3
PYTHON_DEPEND="2"
-inherit qt4-r2 eutils flag-o-matic font python toolchain-funcs
+inherit gnome2-utils qt4-r2 eutils flag-o-matic font python toolchain-funcs
MY_P="${P/_}"
@@ -148,8 +148,13 @@ src_install() {
fi
}
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
pkg_postinst() {
font_pkg_postinst
+ gnome2_icon_cache_update
# fix for bug 91108
if use latex ; then
@@ -169,6 +174,8 @@ pkg_postinst() {
}
pkg_postrm() {
+ gnome2_icon_cache_update
+
if use latex ; then
texhash
fi