summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-02-18 15:59:40 +0000
committerMarinus Schraal <foser@gentoo.org>2004-02-18 15:59:40 +0000
commit41eb77eed26b74700adaf0aa50832fa47ca92a7a (patch)
treed3c0bcc46b69d1e5bdf4ee9282176892fd149fdc /app-office
parentRevision bump for yahoo fix, and removing 0.67 (Manifest recommit) (diff)
downloadgentoo-2-41eb77eed26b74700adaf0aa50832fa47ca92a7a.tar.gz
gentoo-2-41eb77eed26b74700adaf0aa50832fa47ca92a7a.tar.bz2
gentoo-2-41eb77eed26b74700adaf0aa50832fa47ca92a7a.zip
docs install fix
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/ChangeLog7
-rw-r--r--app-office/abiword/abiword-2.0.3-r1.ebuild108
-rw-r--r--app-office/abiword/files/digest-abiword-2.0.3-r11
3 files changed, 115 insertions, 1 deletions
diff --git a/app-office/abiword/ChangeLog b/app-office/abiword/ChangeLog
index 28ba7b9489db..7cb7fe33e7f7 100644
--- a/app-office/abiword/ChangeLog
+++ b/app-office/abiword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/abiword
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.62 2004/02/09 18:52:23 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/ChangeLog,v 1.63 2004/02/18 15:59:40 foser Exp $
+
+*abiword-2.0.3-r1 (18 Feb 2004)
+
+ 18 Feb 2004; foser <foser@gentoo.org> abiword-2.0.3-r1.ebuild :
+ Add documentation support per USE flag, fix provided by khai in #36974
09 Feb 2004; <gustavoz@gentoo.org> abiword-2.0.2.ebuild:
stable on hppa and sparc
diff --git a/app-office/abiword/abiword-2.0.3-r1.ebuild b/app-office/abiword/abiword-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..aca25559172e
--- /dev/null
+++ b/app-office/abiword/abiword-2.0.3-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-2.0.3-r1.ebuild,v 1.1 2004/02/18 15:59:40 foser Exp $
+
+inherit eutils
+
+IUSE="spell jpeg xml2 gnome debug doc"
+
+S_P=${S}/${PN}-plugins
+S_D=${S}/${PN}-docs
+S=${WORKDIR}/${P}/abi
+
+DESCRIPTION="Fully featured yet light and fast cross platform word processor"
+HOMEPAGE="http://www.abisource.com"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+LICENSE="GPL-2"
+SLOT="2"
+
+RDEPEND="virtual/x11
+ virtual/xft
+ >=media-libs/fontconfig-2.1
+ media-libs/libpng
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ >=app-text/wv-1
+ >=dev-libs/fribidi-0.10.4
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ ( xml2? >=dev-libs/libxml2-2.4.10 : dev-libs/expat )
+ spell? ( >=app-text/enchant-1 )
+ gnome? ( >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libgnomeprint-2.2.1
+ >=gnome-base/libgnomeprintui-2.2.1
+ >=gnome-base/libbonobo-2 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/automake
+ dev-util/pkgconfig"
+
+src_compile() {
+
+ # this is a hack since I don't want to go hack in the gnome-vfs headerfiles.
+ # The issue is about gnome-vfs containing "long long" which makes gcc 3.3.1 balk
+ cp configure configure.old
+ cat configure.old |sed s:-pedantic::g >configure
+ rm -f configure.old
+
+ econf \
+ `use_enable gnome` \
+ `use_with xml2 libxml2` \
+ `use_enable spell enchant` \
+ `use_enable debug` \
+ --enable-bidi \
+ --enable-threads \
+ --without-ImageMagick \
+ --disable-scripting \
+ --with-sys-wv || die
+
+ emake all-recursive || die
+
+ # Build plugins
+
+ cd ${S_P}
+
+ econf \
+ `use_enable debug` \
+ --enable-all \
+ --with-abiword=${S} \
+ --without-ImageMagick || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ dodir /usr/{bin,lib}
+
+ einstall PERLDEST=${D} || die
+
+ dosed "s:Exec=abiword:Exec=abiword-2.0:" /usr/share/applications/abiword.desktop
+
+ rm -f ${D}/usr/bin/abiword-2.0
+ rm -f ${D}/usr/bin/abiword
+ dosym AbiWord-2.0 /usr/bin/abiword-2.0
+
+ dodoc COPYING *.TXT docs/build/BUILD.TXT user/wp/readme.txt
+
+ # install plugins
+
+ cd ${S_P}
+
+ make DESTDIR=${D} install || die
+
+ # install documentation
+
+ use doc && (
+ cd ${WORKDIR}/${P}/abiword-docs
+ sed -e 's:prefix = /usr/local:prefix = /usr:g' Makefile > Makefile.new
+ mv Makefile.new Makefile
+ make DESTDIR=${D} || die
+ )
+
+}
+
+USE_DESTDIR="1"
diff --git a/app-office/abiword/files/digest-abiword-2.0.3-r1 b/app-office/abiword/files/digest-abiword-2.0.3-r1
new file mode 100644
index 000000000000..a253760d64df
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-2.0.3-r1
@@ -0,0 +1 @@
+MD5 aa97aec08c353356dcb95b7634b56e9d abiword-2.0.3.tar.bz2 22072758