summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 14:19:23 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 14:19:23 +0000
commit519d935b531ef52927f46676af55135e76cde8f4 (patch)
tree619eb59f61b3a5e08c0d6bcc40995e6d0e919f83 /app-office
parentsanitize patch so it doesn't get mangled by cvs (#55319) (Manifest recommit) (diff)
downloadgentoo-2-519d935b531ef52927f46676af55135e76cde8f4.tar.gz
gentoo-2-519d935b531ef52927f46676af55135e76cde8f4.tar.bz2
gentoo-2-519d935b531ef52927f46676af55135e76cde8f4.zip
change glibc to libc
Diffstat (limited to 'app-office')
-rw-r--r--app-office/dia2code/dia2code-0.8.1.ebuild21
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.0.3.1.ebuild17
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.1.0.ebuild20
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.1.1.ebuild20
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.1.2.ebuild20
5 files changed, 43 insertions, 55 deletions
diff --git a/app-office/dia2code/dia2code-0.8.1.ebuild b/app-office/dia2code/dia2code-0.8.1.ebuild
index b1dd0e5f07b2..a982623ed48d 100644
--- a/app-office/dia2code/dia2code-0.8.1.ebuild
+++ b/app-office/dia2code/dia2code-0.8.1.ebuild
@@ -1,33 +1,32 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/dia2code/dia2code-0.8.1.ebuild,v 1.12 2004/06/24 22:39:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia2code/dia2code-0.8.1.ebuild,v 1.13 2004/06/28 14:15:53 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="Convert UML diagrams produced with Dia to various source code flavours."
+HOMEPAGE="http://dia2code.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-HOMEPAGE="http://dia2code.sourceforge.net"
-KEYWORDS="x86 ppc amd64 sparc"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 ppc sparc amd64"
+IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
dev-libs/libxml2"
-
RDEPEND="${DEPEND}
>=app-office/dia-0.90.0"
-
src_compile () {
# libxml2 header fix
- CFLAGS="${CFLAGS} -I/usr/include/libxml2/libxml"
- ./configure --prefix=/usr \
- --host="${CHOST}"
+ append-flags -I/usr/include/libxml2/libxml
+ econf || die
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog README TODO
doman dia2code.1
}
-
diff --git a/app-office/openoffice-bin/openoffice-bin-1.0.3.1.ebuild b/app-office/openoffice-bin/openoffice-bin-1.0.3.1.ebuild
index c81f0fe6c337..e9e01bb709c3 100644
--- a/app-office/openoffice-bin/openoffice-bin-1.0.3.1.ebuild
+++ b/app-office/openoffice-bin/openoffice-bin-1.0.3.1.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.0.3.1.ebuild,v 1.7 2004/06/24 22:43:43 agriffis Exp $
-
-IUSE="kde gnome"
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.0.3.1.ebuild,v 1.8 2004/06/28 14:19:23 vapier Exp $
inherit virtualx
@@ -24,13 +22,18 @@ else
fi;
DESCRIPTION="OpenOffice productivity suite"
+HOMEPAGE="http://www.openoffice.org/"
SRC_URI="x86? ( http://ny1.mirror.openoffice.org/stable/${PV//.1/}/OOo_${MY_PV}_LinuxIntel_install.tar.gz
http://sf1.mirror.openoffice.org/stable/${PV//.1/}/OOo_${MY_PV}_LinuxIntel_install.tar.gz
http://vlaai.snt.utwente.nl/pub/software/openoffice/stable/${PV//.1/}/libvcl641li.so.gz )
ppc? ( ftp://ftp.yellowdoglinux.com/pub/yellowdog/software/openoffice/OOo_${MY_PV}_LinuxPowerPC_installer.tar.gz )"
-HOMEPAGE="http://www.openoffice.org"
-DEPEND="virtual/glibc
+LICENSE="LGPL-2 | SISSL-1.1"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc"
+IUSE="kde gnome"
+
+DEPEND="virtual/libc
>=dev-lang/perl-5.0
virtual/x11
app-arch/zip
@@ -38,10 +41,6 @@ DEPEND="virtual/glibc
|| ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 )
!app-office/openoffice"
-LICENSE="LGPL-2 | SISSL-1.1"
-SLOT="0"
-KEYWORDS="~x86 -ppc -sparc"
-
src_install() {
# Sandbox issues; bug #8587
diff --git a/app-office/openoffice-bin/openoffice-bin-1.1.0.ebuild b/app-office/openoffice-bin/openoffice-bin-1.1.0.ebuild
index f97218341b2c..ceaaf0ac3264 100644
--- a/app-office/openoffice-bin/openoffice-bin-1.1.0.ebuild
+++ b/app-office/openoffice-bin/openoffice-bin-1.1.0.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.0.ebuild,v 1.10 2004/06/24 22:43:43 agriffis Exp $
-
-IUSE="kde gnome"
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.0.ebuild,v 1.11 2004/06/28 14:19:23 vapier Exp $
# NOTE: There are two big issues that should be addressed.
#
@@ -16,11 +14,16 @@ MY_P="OOo_${MY_PV}_LinuxIntel_install"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="OpenOffice productivity suite"
+HOMEPAGE="http://www.openoffice.org/"
SRC_URI="ftp://ftp.ussg.iu.edu/pub/openoffice/stable/${PV}/OOo_${PV}_LinuxIntel_install.tar.gz"
-HOMEPAGE="http://www.openoffice.org"
+
+LICENSE="LGPL-2 | SISSL-1.1"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc ~amd64"
+IUSE="kde gnome"
DEPEND="sys-apps/findutils
- virtual/glibc
+ virtual/libc
>=dev-lang/perl-5.0
virtual/x11
app-arch/zip
@@ -28,8 +31,7 @@ DEPEND="sys-apps/findutils
|| ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 )
!app-office/openoffice
amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )"
-
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
>=dev-lang/perl-5.0
virtual/x11
app-arch/zip
@@ -38,10 +40,6 @@ RDEPEND="virtual/glibc
!app-office/openoffice
amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )"
-LICENSE="LGPL-2 | SISSL-1.1"
-SLOT="0"
-KEYWORDS="x86 -ppc -sparc ~amd64"
-
src_install() {
# Sandbox issues; bug #8587
addpredict "/user"
diff --git a/app-office/openoffice-bin/openoffice-bin-1.1.1.ebuild b/app-office/openoffice-bin/openoffice-bin-1.1.1.ebuild
index 1ea9878f80fc..a3e060356b16 100644
--- a/app-office/openoffice-bin/openoffice-bin-1.1.1.ebuild
+++ b/app-office/openoffice-bin/openoffice-bin-1.1.1.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.1.ebuild,v 1.10 2004/06/24 22:43:43 agriffis Exp $
-
-IUSE="kde gnome"
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.1.ebuild,v 1.11 2004/06/28 14:19:23 vapier Exp $
# NOTE: There are two big issues that should be addressed.
#
@@ -17,15 +15,18 @@ use ppc && MY_P="OOo_${PV}_LinuxPowerPC_en_installer"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="OpenOffice productivity suite"
-
+HOMEPAGE="http://www.openoffice.org/"
SRC_URI="x86? ( mirror://openoffice/stable/${PV}/OOo_${PV}_LinuxIntel_install.tar.gz )
amd64? ( mirror://openoffice/stable/${PV}/OOo_${PV}_LinuxIntel_install.tar.gz )
ppc? ( http://ftp.sunet.se/pub/Office/OpenOffice.org/contrib/linuxppc/OOo_${PV}_LinuxPowerPC_en_installer.tar.gz )"
-HOMEPAGE="http://www.openoffice.org"
+LICENSE="LGPL-2 | SISSL-1.1"
+SLOT="0"
+KEYWORDS="x86 ppc -sparc ~amd64"
+IUSE="kde gnome"
DEPEND="sys-apps/findutils
- virtual/glibc
+ virtual/libc
>=dev-lang/perl-5.0
virtual/x11
app-arch/zip
@@ -33,8 +34,7 @@ DEPEND="sys-apps/findutils
|| ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 )
!app-office/openoffice
amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )"
-
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
>=dev-lang/perl-5.0
virtual/x11
app-arch/zip
@@ -43,10 +43,6 @@ RDEPEND="virtual/glibc
!app-office/openoffice
amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )"
-LICENSE="LGPL-2 | SISSL-1.1"
-SLOT="0"
-KEYWORDS="x86 ppc -sparc ~amd64"
-
src_install() {
# Sandbox issues; bug #8587
addpredict "/user"
diff --git a/app-office/openoffice-bin/openoffice-bin-1.1.2.ebuild b/app-office/openoffice-bin/openoffice-bin-1.1.2.ebuild
index d215e1c34fcd..ee90bce29554 100644
--- a/app-office/openoffice-bin/openoffice-bin-1.1.2.ebuild
+++ b/app-office/openoffice-bin/openoffice-bin-1.1.2.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.2.ebuild,v 1.2 2004/06/24 22:43:43 agriffis Exp $
-
-IUSE="kde gnome"
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.2.ebuild,v 1.3 2004/06/28 14:19:23 vapier Exp $
# NOTE: There are two big issues that should be addressed.
#
@@ -17,14 +15,17 @@ use ppc && MY_P="OOo_${PV}_LinuxPowerPC_en_installer"
S="${WORKDIR}/${MY_P}"
DESCRIPTION="OpenOffice productivity suite"
-
+HOMEPAGE="http://www.openoffice.org/"
SRC_URI="x86? ( mirror://openoffice/stable/${PV}/OOo_${PV}_LinuxIntel_install.tar.gz )
amd64? ( mirror://openoffice/stable/${PV}/OOo_${PV}_LinuxIntel_install.tar.gz )"
-HOMEPAGE="http://www.openoffice.org"
+LICENSE="LGPL-2 | SISSL-1.1"
+SLOT="0"
+KEYWORDS="~x86 -sparc"
+IUSE="kde gnome"
DEPEND="sys-apps/findutils
- virtual/glibc
+ virtual/libc
>=dev-lang/perl-5.0
virtual/x11
app-arch/zip
@@ -32,8 +33,7 @@ DEPEND="sys-apps/findutils
|| ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 )
!app-office/openoffice
amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )"
-
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
>=dev-lang/perl-5.0
virtual/x11
app-arch/zip
@@ -42,10 +42,6 @@ RDEPEND="virtual/glibc
!app-office/openoffice
amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )"
-LICENSE="LGPL-2 | SISSL-1.1"
-SLOT="0"
-KEYWORDS="~x86 -sparc"
-
src_install() {
# Sandbox issues; bug #8587
addpredict "/user"