summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-02-07 21:10:50 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-02-07 21:10:50 +0000
commit7de752d894753e50a2ff64e8026996e7a8ca5848 (patch)
tree8d5ca60800fc6a074d922ffb655f6c64becbe621 /app-office
parentDirectly inherit multilib, thanks to Arfrever for reporting. (diff)
downloadgentoo-2-7de752d894753e50a2ff64e8026996e7a8ca5848.tar.gz
gentoo-2-7de752d894753e50a2ff64e8026996e7a8ca5848.tar.bz2
gentoo-2-7de752d894753e50a2ff64e8026996e7a8ca5848.zip
Add patch to fix build with Qt 4.8, bug 399291. Backport from Calligra.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice-libs/ChangeLog11
-rw-r--r--app-office/koffice-libs/files/koffice-libs-2.3.3-qt48.patch42
-rw-r--r--app-office/koffice-libs/koffice-libs-2.3.3-r2.ebuild (renamed from app-office/koffice-libs/koffice-libs-2.3.3.ebuild)16
3 files changed, 63 insertions, 6 deletions
diff --git a/app-office/koffice-libs/ChangeLog b/app-office/koffice-libs/ChangeLog
index 72757a065925..d2051336665e 100644
--- a/app-office/koffice-libs/ChangeLog
+++ b/app-office/koffice-libs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/koffice-libs
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/ChangeLog,v 1.133 2011/10/01 03:21:29 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/ChangeLog,v 1.134 2012/02/07 21:10:50 dilfridge Exp $
+
+*koffice-libs-2.3.3-r2 (07 Feb 2012)
+
+ 07 Feb 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ -koffice-libs-2.3.3.ebuild, +koffice-libs-2.3.3-r2.ebuild,
+ +files/koffice-libs-2.3.3-qt48.patch:
+ Add patch to fix build with Qt 4.8, bug 399291. Backport from Calligra.
01 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org>
koffice-libs-2.3.3-r1.ebuild:
diff --git a/app-office/koffice-libs/files/koffice-libs-2.3.3-qt48.patch b/app-office/koffice-libs/files/koffice-libs-2.3.3-qt48.patch
new file mode 100644
index 000000000000..9cd8c68acd29
--- /dev/null
+++ b/app-office/koffice-libs/files/koffice-libs-2.3.3-qt48.patch
@@ -0,0 +1,42 @@
+From accabfeac22e869e5a248a764a64096d107e4c7c Mon Sep 17 00:00:00 2001
+From: Michael Jansen <kde@michael-jansen.biz>
+Date: Mon, 11 Jul 2011 00:27:38 +0200
+Subject: [PATCH] Fix build with QT 4.8.
+
+KDChartBackgroundAttributes.cpp:153:26: error: ambiguous overload for 'operator<<' in '((QDebug*)((QDebug*)operator<<(QDebug, const QBrush&)(((const QBrush&)((const QBrush*)(& KDChart::BackgroundAttributes::brush() const())))).QDebug::operator<<(((const char*)"pixmapmode=")))->QDebug::operator<<(((int)((const KDChart::BackgroundAttributes*)ba)->KDChart::BackgroundAttributes::pixmapMode())))->QDebug::operator<<(((const char*)"pixmap=")) << KDChart::BackgroundAttributes::pixmap() const()'
+
+It does not know if it should convert QPixmap to QVariant or QBrush before dumping it into
+qDebug(). It happens because with qt4.8 qvariant is included implictely with klocale.h over
+qlocale.h. Which was not the case before qt4.8.
+
+Related: QTBUG-19764: Please add QDebug operator for QPixmap
+---
+ .../kdchart/src/KDChartBackgroundAttributes.cpp | 5 ++++-
+ 1 files changed, 4 insertions(+), 1 deletions(-)
+
+diff --git a/plugins/chartshape/kdchart/src/KDChartBackgroundAttributes.cpp b/plugins/chartshape/kdchart/src/KDChartBackgroundAttributes.cpp
+index 2dc4974..9f2990a 100644
+--- a/plugins/chartshape/kdchart/src/KDChartBackgroundAttributes.cpp
++++ b/plugins/chartshape/kdchart/src/KDChartBackgroundAttributes.cpp
+@@ -22,6 +22,9 @@
+
+ #include "KDChartBackgroundAttributes.h"
+ #include <QPixmap>
++#if !defined(QT_NO_DEBUG_STREAM)
++#include <QVariant>
++#endif
+
+ #include <KDABLibFakes>
+
+@@ -150,7 +153,7 @@ QDebug operator<<(QDebug dbg, const KDChart::BackgroundAttributes& ba)
+ << "visible="<<ba.isVisible()
+ << "brush="<<ba.brush()
+ << "pixmapmode="<<ba.pixmapMode()
+- << "pixmap="<<ba.pixmap()
++ << "pixmap="<<QVariant(ba.pixmap())
+ << ")";
+ return dbg;
+ }
+--
+1.7.3.4
+
diff --git a/app-office/koffice-libs/koffice-libs-2.3.3.ebuild b/app-office/koffice-libs/koffice-libs-2.3.3-r2.ebuild
index 746cc06b0587..1c19ea361182 100644
--- a/app-office/koffice-libs/koffice-libs-2.3.3.ebuild
+++ b/app-office/koffice-libs/koffice-libs-2.3.3-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/koffice-libs-2.3.3.ebuild,v 1.5 2011/06/07 03:06:16 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/koffice-libs-2.3.3-r2.ebuild,v 1.1 2012/02/07 21:10:50 dilfridge Exp $
EAPI=3
@@ -10,8 +10,8 @@ OPENGL_REQUIRED="optional"
CPPUNIT_REQUIRED="optional"
inherit kde4-meta
-DESCRIPTION="Shared KOffice libraries."
-KEYWORDS="amd64 x86"
+DESCRIPTION="Shared KOffice libraries"
+KEYWORDS="~amd64 ~x86"
IUSE="crypt openexr reports"
RDEPEND="
@@ -54,6 +54,11 @@ KMEXTRACTONLY="
KMSAVELIBS="true"
+RESTRICT=test
+# bug 385025
+
+PATCHES=( "${FILESDIR}/${P}-qt48.patch" )
+
src_configure() {
mycmakeargs=(
$(cmake-utils_use_with crypt QCA2)
@@ -78,4 +83,7 @@ src_install() {
# this is already installed by koffice-data
rm -f "${D}/usr/include/config-opengl.h"
rm -f "${D}/usr/include/KoConfig.h"
+
+ # this is not useful and only leads to error messages, bug 381955
+ rm -f "${D}/usr/share/applications/kde4/koffice.desktop"
}