summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-11-01 10:44:45 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-11-01 10:44:45 +0000
commita11952d15e10c1c880035ba728237a40efb40495 (patch)
treee4b6c8a4fed76ea55699b70a9c13adfd8dae1fce /app-office
parentbump (diff)
downloadgentoo-2-a11952d15e10c1c880035ba728237a40efb40495.tar.gz
gentoo-2-a11952d15e10c1c880035ba728237a40efb40495.tar.bz2
gentoo-2-a11952d15e10c1c880035ba728237a40efb40495.zip
Version bump, bug #501562. Fix homepage.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gtg/ChangeLog10
-rw-r--r--app-office/gtg/files/gtg-0.3.1-desktop.patch13
-rw-r--r--app-office/gtg/files/gtg-0.3.1-locales.patch20
-rw-r--r--app-office/gtg/gtg-0.3.1.ebuild74
4 files changed, 115 insertions, 2 deletions
diff --git a/app-office/gtg/ChangeLog b/app-office/gtg/ChangeLog
index fc14f289cc3b..a7c96f9baea8 100644
--- a/app-office/gtg/ChangeLog
+++ b/app-office/gtg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/gtg
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/gtg/ChangeLog,v 1.14 2013/02/04 23:16:31 eva Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gtg/ChangeLog,v 1.15 2014/11/01 10:44:45 eva Exp $
+
+*gtg-0.3.1 (01 Nov 2014)
+
+ 01 Nov 2014; Gilles Dartiguelongue <eva@gentoo.org> +gtg-0.3.1.ebuild,
+ +files/gtg-0.3.1-desktop.patch, +files/gtg-0.3.1-locales.patch:
+ Version bump, bug #501562. Fix homepage.
*gtg-0.3 (04 Feb 2013)
diff --git a/app-office/gtg/files/gtg-0.3.1-desktop.patch b/app-office/gtg/files/gtg-0.3.1-desktop.patch
new file mode 100644
index 000000000000..82db6ce36f3b
--- /dev/null
+++ b/app-office/gtg/files/gtg-0.3.1-desktop.patch
@@ -0,0 +1,13 @@
+Fix desktop-file-validate warning.
+
+--- a/gtg.desktop 2014-11-01 11:23:31.101881704 +0100
++++ b/gtg.desktop 2014-11-01 11:23:37.349775014 +0100
+@@ -14,7 +14,7 @@
+ StartupNotify=true
+ X-Ayatana-Desktop-Shortcuts=NewTask
+
+-[NewTask Shortcut Group]
++[X-NewTask Shortcut Group]
+ Name=New Task
+ Exec=gtg_new_task
+ TargetEnvironment=Unity
diff --git a/app-office/gtg/files/gtg-0.3.1-locales.patch b/app-office/gtg/files/gtg-0.3.1-locales.patch
new file mode 100644
index 000000000000..56bf5ce5e9b1
--- /dev/null
+++ b/app-office/gtg/files/gtg-0.3.1-locales.patch
@@ -0,0 +1,20 @@
+Do not install unwanted locales.
+
+--- a/setup.py 2014-11-01 11:21:49.679613605 +0100
++++ b/setup.py 2014-11-01 11:26:36.305719135 +0100
+@@ -101,9 +101,15 @@
+
+ PO_DIR = 'po'
+ MO_DIR = os.path.join('build', 'po')
++LINGUAS = os.environ.get('LINGUAS', '*').split(' ')
+
+ for po in glob.glob(os.path.join(PO_DIR, '*.po')):
+ lang = os.path.basename(po[:-3])
++
++ # Skip unwanted locales
++ if lang not in LINGUAS and '*' not in LINGUAS:
++ continue
++
+ mo = os.path.join(MO_DIR, lang, 'gtg.mo')
+ target_dir = os.path.dirname(mo)
+ if not os.path.isdir(target_dir):
diff --git a/app-office/gtg/gtg-0.3.1.ebuild b/app-office/gtg/gtg-0.3.1.ebuild
new file mode 100644
index 000000000000..390441118dc0
--- /dev/null
+++ b/app-office/gtg/gtg-0.3.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gtg/gtg-0.3.1.ebuild,v 1.1 2014/11/01 10:44:45 eva Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils fdo-mime gnome2-utils distutils-r1 versionator
+
+MY_PV="$(get_version_component_range 1-2)"
+DESCRIPTION="Personal organizer for the GNOME desktop environment"
+HOMEPAGE="http://gtgnome.net/"
+SRC_URI="http://launchpad.net/${PN}/${MY_PV}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/liblarch[${PYTHON_USEDEP}]
+ dev-python/notify-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ # Plugins are voluntarily left automagic as application has a nice way
+ # to suggest missing dependencies. We only remove the ones that cannot
+ # work on gentoo.
+ # Backends should be enabled via USE flag when pulling extra deps
+
+ # geoloc: uses removed from tree bindings
+ sed -e "/GTG.plugins.geolocalized_tasks',/d" \
+ -e "/geolocalized-tasks.gtg-plugin/d" \
+ -i setup.py || die
+
+ # launchpad: missing dependency
+ # evolution: missing python-r1 support
+ rm GTG/backends/backend_launchpad.py \
+ GTG/backends/backend_evolution.py \
+ || die
+
+ # Respect LINGUAS
+ epatch "${FILESDIR}"/${PN}-0.3.1-locales.patch
+
+ # Fix validation warning
+ epatch "${FILESDIR}"/${PN}-0.3.1-desktop.patch
+
+ distutils-r1_python_prepare_all
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}