summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-05 17:29:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-05 17:29:25 +0000
commit1b810711fc23a719e1ac6f51a9157da68311e640 (patch)
treeb3a3cfbb7ea5c75150c7a40542be13641ca09605 /app-pda/usbmuxd
parentremove neurogeek add proxy-maintainers (diff)
downloadgentoo-2-1b810711fc23a719e1ac6f51a9157da68311e640.tar.gz
gentoo-2-1b810711fc23a719e1ac6f51a9157da68311e640.tar.bz2
gentoo-2-1b810711fc23a719e1ac6f51a9157da68311e640.zip
FindUSB.cmake file doesn't seem to work with dev-util/cmake >= 2.8.8 so defining -DUSB_INCLUDE_DIR by hand wrt #414601
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-pda/usbmuxd')
-rw-r--r--app-pda/usbmuxd/ChangeLog6
-rw-r--r--app-pda/usbmuxd/usbmuxd-1.0.8.ebuild11
2 files changed, 15 insertions, 2 deletions
diff --git a/app-pda/usbmuxd/ChangeLog b/app-pda/usbmuxd/ChangeLog
index bc90e0175dc2..8ee7185821c0 100644
--- a/app-pda/usbmuxd/ChangeLog
+++ b/app-pda/usbmuxd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/usbmuxd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/usbmuxd/ChangeLog,v 1.18 2012/04/12 14:46:23 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/usbmuxd/ChangeLog,v 1.19 2012/05/05 17:29:25 ssuominen Exp $
+
+ 05 May 2012; Samuli Suominen <ssuominen@gentoo.org> usbmuxd-1.0.8.ebuild:
+ FindUSB.cmake file doesn't seem to work with dev-util/cmake >= 2.8.8 so
+ defining -DUSB_INCLUDE_DIR by hand wrt #414601
12 Apr 2012; Samuli Suominen <ssuominen@gentoo.org> usbmuxd-1.0.8.ebuild:
Change from eutils.eclass to user.eclass for enewgroup() and enewuser().
diff --git a/app-pda/usbmuxd/usbmuxd-1.0.8.ebuild b/app-pda/usbmuxd/usbmuxd-1.0.8.ebuild
index 1e85fa9e21db..bdeb62486dd3 100644
--- a/app-pda/usbmuxd/usbmuxd-1.0.8.ebuild
+++ b/app-pda/usbmuxd/usbmuxd-1.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/usbmuxd/usbmuxd-1.0.8.ebuild,v 1.2 2012/04/12 14:46:23 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/usbmuxd/usbmuxd-1.0.8.ebuild,v 1.3 2012/05/05 17:29:25 ssuominen Exp $
EAPI=4
inherit cmake-utils user
@@ -25,3 +25,12 @@ pkg_setup() {
}
DOCS="AUTHORS README README.devel"
+
+src_configure() {
+ # Modules/FindUSB.cmake is broken wrt #414601
+ local mycmakeargs=(
+ -DUSB_INCLUDE_DIR=/usr/include/libusb-1.0
+ )
+
+ cmake-utils_src_configure
+}