summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-01-16 18:41:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-01-16 18:41:10 +0000
commit1ee1ebf7a8813b93a94a6f792ffb9c77a65fdae3 (patch)
tree6012dd565ba0ea98a4d48ba7715758c40e48df39 /app-pda
parentVersion bump (diff)
downloadgentoo-2-1ee1ebf7a8813b93a94a6f792ffb9c77a65fdae3.tar.gz
gentoo-2-1ee1ebf7a8813b93a94a6f792ffb9c77a65fdae3.tar.bz2
gentoo-2-1ee1ebf7a8813b93a94a6f792ffb9c77a65fdae3.zip
Remove python support because it's unused and broken wrt #451044 by Michelangelo Scopelliti
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libimobiledevice/ChangeLog11
-rw-r--r--app-pda/libimobiledevice/libimobiledevice-1.1.4-r3.ebuild56
2 files changed, 65 insertions, 2 deletions
diff --git a/app-pda/libimobiledevice/ChangeLog b/app-pda/libimobiledevice/ChangeLog
index cca080002f7d..eaab066f7ae3 100644
--- a/app-pda/libimobiledevice/ChangeLog
+++ b/app-pda/libimobiledevice/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-pda/libimobiledevice
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.38 2012/12/31 14:16:44 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/ChangeLog,v 1.39 2013/01/16 18:41:10 ssuominen Exp $
+
+*libimobiledevice-1.1.4-r3 (16 Jan 2013)
+
+ 16 Jan 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +libimobiledevice-1.1.4-r3.ebuild:
+ Remove python support because it's unused and broken wrt #451044 by
+ Michelangelo Scopelliti
31 Dec 2012; Agostino Sarubbo <ago@gentoo.org>
libimobiledevice-1.1.4-r2.ebuild:
diff --git a/app-pda/libimobiledevice/libimobiledevice-1.1.4-r3.ebuild b/app-pda/libimobiledevice/libimobiledevice-1.1.4-r3.ebuild
new file mode 100644
index 000000000000..6f7a27d35a70
--- /dev/null
+++ b/app-pda/libimobiledevice/libimobiledevice-1.1.4-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libimobiledevice/libimobiledevice-1.1.4-r3.ebuild,v 1.1 2013/01/16 18:41:10 ssuominen Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Support library to communicate with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="gnutls"
+
+RDEPEND=">=app-pda/libplist-1.8-r1
+ >=app-pda/usbmuxd-1.0.8
+ gnutls? (
+ dev-libs/libgcrypt
+ >=dev-libs/libtasn1-1.1
+ >=net-libs/gnutls-2.2.0
+ )
+ !gnutls? ( dev-libs/openssl:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS NEWS README"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-openssl.patch \
+ "${FILESDIR}"/${P}-HOME-segfault.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ # Disable python support wrt #451044, look at -1.1.4-r2
+ # from Attic if you need to restore it.
+
+ local myconf
+ use gnutls && myconf='--disable-openssl'
+
+ econf \
+ --disable-static \
+ --without-cython \
+ ${myconf}
+}
+
+src_install() {
+ default
+ dohtml docs/html/*
+
+ prune_libtool_files --all
+}