summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-02-15 11:41:39 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-02-15 11:41:39 +0000
commit37f8acd0b18e2ec8f9f5956bb5d82baca3e5767b (patch)
treeab12108bb3073fe598e906e6322d400b332bb055 /app-pda
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-37f8acd0b18e2ec8f9f5956bb5d82baca3e5767b.tar.gz
gentoo-2-37f8acd0b18e2ec8f9f5956bb5d82baca3e5767b.tar.bz2
gentoo-2-37f8acd0b18e2ec8f9f5956bb5d82baca3e5767b.zip
add treo600 patch
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/gnome-pilot/ChangeLog8
-rw-r--r--app-pda/gnome-pilot/files/gnome-pilot-2.0.10-treo600.patch19
-rw-r--r--app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild7
3 files changed, 30 insertions, 4 deletions
diff --git a/app-pda/gnome-pilot/ChangeLog b/app-pda/gnome-pilot/ChangeLog
index b1de91d5ad43..098061dc2de7 100644
--- a/app-pda/gnome-pilot/ChangeLog
+++ b/app-pda/gnome-pilot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/gnome-pilot
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/ChangeLog,v 1.8 2003/12/14 01:06:20 pylon Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/ChangeLog,v 1.9 2004/02/15 11:41:39 liquidx Exp $
+
+ 04 Feb 2004; Alastair Tse <liquidx@gentoo.org> gnome-pilot-2.0.10-r1.ebuild,
+ files/gnome-pilot-2.0.10-treo600.patch:
+ add patch to support treo600 (#39004)
14 Dec 2003; Lars Weiler <pylon@gentoo.org> gnome-pilot-2.0.10-r1.ebuild:
Make stable on ppc
diff --git a/app-pda/gnome-pilot/files/gnome-pilot-2.0.10-treo600.patch b/app-pda/gnome-pilot/files/gnome-pilot-2.0.10-treo600.patch
new file mode 100644
index 000000000000..f647a986ce62
--- /dev/null
+++ b/app-pda/gnome-pilot/files/gnome-pilot-2.0.10-treo600.patch
@@ -0,0 +1,19 @@
+diff -ur gnome-pilot-2.0.10-treo600/gpilotd/gpilotd.c gnome-pilot-2.0.10/gpilotd/gpilotd.c
+--- gnome-pilot-2.0.10-treo600/gpilotd/gpilotd.c 2003-07-16 10:25:16.000000000 -0600
++++ gnome-pilot-2.0.10/gpilotd/gpilotd.c 2003-10-23 21:18:13.000000000 -0600
+@@ -791,6 +791,7 @@
+ {
+ "Vendor=082d ProdID=0100", /* Handspring Visor/Treo 300 */
+ "Vendor=082d ProdID=0200", /* Handspring Treo */
++ "Vendor=082d ProdID=0300", /* Handspring Treo 600*/
+ "Vendor=0830 ProdID=0001", /* Palm M500 */
+ "Vendor=0830 ProdID=0002", /* Palm M505 */
+ "Vendor=0830 ProdID=0003", /* Palm M515 */
+@@ -832,6 +833,7 @@
+ TRUE,
+ TRUE,
+ TRUE,
++ TRUE,
+ -1
+ };
+
diff --git a/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild b/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild
index 876b623917c4..25a337398852 100644
--- a/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild
+++ b/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild,v 1.5 2003/12/14 01:06:21 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild,v 1.6 2004/02/15 11:41:39 liquidx Exp $
inherit gnome2 eutils
@@ -36,4 +36,7 @@ src_unpack() {
# patch to fix crashes with memo file syncing
# http://bugzilla.gnome.org/show_bug.cgi?id=114361
epatch ${FILESDIR}/${P}-memofile.patch
+ # add treo600 support
+ # http://bugzilla.gnome.org/show_bug.cgi?id=124254
+ epatch ${FILESDIR}/${P}-treo600.patch
}