summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-13 13:38:01 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-13 13:38:01 +0000
commit65adc819019a5de948d6332a9913797d31039cda (patch)
treea01f16dfa605b44349799652b0f439e9a315707b /app-pda
parentx86 stable, bug 327777 (diff)
downloadgentoo-2-65adc819019a5de948d6332a9913797d31039cda.tar.gz
gentoo-2-65adc819019a5de948d6332a9913797d31039cda.tar.bz2
gentoo-2-65adc819019a5de948d6332a9913797d31039cda.zip
Upstream doc/Makefile.am is using datadir instead of docdir or htmldir for .html manual path wrt #246924 by Diego E. Pettenò.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/jpilot-Mail/ChangeLog9
-rw-r--r--app-pda/jpilot-Mail/jpilot-Mail-0.1.7.ebuild36
2 files changed, 30 insertions, 15 deletions
diff --git a/app-pda/jpilot-Mail/ChangeLog b/app-pda/jpilot-Mail/ChangeLog
index fb01be868a70..ef5026a6f64d 100644
--- a/app-pda/jpilot-Mail/ChangeLog
+++ b/app-pda/jpilot-Mail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/jpilot-Mail
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot-Mail/ChangeLog,v 1.1 2007/09/18 17:11:15 philantrop Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot-Mail/ChangeLog,v 1.2 2010/07/13 13:38:01 ssuominen Exp $
+
+ 13 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
+ jpilot-Mail-0.1.7.ebuild:
+ Upstream doc/Makefile.am is using datadir instead of docdir or htmldir for
+ .html manual path wrt #246924 by Diego E. Pettenò.
*jpilot-Mail-0.1.7 (18 Sep 2007)
diff --git a/app-pda/jpilot-Mail/jpilot-Mail-0.1.7.ebuild b/app-pda/jpilot-Mail/jpilot-Mail-0.1.7.ebuild
index 3347d16da79f..9dad5a33e85e 100644
--- a/app-pda/jpilot-Mail/jpilot-Mail-0.1.7.ebuild
+++ b/app-pda/jpilot-Mail/jpilot-Mail-0.1.7.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot-Mail/jpilot-Mail-0.1.7.ebuild,v 1.1 2007/09/18 17:11:15 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/jpilot-Mail/jpilot-Mail-0.1.7.ebuild,v 1.2 2010/07/13 13:38:01 ssuominen Exp $
+EAPI=2
inherit eutils multilib
DESCRIPTION="jpilot-Mail is a jpilot plugin to deliver mail from the pilot and upload mail to it."
@@ -13,22 +14,31 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=x11-libs/gtk+-2
- >=app-pda/jpilot-0.99.7-r1"
-RDEPEND="${DEPEND}"
+RDEPEND=">=x11-libs/gtk+-2
+ >=app-pda/jpilot-0.99.7-r1"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}/${P}.patch"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_configure() {
+ econf \
+ --enable-gtk2
}
src_compile() {
- econf --enable-gtk2 || die "configure failed"
- emake -j1 || die "make failed"
+ emake -j1 || die
}
src_install() {
- make install DESTDIR="${D}" \
- libdir=/usr/$(get_libdir)/jpilot/plugins \
- || die "install failed"
+ emake DESTDIR="${D}" \
+ datadir="/usr/share/doc/${PF}/html" \
+ libdir="/usr/$(get_libdir)/jpilot/plugins" \
+ install || die
+
+ dodoc AUTHORS ChangeLog README TODO
+
+ find "${D}" -name '*.la' -delete
}