summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-01-23 09:35:08 +0000
committerJonathan Callen <abcd@gentoo.org>2010-01-23 09:35:08 +0000
commit74fcd73929320487b66844dccaa4b1c912a0343e (patch)
tree171a1a8f417edd4fbf296ead88bf071f8c406396 /app-pda
parentVersion bump (diff)
downloadgentoo-2-74fcd73929320487b66844dccaa4b1c912a0343e.tar.gz
gentoo-2-74fcd73929320487b66844dccaa4b1c912a0343e.tar.bz2
gentoo-2-74fcd73929320487b66844dccaa4b1c912a0343e.zip
Avoid calling libpng-config when png is not installed; add prefix support; keyword ~amd64-linux/~x86-linux
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/pilot-link/ChangeLog7
-rw-r--r--app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild14
2 files changed, 13 insertions, 8 deletions
diff --git a/app-pda/pilot-link/ChangeLog b/app-pda/pilot-link/ChangeLog
index 3eaec0b6d519..792c97c18aa3 100644
--- a/app-pda/pilot-link/ChangeLog
+++ b/app-pda/pilot-link/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-pda/pilot-link
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.52 2010/01/19 02:45:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.53 2010/01/23 09:35:08 abcd Exp $
+
+ 23 Jan 2010; Jonathan Callen <abcd@gentoo.org>
+ pilot-link-0.12.3-r2.ebuild:
+ Avoid calling libpng-config when png is not installed; add prefix support;
+ keyword ~amd64-linux/~x86-linux
19 Jan 2010; Jeroen Roovers <jer@gentoo.org> pilot-link-0.12.3-r1.ebuild:
Stable for HPPA too.
diff --git a/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild b/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild
index 562d48b4b813..aafbe620bd2e 100644
--- a/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild,v 1.5 2009/07/01 09:42:08 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild,v 1.6 2010/01/23 09:35:08 abcd Exp $
EAPI=2
@@ -12,7 +12,7 @@ SRC_URI="http://pilot-link.org/source/${P}.tar.bz2"
LICENSE="|| ( GPL-2 LGPL-2 )"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="perl java python png readline threads bluetooth usb debug"
@@ -65,9 +65,10 @@ src_prepare() {
}
src_configure() {
+ use prefix || EPREFIX=
# tcl/tk support is disabled as per upstream request.
econf \
- --includedir=/usr/include/libpisock \
+ --includedir="${EPREFIX}"/usr/include/libpisock \
--enable-conduits \
--with-tcl=no \
--without-included-popt \
@@ -75,13 +76,12 @@ src_configure() {
$(use_enable threads) \
$(use_enable usb libusb) \
$(use_enable debug) \
- $(use_with png libpng $(libpng-config --prefix)) \
+ $(use_with png libpng "${EPREFIX}"/usr) \
$(use_with bluetooth bluez) \
$(use_with readline) \
$(use_with perl) \
$(use_with java) \
- $(use_with python) \
- || die "econf failed"
+ $(use_with python)
}
src_compile() {