summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-11 13:19:44 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-11 13:19:44 +0000
commite46b5cacfe0d9ef94624d34fbb57bfaae0fcdf73 (patch)
tree2abda919bf96487e2ebe9acc790bb88ae849727a /app-pda
parentAdd a patch to fix fcrontab -u systab when using PAM. Thanks to Dmitry Karasi... (diff)
downloadgentoo-2-e46b5cacfe0d9ef94624d34fbb57bfaae0fcdf73.tar.gz
gentoo-2-e46b5cacfe0d9ef94624d34fbb57bfaae0fcdf73.tar.bz2
gentoo-2-e46b5cacfe0d9ef94624d34fbb57bfaae0fcdf73.zip
Fix building with libpng14.
(Portage version: 2.2_rc66/cvs/Linux x86_64)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/pilot-link/ChangeLog6
-rw-r--r--app-pda/pilot-link/files/pilot-link-0.12.3-libpng14.patch98
-rw-r--r--app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild7
3 files changed, 107 insertions, 4 deletions
diff --git a/app-pda/pilot-link/ChangeLog b/app-pda/pilot-link/ChangeLog
index 792c97c18aa3..7cb0c59fdc53 100644
--- a/app-pda/pilot-link/ChangeLog
+++ b/app-pda/pilot-link/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/pilot-link
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.53 2010/01/23 09:35:08 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.54 2010/03/11 13:19:42 ssuominen Exp $
+
+ 11 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ pilot-link-0.12.3-r2.ebuild, +files/pilot-link-0.12.3-libpng14.patch:
+ Fix building with libpng14.
23 Jan 2010; Jonathan Callen <abcd@gentoo.org>
pilot-link-0.12.3-r2.ebuild:
diff --git a/app-pda/pilot-link/files/pilot-link-0.12.3-libpng14.patch b/app-pda/pilot-link/files/pilot-link-0.12.3-libpng14.patch
new file mode 100644
index 000000000000..14b8c16ac3b1
--- /dev/null
+++ b/app-pda/pilot-link/files/pilot-link-0.12.3-libpng14.patch
@@ -0,0 +1,98 @@
+http://repos.archlinux.org/wsvn/packages/pilot-link/trunk/pilot-link-png14.patch
+
+--- src/pilot-read-notepad.c
++++ src/pilot-read-notepad.c
+@@ -39,10 +39,6 @@
+
+ #ifdef HAVE_PNG
+ #include "png.h"
+-#if (PNG_LIBPNG_VER < 10201)
+- #define png_voidp_NULL (png_voidp)NULL
+- #define png_error_ptr_NULL (png_error_ptr)NULL
+-#endif
+ #endif
+
+ const char *progname;
+@@ -166,8 +162,8 @@
+ width = n->body.width + 8;
+
+ png_ptr = png_create_write_struct
+- ( PNG_LIBPNG_VER_STRING, png_voidp_NULL,
+- png_error_ptr_NULL, png_error_ptr_NULL);
++ ( PNG_LIBPNG_VER_STRING, NULL,
++ NULL, NULL);
+
+ if(!png_ptr)
+ return;
+--- src/pilot-read-palmpix.c
++++ src/pilot-read-palmpix.c
+@@ -42,10 +42,6 @@
+
+ #ifdef HAVE_PNG
+ #include "png.h"
+-#if (PNG_LIBPNG_VER < 10201)
+- #define png_voidp_NULL (png_voidp)NULL
+- #define png_error_ptr_NULL (png_error_ptr)NULL
+-#endif
+ #endif
+
+ const char *progname;
+@@ -223,8 +219,8 @@
+ png_infop info_ptr;
+
+ png_ptr = png_create_write_struct
+- ( PNG_LIBPNG_VER_STRING, png_voidp_NULL,
+- png_error_ptr_NULL, png_error_ptr_NULL);
++ ( PNG_LIBPNG_VER_STRING, NULL,
++ NULL, NULL);
+
+ if(!png_ptr)
+ return;
+--- src/pilot-read-screenshot.c
++++ src/pilot-read-screenshot.c
+@@ -40,10 +40,6 @@
+
+ #ifdef HAVE_PNG
+ # include "png.h"
+-# if (PNG_LIBPNG_VER < 10201)
+-# define png_voidp_NULL (png_voidp)NULL
+-# define png_error_ptr_NULL (png_error_ptr)NULL
+-# endif
+ #endif
+
+ #define pi_mktag(c1,c2,c3,c4) (((c1)<<24)|((c2)<<16)|((c3)<<8)|(c4))
+@@ -87,8 +83,8 @@
+ gray_buf = malloc( state->w );
+
+ png_ptr = png_create_write_struct
+- (PNG_LIBPNG_VER_STRING, png_voidp_NULL,
+- png_error_ptr_NULL, png_error_ptr_NULL);
++ (PNG_LIBPNG_VER_STRING, NULL,
++ NULL, NULL);
+
+ if (!png_ptr)
+ return;
+--- src/pilot-read-veo.c
++++ src/pilot-read-veo.c
+@@ -41,10 +41,6 @@
+
+ #ifdef HAVE_PNG
+ # include "png.h"
+-# if (PNG_LIBPNG_VER < 10201)
+-# define png_voidp_NULL (png_voidp)NULL
+-# define png_error_ptr_NULL (png_error_ptr)NULL
+-# endif
+ #endif
+
+ #define pi_mktag(c1,c2,c3,c4) (((c1)<<24)|((c2)<<16)|((c3)<<8)|(c4))
+@@ -856,8 +852,8 @@
+ png_infop info_ptr;
+
+ png_ptr = png_create_write_struct
+- (PNG_LIBPNG_VER_STRING, png_voidp_NULL,
+- png_error_ptr_NULL, png_error_ptr_NULL);
++ (PNG_LIBPNG_VER_STRING, NULL,
++ NULL, NULL);
+
+ if (!png_ptr)
+ return;
diff --git a/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild b/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild
index aafbe620bd2e..4d1848267abb 100644
--- a/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild,v 1.6 2010/01/23 09:35:08 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3-r2.ebuild,v 1.7 2010/03/11 13:19:42 ssuominen Exp $
EAPI=2
@@ -21,7 +21,7 @@ BOTH_DEPEND="virtual/libiconv
>=dev-libs/popt-1.10.7
perl? ( >=dev-lang/perl-5.8.8-r2 )
python? ( >=dev-lang/python-2.4.4-r4 )
- png? ( >=media-libs/libpng-1.2.18-r1 )
+ png? ( >=media-libs/libpng-1.2.40 )
readline? ( >=sys-libs/readline-5.2_p4 )
usb? ( virtual/libusb:0 )
bluetooth? ( || ( >=net-wireless/bluez-libs-3.10 net-wireless/bluez ) )"
@@ -36,7 +36,8 @@ src_prepare() {
# Fixing some broken configure switches and automagic deps.
epatch "${FILESDIR}/${PN}-0.12.2-readline.patch"
epatch "${FILESDIR}/${PN}-0.12.2-threads.patch"
- epatch "${FILESDIR}/${P}-png.patch"
+ epatch "${FILESDIR}"/${P}-png.patch \
+ "${FILESDIR}"/${P}-libpng14.patch
# Upstream's check for Werror was wrong. Fixes bug 194921.
epatch "${FILESDIR}/${PN}-0.12.2-werror_194921.patch"