summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-01 19:09:18 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-01 19:09:18 +0000
commitf1840ed5eeaa229f12bf9ad7a534a9f29466386e (patch)
tree7bb43bc61bf2addb4039ee8e8a19fc19222b1666 /app-pda
parentVersion bump. (diff)
downloadgentoo-2-f1840ed5eeaa229f12bf9ad7a534a9f29466386e.tar.gz
gentoo-2-f1840ed5eeaa229f12bf9ad7a534a9f29466386e.tar.bz2
gentoo-2-f1840ed5eeaa229f12bf9ad7a534a9f29466386e.zip
Fix building with latest automake-1.13, plus other improvements, see ChangeLog
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/gtkpod/ChangeLog10
-rw-r--r--app-pda/gtkpod/gtkpod-2.1.3-r1.ebuild47
2 files changed, 37 insertions, 20 deletions
diff --git a/app-pda/gtkpod/ChangeLog b/app-pda/gtkpod/ChangeLog
index ede61b8db052..b9efb4ed6b2d 100644
--- a/app-pda/gtkpod/ChangeLog
+++ b/app-pda/gtkpod/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-pda/gtkpod
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gtkpod/ChangeLog,v 1.125 2013/04/12 04:25:34 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gtkpod/ChangeLog,v 1.126 2013/05/01 19:09:18 ssuominen Exp $
+
+ 01 May 2013; Samuli Suominen <ssuominen@gentoo.org> gtkpod-2.1.3-r1.ebuild:
+ Use AC_CONFIG_HEADERS instead of AM_CONFIG_HEADER for automake-1.13
+ compability wrt #467598 by Ian Stakenvicius.
+ Punt GTK+ related "DEPRECATED" preprocessor flags for forward compability.
+ Fix USE="cdr" dependencies since the plug-in links to -lgstreamer-0.10.
+ Compress gst-element-check-0.10.m4 to SRC_URI instead of using hard DEPEND
+ for media-libs/gstreamer (as required by eautoreconf).
12 Apr 2013; Samuli Suominen <ssuominen@gentoo.org> gtkpod-2.1.3-r1.ebuild:
Force more recent dev-util/anjuta too in addition to dev-libs/gdl
diff --git a/app-pda/gtkpod/gtkpod-2.1.3-r1.ebuild b/app-pda/gtkpod/gtkpod-2.1.3-r1.ebuild
index 42ccc6a69177..df62ca8661bd 100644
--- a/app-pda/gtkpod/gtkpod-2.1.3-r1.ebuild
+++ b/app-pda/gtkpod/gtkpod-2.1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gtkpod/gtkpod-2.1.3-r1.ebuild,v 1.5 2013/04/12 04:25:34 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gtkpod/gtkpod-2.1.3-r1.ebuild,v 1.6 2013/05/01 19:09:18 ssuominen Exp $
EAPI=5
@@ -8,61 +8,70 @@ inherit autotools eutils gnome2-utils
DESCRIPTION="A graphical user interface to the Apple productline"
HOMEPAGE="http://gtkpod.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ http://dev.gentoo.org/~ssuominen/gst-element-check-0.10.m4.xz"
LICENSE="GPL-2 FDL-1.2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="aac clutter curl cdr flac gstreamer mp3 vorbis webkit"
+# watch out for possible musicbrainz:5 compability in next version?
COMMON_DEPEND="
>=dev-libs/gdl-3.6:3
>=dev-libs/glib-2.28.5
>=dev-libs/libxml2-2.7.7
>=dev-util/anjuta-3.6
- >=media-libs/libgpod-0.7.0
+ >=media-libs/libgpod-0.8.2:=
>=media-libs/libid3tag-0.15
>=x11-libs/gtk+-3.0.8:3
aac? ( media-libs/faad2 )
clutter? ( media-libs/clutter-gtk:1.0 )
curl? ( >=net-misc/curl-7.10 )
- cdr? (
- >=app-cdr/brasero-3
- media-libs/musicbrainz:3
- )
flac? ( media-libs/flac )
- gstreamer? ( >=media-libs/gst-plugins-base-0.10.25:0.10 )
+ gstreamer? (
+ >=media-libs/gstreamer-0.10.25:0.10
+ >=media-libs/gst-plugins-base-0.10.25:0.10
+ cdr? (
+ >=app-cdr/brasero-3
+ media-libs/musicbrainz:3
+ )
+ )
mp3? ( media-sound/lame )
vorbis? (
media-libs/libvorbis
media-sound/vorbis-tools
)
webkit? ( >=net-libs/webkit-gtk-1.3:3 )"
+# to pull in at least -flac and -vorbis plugins , but others at the same time
RDEPEND="${COMMON_DEPEND}
gstreamer? ( media-plugins/gst-plugins-meta:0.10 )"
DEPEND="${COMMON_DEPEND}
dev-util/intltool
- media-libs/gstreamer:0.10
sys-devel/flex
sys-devel/gettext
virtual/os-headers
virtual/pkgconfig"
-# media-libs/gstreamer is always required for gst-element-check-0.10.m4 and
-# eautoreconf
+REQUIRED_USE="cdr? ( gstreamer )"
src_prepare() {
- # Make sure SLOT="4" is not used. Everyone should move from "3" to "5" directly.
- sed -i -e '/PKG_CHECK_MODULES/s:libmusicbrainz4:&sLoT4iSdEpReCaTeD:' configure.ac || die
+ epatch \
+ "${FILESDIR}"/${P}-gdl-3.6.patch \
+ "${FILESDIR}"/${P}-gold.patch
+ sed -i -e 's:python:python2:' scripts/sync-palm-jppy.py || die
+ # punt deprecated flags for forward compability
+ # use more widely used musicbrainz:3 instead of :4
+ # use AC_CONFIG_HEADERS for automake-1.13 compability wrt #467598
+ sed -e 's:CLEANLINESS_FLAGS=".*:CLEANLINESS_FLAGS="":' \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ -e '/PKG_CHECK_MODULES/s:libmusicbrainz4:&sLoT4iSdEpReCaTeD:' \
+ -i configure.ac || die
# /path/to/install: '/path/to/app-pda/gtkpod-2.1.2_beta2/image/usr/share/gtkpod/data/rhythmbox.gep’: File exists
sed -i -e '/^dist_profiles_DATA/s:=.*:=:' plugins/sjcd/data/Makefile.am || die
- sed -i -e 's:python:python2:' scripts/sync-palm-jppy.py || die
-
- epatch \
- "${FILESDIR}"/${P}-gdl-3.6.patch \
- "${FILESDIR}"/${P}-gold.patch
- eautoreconf
+ # m4dir for gst-element-check-0.10.m4
+ AT_M4DIR=${WORKDIR} eautoreconf
}
src_configure() {