summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-02-12 03:51:19 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-02-12 03:51:19 +0000
commitf7396ea57451e3c7e7e9f8c2bf5dbbd1503df914 (patch)
tree2916b15969ba8cf4606f7c6f7cef321bae5cd12b /app-pda
parentgstreamer herd is the sole maintainer of gstreamer and related ebuilds, which... (diff)
downloadgentoo-2-f7396ea57451e3c7e7e9f8c2bf5dbbd1503df914.tar.gz
gentoo-2-f7396ea57451e3c7e7e9f8c2bf5dbbd1503df914.tar.bz2
gentoo-2-f7396ea57451e3c7e7e9f8c2bf5dbbd1503df914.zip
Revision bump, remove broken version.
- fix dependencies (bug #354407) - use CMake native module for FindPythonLibs (bug #276220 with thanks to John W Eckhart) - support multiabi python (bug #311763) and fix bindings getting built with USE="-python" - drop test USE flag since tests are still restricted - port to EAPI 3 (Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/libopensync/ChangeLog17
-rw-r--r--app-pda/libopensync/libopensync-0.39-r1.ebuild126
-rw-r--r--app-pda/libopensync/libopensync-0.39.ebuild69
3 files changed, 141 insertions, 71 deletions
diff --git a/app-pda/libopensync/ChangeLog b/app-pda/libopensync/ChangeLog
index 7c06739b554e..50e6c2cfccc8 100644
--- a/app-pda/libopensync/ChangeLog
+++ b/app-pda/libopensync/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for app-pda/libopensync
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/ChangeLog,v 1.37 2010/09/27 13:07:35 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/ChangeLog,v 1.38 2011/02/12 03:51:19 dirtyepic Exp $
+
+*libopensync-0.39-r1 (12 Feb 2011)
+
+ 12 Feb 2011; Ryan Hill <dirtyepic@gentoo.org> -libopensync-0.39.ebuild,
+ +libopensync-0.39-r1.ebuild:
+ Revision bump, remove broken version.
+ - fix dependencies (bug #354407)
+ - use CMake native module for FindPythonLibs (bug #276220 with thanks
+ to John W Eckhart)
+ - support multiabi python (bug #311763) and fix bindings getting built
+ with USE="-python"
+ - drop test USE flag since tests are still restricted
+ - port to EAPI 3
27 Sep 2010; Diego E. Pettenò <flameeyes@gentoo.org>
-libopensync-0.38.ebuild:
diff --git a/app-pda/libopensync/libopensync-0.39-r1.ebuild b/app-pda/libopensync/libopensync-0.39-r1.ebuild
new file mode 100644
index 000000000000..12468765201b
--- /dev/null
+++ b/app-pda/libopensync/libopensync-0.39-r1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-0.39-r1.ebuild,v 1.1 2011/02/12 03:51:19 dirtyepic Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="python? 2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit cmake-utils python
+
+DESCRIPTION="OpenSync synchronisation framework library"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="doc python" # test
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-libs/glib-2.12:2
+ dev-libs/libxml2
+ dev-libs/libxslt"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ doc? ( app-doc/doxygen
+ media-gfx/graphviz )
+ python? ( >=dev-lang/swig-1.3.17 )"
+# test? ( >=dev-libs/check-0.9.2 )"
+
+# 14% tests passed, 275 tests failed out of 321
+RESTRICT="test"
+
+DOCS="AUTHORS CODING ChangeLog README"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+#CMAKE_VERBOSE="1"
+
+src_prepare() {
+ # Has hardcoded python versions, use the module shipped with cmake instead
+ # bug #276220
+ rm "${S}"/cmake/modules/FindPythonLibs.cmake
+
+ use python && python_copy_sources
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DCMAKE_SKIP_RPATH=ON
+ $(cmake-utils_use_build doc DOCUMENTATION)
+ $(cmake-utils_use_enable python WRAPPER)
+ $(cmake-utils_use python OPENSYNC_PYTHONBINDINGS)
+ $(cmake-utils_use test OPENSYNC_UNITTESTS)"
+
+ do_configure() {
+ if use python; then
+ CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
+ CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
+ # since we're using cmake's FindPythonLibs PYTHON_VERSION is
+ # not defined
+ sed -i -e "s:\${PYTHON_VERSION}:${PYTHON_ABI}:g" \
+ "${CMAKE_BUILD_DIR}"/wrapper/CMakeLists.txt
+ fi
+ cmake-utils_src_configure || die
+ }
+
+ use python \
+ && python_execute_function -s do_configure \
+ || do_configure
+}
+
+src_compile() {
+ do_compile() {
+ if use python; then
+ CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
+ CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
+ fi
+ cmake-utils_src_compile || die
+ }
+
+ use python \
+ && python_execute_function -s do_compile \
+ || do_compile
+
+ if use doc ; then
+ cmake-utils_src_make DoxygenDoc || die
+ fi
+}
+
+# TODO - fix
+src_test() {
+ pushd "${CMAKE_BUILD_DIR}" > /dev/null
+
+ if ! LD_LIBRARY_PATH="${CMAKE_BUILD_DIR}/opensync/" emake -j1 test ; then
+ die "Make test failed. See above for details."
+ fi
+
+ popd > /dev/null
+}
+
+src_install() {
+ do_install() {
+ if use python; then
+ CMAKE_BUILD_DIR="${WORKDIR}/${P}-${PYTHON_ABI}"
+ CMAKE_USE_DIR="${CMAKE_BUILD_DIR}"
+ fi
+ cmake-utils_src_install || die
+ }
+
+ use python \
+ && python_execute_function -s do_install \
+ || do_install
+
+ if use doc; then
+ cd "${CMAKE_BUILD_DIR}"
+ dohtml docs/html/* || die
+ fi
+}
+
+pkg_postinst() {
+ einfo "For >=app-pda/libopensync-0.39 use app-pda/osynctool instead of"
+ einfo "the older app-pda/msynctool."
+}
diff --git a/app-pda/libopensync/libopensync-0.39.ebuild b/app-pda/libopensync/libopensync-0.39.ebuild
deleted file mode 100644
index 7d9343e2a0b5..000000000000
--- a/app-pda/libopensync/libopensync-0.39.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync/libopensync-0.39.ebuild,v 1.3 2010/05/23 20:38:01 bangert Exp $
-
-inherit cmake-utils
-
-DESCRIPTION="OpenSync synchronisation framework library"
-HOMEPAGE="http://www.opensync.org/"
-SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE="doc python test"
-
-# 14% tests passed, 275 tests failed out of 321
-RESTRICT="test"
-
-RDEPEND=">=dev-db/sqlite-3
- >=dev-libs/glib-2.12
- dev-libs/libxml2
- python? ( >=dev-lang/python-2.2 )"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.9.0
- doc? ( app-doc/doxygen )
- python? ( >=dev-lang/swig-1.3.17 )
- test? ( >=dev-libs/check-0.9.2 )"
-
-src_compile() {
- DOCS="AUTHORS CODING ChangeLog README"
-
- local mycmakeargs="
- -DCMAKE_SKIP_RPATH=ON
- $(cmake-utils_use_enable python WRAPPER)
- $(cmake-utils_use_build doc DOCUMENTATION)
- $(cmake-utils_use test OPENSYNC_UNITTESTS)
- "
-
- cmake-utils_src_compile
-
- if use doc ; then
- cmake-utils_src_make DoxygenDoc || die "Failed to generate docs."
- fi
-}
-
-src_test() {
- pushd "${CMAKE_BUILD_DIR}" > /dev/null
-
- if ! LD_LIBRARY_PATH="${CMAKE_BUILD_DIR}/opensync/" emake -j1 test ; then
- die "Make test failed. See above for details."
- fi
-
- popd > /dev/null
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use doc ; then
- cd "${CMAKE_BUILD_DIR}"
- dohtml docs/html/* || die "Failed to install docs."
- fi
-}
-
-pkg_postinst() {
- einfo "For >=app-pda/libopensync-0.39 use app-pda/osynctool instead of"
- einfo "the older app-pda/msynctool."
-}