summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-10-01 00:05:14 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-10-01 00:05:14 +0000
commit14f390406a5287b2b1566aa3b878b9161559a1af (patch)
tree9ddac8544138112a8e852875849e3df5d3524742 /app-portage
parentSparc stable early at developer request --- Bug #170220 --- there haven't (diff)
downloadgentoo-2-14f390406a5287b2b1566aa3b878b9161559a1af.tar.gz
gentoo-2-14f390406a5287b2b1566aa3b878b9161559a1af.tar.bz2
gentoo-2-14f390406a5287b2b1566aa3b878b9161559a1af.zip
Bump, fixing bug 239199. This version fixes bug 238942, weirdness w/ portage sqlite backends.
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc8 x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog8
-rw-r--r--app-portage/eix/eix-0.14.0.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 7e0ca6383d64..18146d92fa62 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.247 2008/09/24 07:02:45 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.248 2008/10/01 00:05:14 loki_val Exp $
+
+*eix-0.14.0 (01 Oct 2008)
+
+ 01 Oct 2008; Peter Alfredsen <loki_val@gentoo.org> +eix-0.14.0.ebuild:
+ Bump, fixing bug 239199. This version fixes bug 238942, weirdness w/
+ portage sqlite backends.
24 Sep 2008; Stefan Schweizer <genstef@gentoo.org> -eix-0.12.4.ebuild:
remove old buggy version
diff --git a/app-portage/eix/eix-0.14.0.ebuild b/app-portage/eix/eix-0.14.0.ebuild
new file mode 100644
index 000000000000..08786d62e97a
--- /dev/null
+++ b/app-portage/eix/eix-0.14.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.14.0.ebuild,v 1.1 2008/10/01 00:05:14 loki_val Exp $
+
+DESCRIPTION="Small utility for searching ebuilds with indexing for fast results"
+HOMEPAGE="http://eix.sourceforge.net"
+SRC_URI="mirror://sourceforge/eix/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="doc sqlite"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ app-arch/bzip2"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/docutils )"
+
+src_compile() {
+ econf --with-bzip2 $(use_with sqlite) $(use_with doc rst) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog doc/format.txt
+ use doc && dodoc doc/format.html
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "Security Warning:"
+ ewarn
+ ewarn "Since >=eix-0.12.0, eix uses by default OVERLAY_CACHE_METHOD=\"parse|ebuild*\""
+ ewarn "This is rather reliable, but ebuilds may be executed by user \"portage\". Set"
+ ewarn "OVERLAY_CACHE_METHOD=parse in /etc/eixrc if you do not trust the ebuilds."
+ if test -d /var/log && ! test -x /var/log || test -e /var/log/eix-sync.log
+ then
+ einfo
+ einfo "eix-sync no longer supports redirection to /var/log/eix-sync.log"
+ einfo "You can remove that file."
+ fi
+}