summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-06-26 22:04:56 +0000
committerMichał Górny <mgorny@gentoo.org>2011-06-26 22:04:56 +0000
commit3c37a37a8af6cfadf7f9b7d60368247b25e3594f (patch)
tree282200b7b29cb4a5796279ab31f045317661661f /app-portage
parentarm stable, bug #372333 (diff)
downloadgentoo-2-3c37a37a8af6cfadf7f9b7d60368247b25e3594f.tar.gz
gentoo-2-3c37a37a8af6cfadf7f9b7d60368247b25e3594f.tar.bz2
gentoo-2-3c37a37a8af6cfadf7f9b7d60368247b25e3594f.zip
Restore the old version due to portage argument passing broken in 1.0.
(Portage version: 2.2.0_alpha41_p25/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/smart-live-rebuild/ChangeLog6
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-0.8.1.ebuild31
2 files changed, 36 insertions, 1 deletions
diff --git a/app-portage/smart-live-rebuild/ChangeLog b/app-portage/smart-live-rebuild/ChangeLog
index 720fcc0c5dae..c3b685422ff3 100644
--- a/app-portage/smart-live-rebuild/ChangeLog
+++ b/app-portage/smart-live-rebuild/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-portage/smart-live-rebuild
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/ChangeLog,v 1.18 2011/06/25 13:05:45 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/ChangeLog,v 1.19 2011/06/26 22:04:56 mgorny Exp $
+
+ 26 Jun 2011; Michał Górny <mgorny@gentoo.org>
+ +smart-live-rebuild-0.8.1.ebuild:
+ Restore the old version due to portage argument passing broken in 1.0.
*smart-live-rebuild-1.0 (25 Jun 2011)
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-0.8.1.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-0.8.1.ebuild
new file mode 100644
index 000000000000..10fd6b591feb
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-0.8.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/smart-live-rebuild/smart-live-rebuild-0.8.1.ebuild,v 1.3 2011/06/26 22:04:56 mgorny Exp $
+
+EAPI=3
+PYTHON_DEPEND='*:2.6'
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS='2.4 2.5'
+inherit distutils
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
+SRC_URI="http://cloud.github.com/downloads/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1.8.3"
+
+PYTHON_MODNAME=SmartLiveRebuild
+
+src_install() {
+ distutils_src_install
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,} || die
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example ${PN}.conf || die
+}