summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-03-12 16:14:57 +0000
committerMike Frysinger <vapier@gentoo.org>2013-03-12 16:14:57 +0000
commit86099d9d2fc94e428c3300d18db19a2220faea81 (patch)
tree177d22b9794b2405f4a586b620c0e078626c66af /app-portage
parentStable for HPPA (bug #461378). (diff)
downloadgentoo-2-86099d9d2fc94e428c3300d18db19a2220faea81.tar.gz
gentoo-2-86099d9d2fc94e428c3300d18db19a2220faea81.tar.bz2
gentoo-2-86099d9d2fc94e428c3300d18db19a2220faea81.zip
Also respect PORTAGE_CONFIGROOT in various utils.
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoolkit/ChangeLog8
-rw-r--r--app-portage/gentoolkit/files/0.3.0.7-configroot.patch25
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.3.0.7-r2.ebuild96
3 files changed, 128 insertions, 1 deletions
diff --git a/app-portage/gentoolkit/ChangeLog b/app-portage/gentoolkit/ChangeLog
index 24dde60dd0d1..1ae6c38d3e24 100644
--- a/app-portage/gentoolkit/ChangeLog
+++ b/app-portage/gentoolkit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/gentoolkit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.292 2013/02/25 18:03:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/ChangeLog,v 1.293 2013/03/12 16:14:57 vapier Exp $
+
+*gentoolkit-0.3.0.7-r2 (12 Mar 2013)
+
+ 12 Mar 2013; Mike Frysinger <vapier@gentoo.org>
+ +files/0.3.0.7-configroot.patch, +gentoolkit-0.3.0.7-r2.ebuild:
+ Also respect PORTAGE_CONFIGROOT in various utils.
*gentoolkit-0.3.0.7-r1 (25 Feb 2013)
diff --git a/app-portage/gentoolkit/files/0.3.0.7-configroot.patch b/app-portage/gentoolkit/files/0.3.0.7-configroot.patch
new file mode 100644
index 000000000000..74dc1e025362
--- /dev/null
+++ b/app-portage/gentoolkit/files/0.3.0.7-configroot.patch
@@ -0,0 +1,25 @@
+From 95648e0369e74d65582ee3ef44b0a0a338f82cf0 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 12 Mar 2013 12:08:56 -0400
+Subject: [PATCH] equery: respect PORTAGE_CONFIGROOT too
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ pym/gentoolkit/package.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/pym/gentoolkit/package.py b/pym/gentoolkit/package.py
+index 2a103de..da9d65c 100644
+--- a/pym/gentoolkit/package.py
++++ b/pym/gentoolkit/package.py
+@@ -61,6 +61,7 @@ from gentoolkit.eprefix import EPREFIX
+ def _NewPortageConfig(local_config):
+ ret = portage.config(local_config=local_config,
+ eprefix=EPREFIX if EPREFIX else None,
++ config_root=os.environ.get('PORTAGE_CONFIGROOT', None),
+ target_root=os.environ.get('ROOT', None))
+ ret.lock()
+ return ret
+--
+1.8.1.2
+
diff --git a/app-portage/gentoolkit/gentoolkit-0.3.0.7-r2.ebuild b/app-portage/gentoolkit/gentoolkit-0.3.0.7-r2.ebuild
new file mode 100644
index 000000000000..373b01b9336a
--- /dev/null
+++ b/app-portage/gentoolkit/gentoolkit-0.3.0.7-r2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/gentoolkit/gentoolkit-0.3.0.7-r2.ebuild,v 1.1 2013/03/12 16:14:57 vapier Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.[45]"
+PYTHON_USE_WITH="xml"
+PYTHON_NONVERSIONED_EXECUTABLES=(".*")
+
+inherit distutils python eutils
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/tools/index.xml"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Note: dev-lang/python dependencies are so emerge will print a blocker if any
+# installed slot of python is not built with +xml. This is used since
+# PYTHON_USE_WITH just dies in the middle of the emerge. See bug 399331.
+DEPEND="sys-apps/portage"
+RDEPEND="${DEPEND}
+ >=dev-lang/python-2.6[xml]
+ !>=dev-lang/python-2.6[-xml]
+ !<=app-portage/gentoolkit-dev-0.2.7
+ || ( >=sys-apps/coreutils-8.15 app-misc/realpath sys-freebsd/freebsd-bin )
+ sys-apps/gawk
+ sys-apps/grep
+ virtual/python-argparse"
+
+distutils_src_compile_pre_hook() {
+ echo VERSION="${PVR}" "$(PYTHON)" setup.py set_version
+ VERSION="${PVR}" "$(PYTHON)" setup.py set_version \
+ || die "setup.py set_version failed"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-root.patch
+ epatch "${FILESDIR}"/${PV}-configroot.patch
+}
+
+src_install() {
+ python_convert_shebangs -r "" build-*/scripts-*
+ distutils_src_install
+
+ # Rename the python versions of revdep-rebuild, since we are not ready
+ # to switch to the python version yet. Link /usr/bin/revdep-rebuild to
+ # revdep-rebuild.sh. Leaving the python version available for potential
+ # testing by a wider audience.
+ mv "${ED}"/usr/bin/revdep-rebuild "${ED}"/usr/bin/revdep-rebuild.py
+ dosym revdep-rebuild.sh /usr/bin/revdep-rebuild
+
+ # Create cache directory for revdep-rebuild
+ dodir /var/cache/revdep-rebuild
+ keepdir /var/cache/revdep-rebuild
+ use prefix || fowners root:root /var/cache/revdep-rebuild
+ fperms 0700 /var/cache/revdep-rebuild
+
+ # remove on Gentoo Prefix platforms where it's broken anyway
+ if use prefix; then
+ elog "The revdep-rebuild command is removed, the preserve-libs"
+ elog "feature of portage will handle issues."
+ rm "${ED}"/usr/bin/revdep-rebuild*
+ rm "${ED}"/usr/share/man/man1/revdep-rebuild.1
+ rm -rf "${ED}"/etc/revdep-rebuild
+ rm -rf "${ED}"/var
+ fi
+
+ # Can distutils handle this?
+ dosym eclean /usr/bin/eclean-dist
+ dosym eclean /usr/bin/eclean-pkg
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ einfo
+ einfo "For further information on gentoolkit, please read the gentoolkit"
+ einfo "guide: http://www.gentoo.org/doc/en/gentoolkit.xml"
+ einfo
+ einfo "Another alternative to equery is app-portage/portage-utils"
+ einfo
+ einfo "Additional tools that may be of interest:"
+ einfo
+ einfo " app-admin/eclean-kernel"
+ einfo " app-portage/diffmask"
+ einfo " app-portage/flaggie"
+ einfo " app-portage/install-mask"
+ einfo " app-portage/portpeek"
+ einfo " app-portage/smart-live-rebuild"
+}