summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-10-29 18:15:01 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-10-29 18:15:01 +0000
commit86f08e3604dc5a2245ceb8a7e6a1d1abab6528d3 (patch)
tree99f2c8f86bfd70ff75d6747ae35678b83b43c562 /app-portage
parentAdding a patch to fix regression in event loop. Thanks to scarabeus@g.o for p... (diff)
downloadgentoo-2-86f08e3604dc5a2245ceb8a7e6a1d1abab6528d3.tar.gz
gentoo-2-86f08e3604dc5a2245ceb8a7e6a1d1abab6528d3.tar.bz2
gentoo-2-86f08e3604dc5a2245ceb8a7e6a1d1abab6528d3.zip
Version bump with new optimization USE flags and code cleanup. Closes bugs 288514 & 288031
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog9
-rw-r--r--app-portage/eix/eix-0.18.3.ebuild (renamed from app-portage/eix/eix-0.18.0.ebuild)32
-rw-r--r--app-portage/eix/metadata.xml6
3 files changed, 22 insertions, 25 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index b8ab26486aaa..f5d0b743fadd 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.308 2009/10/10 23:53:30 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.309 2009/10/29 18:15:01 darkside Exp $
+
+*eix-0.18.3 (29 Oct 2009)
+
+ 29 Oct 2009; Jeremy Olexa <darkside@gentoo.org> -eix-0.18.0.ebuild,
+ +eix-0.18.3.ebuild, metadata.xml:
+ Version bump with new optimization USE flags and code cleanup. Closes bugs
+ 288514 & 288031
*eix-0.18.2 (10 Oct 2009)
diff --git a/app-portage/eix/eix-0.18.0.ebuild b/app-portage/eix/eix-0.18.3.ebuild
index 58fdd73cc130..1ff2d5969a18 100644
--- a/app-portage/eix/eix-0.18.0.ebuild
+++ b/app-portage/eix/eix-0.18.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.18.0.ebuild,v 1.1 2009/09/20 03:07:00 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.18.3.ebuild,v 1.1 2009/10/29 18:15:01 darkside Exp $
EAPI="2"
-inherit multilib
+inherit multilib autotools
DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
HOMEPAGE="http://eix.sourceforge.net"
@@ -12,8 +12,8 @@ SRC_URI="mirror://sourceforge/eix/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="+bzip2 deprecated doc nls sqlite tools"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="+bzip2 debug deprecated doc +hardened nls +optimization strong-optimization sqlite tools"
RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
nls? ( virtual/libintl )
@@ -37,34 +37,21 @@ src_unpack() {
src_configure() {
econf $(use_with bzip2) $(use_with sqlite) $(use_with doc rst) \
$(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable hardened security) $(use_enable optimization) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
--with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
--with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
$(use_enable deprecated obsolete-reminder)
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog doc/format.txt
- use doc && dodoc doc/format.html
+ prepalldocs
}
pkg_postinst() {
- elog "Ask your overlay maintainers to provide metadata or consider to run"
- elog " egencache --repo=foo --update"
- elog "after updates (e.g. in /etc/eix-sync)."
- elog "This will speed up portage and eix-update (when the new default cache method"
- elog "\"...#metadata-flat\" is used and file dates are correct) for those overlays."
- elog "If metadata is provided but file dates are mangled during overlay updates,"
- elog "you may switch to cache method \"metadata-flat\" instead for that overlay:"
- elog "This is even faster, but works only if metadata is actually up-to-date."
- ewarn
- ewarn "Security Warning:"
- ewarn
- ewarn "Since >=eix-0.12.0, eix uses by default OVERLAY_CACHE_METHOD=\"parse|ebuild*\""
- ewarn "(since >=eix-0.16.1 with automagic \"#metadata-flat\")."
- ewarn "This is rather reliable, but ebuilds may be executed by user \"portage\". Set"
- ewarn "OVERLAY_CACHE_METHOD=parse in /etc/eixrc if you do not trust the ebuilds."
if use deprecated; then
elog "ATTENTION: The old eix executable names will be going away soon"
elog "Update your scripts"
@@ -72,5 +59,4 @@ pkg_postinst() {
elog "ATTENTION: The eix executable names have changed. Update your"
elog "scripts, if needed. This message will go away soon."
fi
-
}
diff --git a/app-portage/eix/metadata.xml b/app-portage/eix/metadata.xml
index b7deff3dcb52..57c6f8466a20 100644
--- a/app-portage/eix/metadata.xml
+++ b/app-portage/eix/metadata.xml
@@ -13,10 +13,14 @@
<description>Proxy committer, CC bugs</description>
</maintainer>
<use>
- <flag name="bzip2">Support for parsing of environment.bz2 to guess repository name of packages installed with ancient portage versions (requires <pkg>app-arch/bbzip2</pkg>). This flag is safe to disable for portage users that have re-merged all packages since 2007. This flag will be phased out.</flag>
+ <flag name="bzip2">Support for parsing of environment.bz2 to guess repository name of packages installed with ancient portage versions (requires <pkg>app-arch/bbzip2</pkg>). This flag is safe to disable for portage users that have re-merged all packages since 2007. This flag will be phased out.</flag>
+ <flag name="debug">Build with CXXFLAGS/LDFLAGS for debugging support. Only makes sense in combination with FEATURES=nostrip.</flag>
<flag name="deprecated">Installs wrapper scripts for all the previous executable names that will soon be going away. Enabled by default in 0.17.0, optional in 0.18.0, removed in next major release.</flag>
<flag name="doc">Create description of the eix cache file additionally in html format</flag>
+ <flag name="hardened">Add CXXFLAGS/LDFLAGS enhancing security at the cost of a slight speed loss. If a hardened gcc is used, these flags should not make a difference.</flag>
<flag name="nls">Support foreign language messages (experimental; currently only de)</flag>
+ <flag name="optimization">Add several CXXFLAGS/LDFLAGS for optimization.</flag>
+ <flag name="strong-optimization">Add more CXXFLAGS/LDFLAGS for optimization like graphite (if available). May cause trouble with some buggy compiler versions.</flag>
<flag name="sqlite">Compile in support for portage's sqlite backend; to actually use it you need additional configuration of portage and eix</flag>
<flag name="tools">Create separate binary for script helper tools (currently only: versionsort); useful if they are called extremely often</flag>
</use>