summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-12-01 01:10:23 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-12-01 01:10:23 +0000
commitece81738009e162c91b2bbf538932367bd1c82bb (patch)
treee19a0300d42631c10d6f7dd6b3920c2841d3e07d /app-portage
parentadd version bump to push pam fix to users - requested by pacho (diff)
downloadgentoo-2-ece81738009e162c91b2bbf538932367bd1c82bb.tar.gz
gentoo-2-ece81738009e162c91b2bbf538932367bd1c82bb.tar.bz2
gentoo-2-ece81738009e162c91b2bbf538932367bd1c82bb.zip
Version bump. Many internal changes but not many visible to the end user. Turn off IUSE defaults because enough people complained. Remove deprecated IUSE flag because it has been enough time to phase out.
(Portage version: 2.1.7.4/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog9
-rw-r--r--app-portage/eix/eix-0.19.0.ebuild51
2 files changed, 59 insertions, 1 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index f5d0b743fadd..af2973a19804 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.309 2009/10/29 18:15:01 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.310 2009/12/01 01:10:23 darkside Exp $
+
+*eix-0.19.0 (01 Dec 2009)
+
+ 01 Dec 2009; Jeremy Olexa <darkside@gentoo.org> +eix-0.19.0.ebuild:
+ Version bump. Many internal changes but not many visible to the end user.
+ Turn off IUSE defaults because enough people complained. Remove deprecated
+ IUSE flag because it has been enough time to phase out.
*eix-0.18.3 (29 Oct 2009)
diff --git a/app-portage/eix/eix-0.19.0.ebuild b/app-portage/eix/eix-0.19.0.ebuild
new file mode 100644
index 000000000000..4a3893a33394
--- /dev/null
+++ b/app-portage/eix/eix-0.19.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.19.0.ebuild,v 1.1 2009/12/01 01:10:23 darkside Exp $
+
+EAPI="2"
+
+inherit multilib autotools
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
+HOMEPAGE="http://eix.sourceforge.net"
+SRC_URI="mirror://sourceforge/eix/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="+bzip2 debug doc hardened nls optimization strong-optimization sqlite tools"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ doc? ( dev-python/docutils )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ local i s
+ for i in ${A}
+ do
+ s="${DISTDIR%/}/${i}"
+ einfo "Unpacking ${s} to ${PWD}"
+ test -s "${s}" || die "${s} does not exist"
+ xz -dc -- "${s}" | tar xof - || die "Unpacking ${s} failed"
+ done
+}
+
+src_configure() {
+ econf $(use_with bzip2) $(use_with sqlite) $(use_with doc rst) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable hardened security) $(use_enable optimization) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
+ --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ prepalldocs
+}