summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-10-30 00:42:59 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-10-30 00:42:59 +0000
commitba7558fe33f12c8b60c3f58888853cce4afa0891 (patch)
treeb2fb34d3c9c3102972680df2264862361cec551f /app-sci/ginac
parentremoved ppc 2.0 profile (diff)
downloadgentoo-2-ba7558fe33f12c8b60c3f58888853cce4afa0891.tar.gz
gentoo-2-ba7558fe33f12c8b60c3f58888853cce4afa0891.tar.bz2
gentoo-2-ba7558fe33f12c8b60c3f58888853cce4afa0891.zip
new package: a CAS as well as a C++ library providing algebraic capabilities.
Diffstat (limited to 'app-sci/ginac')
-rw-r--r--app-sci/ginac/ChangeLog11
-rw-r--r--app-sci/ginac/files/digest-ginac-1.0.91
-rw-r--r--app-sci/ginac/ginac-1.0.9.ebuild28
3 files changed, 40 insertions, 0 deletions
diff --git a/app-sci/ginac/ChangeLog b/app-sci/ginac/ChangeLog
new file mode 100644
index 000000000000..b976ec51e899
--- /dev/null
+++ b/app-sci/ginac/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-sci/ginac
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/ginac/ChangeLog,v 1.1 2002/10/30 00:42:59 george Exp $
+
+*ginac-1.0.9 (29 Oct 2002)
+
+ 29 Oct 2002; G.Shapovalov <georges@its.caltech.edu> ginac-1.0.9.ebuild :
+
+ initial release.
+ "GiNaC is a CAS as well as a C++ library providing algebraic capabilities."
+ ebuild submitted by Pierre-Henri Jondot <Pierre-Henri.Jondot@wanadoo.fr>
diff --git a/app-sci/ginac/files/digest-ginac-1.0.9 b/app-sci/ginac/files/digest-ginac-1.0.9
new file mode 100644
index 000000000000..c72ed8b469b9
--- /dev/null
+++ b/app-sci/ginac/files/digest-ginac-1.0.9
@@ -0,0 +1 @@
+MD5 e24ec7c3869240a1293a09581cec55ab GiNaC-1.0.9.tar.bz2 582710
diff --git a/app-sci/ginac/ginac-1.0.9.ebuild b/app-sci/ginac/ginac-1.0.9.ebuild
new file mode 100644
index 000000000000..07ef796fed44
--- /dev/null
+++ b/app-sci/ginac/ginac-1.0.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/ginac/ginac-1.0.9.ebuild,v 1.1 2002/10/30 00:42:59 george Exp $
+
+inherit flag-o-matic
+
+Name="GiNaC"
+S=${WORKDIR}/${Name}-${PV}
+
+DESCRIPTION="GiNaC : a free CAS (computer algebra system)"
+SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/${Name}-${PV}.tar.bz2"
+HOMEPAGE="http://www.ginac.de/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND="dev-libs/cln"
+
+src_compile() {
+ filter-flags "-funroll-loops -frerun-loop-opt"
+ econf || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}