summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-29 12:32:59 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-29 12:32:59 +0000
commit99e859982a40868fc89185234a87b3ec76e2dffb (patch)
tree4c7f9177bfcfb19b29935ced8007a0ae090e522a /app-sci/lin-seti
parentold (diff)
downloadgentoo-2-99e859982a40868fc89185234a87b3ec76e2dffb.tar.gz
gentoo-2-99e859982a40868fc89185234a87b3ec76e2dffb.tar.bz2
gentoo-2-99e859982a40868fc89185234a87b3ec76e2dffb.zip
hppa support #33813
Diffstat (limited to 'app-sci/lin-seti')
-rw-r--r--app-sci/lin-seti/lin-seti-0.7.6.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/app-sci/lin-seti/lin-seti-0.7.6.ebuild b/app-sci/lin-seti/lin-seti-0.7.6.ebuild
index 9392002ec734..159be174878e 100644
--- a/app-sci/lin-seti/lin-seti-0.7.6.ebuild
+++ b/app-sci/lin-seti/lin-seti-0.7.6.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/lin-seti/lin-seti-0.7.6.ebuild,v 1.1 2003/09/08 12:16:09 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/lin-seti/lin-seti-0.7.6.ebuild,v 1.2 2004/01/29 12:32:59 vapier Exp $
DESCRIPTION="A Seti@Home cache manager, cache-compatible with Seti Driver. Can be run as system daemon."
HOMEPAGE="http://lin-seti.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 sparc ~ppc ~alpha"
-IUSE=""
+KEYWORDS="x86 ppc sparc ~alpha hppa"
+
DEPEND="app-sci/setiathome"
src_compile() {
@@ -16,16 +17,14 @@ src_compile() {
}
src_install() {
- mkdir -m 755 ${D}usr
- mkdir -m 755 ${D}usr/bin
- mkdir -m 755 ${D}opt
- mkdir -m 755 ${D}etc
- mkdir -m 755 ${D}etc/init.d
+ dodir /usr/bin /opt /etc/init.d
make \
PREFIX=${D} \
install || die
# Let's see if this file already exists: if so we will not install it
- if [ -a "/opt/setiathome/cache/1/user_info.sah" ]; then rm ${D}opt/setiathome/cache/1/user_info.sah; fi
+ if [ -a "/opt/setiathome/cache/1/user_info.sah" ] ; then
+ rm ${D}/opt/setiathome/cache/1/user_info.sah
+ fi
# Otherwise the ebuild will overwrite this file!
# And THAT is bad: if the client runs in daemon mode,
# when switching to that dir it will wait forever for someone to give it
@@ -33,9 +32,7 @@ src_install() {
}
pkg_postinst () {
-
einfo "NOTICE: If you use SETI Driver for Windows"
einfo "to share the cache make sure it is"
einfo "version 1.6.4.0 or higher!"
- sleep 5
}