summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-05-12 12:27:26 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-05-12 12:27:26 +0000
commit8363e9fdaac4144ca2b6fe615c422e2393d230d5 (patch)
treee951f33db163216afa5ed1581c6ff9a55dee7ca8 /app-sci/octave
parentAdded s390 keywords (Manifest recommit) (diff)
downloadgentoo-2-8363e9fdaac4144ca2b6fe615c422e2393d230d5.tar.gz
gentoo-2-8363e9fdaac4144ca2b6fe615c422e2393d230d5.tar.bz2
gentoo-2-8363e9fdaac4144ca2b6fe615c422e2393d230d5.zip
Fixed BUG #50777.
Diffstat (limited to 'app-sci/octave')
-rw-r--r--app-sci/octave/ChangeLog10
-rw-r--r--app-sci/octave/octave-2.1.57-r1.ebuild15
2 files changed, 23 insertions, 2 deletions
diff --git a/app-sci/octave/ChangeLog b/app-sci/octave/ChangeLog
index fc08cf51b7a6..a568a1dc1143 100644
--- a/app-sci/octave/ChangeLog
+++ b/app-sci/octave/ChangeLog
@@ -1,12 +1,20 @@
# ChangeLog for app-sci/octave
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.26 2004/05/10 12:34:14 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.27 2004/05/12 12:27:26 kugelfang Exp $
+
+ 12 May 2004; Danny van Dyk <kugelfang@gentoo.org> octave-2.1.57-r1.ebuild:
+ The ebuild checks now if g77 has been compiled. If not, a warning is shown.
+ However, the compilation process proceeds, in case that a different compiler
+ than g77 shall be used. Fixes BUG #50777.
*octave-2.1.57-r1 (10 May 2004)
10 May 2004; Patrick Kursawe <phosphan@gentoo.org> octave-2.1.57-r1.ebuild:
Installs emacs related files if emacs is in USE now
+ 09 May 2004; Danny van Dyk <kugelfang@gentoo.org> octave-2.1.57.ebuild:
+ Added local useflag "blas" to make ebuild depend on virtual/blas.
+
05 May 2004; Bryan Østergaard <kloeri@gentoo.org> octave-2.1.57.ebuild:
Stable on alpha.
diff --git a/app-sci/octave/octave-2.1.57-r1.ebuild b/app-sci/octave/octave-2.1.57-r1.ebuild
index 4e11d7fc5afa..240b0e37722c 100644
--- a/app-sci/octave/octave-2.1.57-r1.ebuild
+++ b/app-sci/octave/octave-2.1.57-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.57-r1.ebuild,v 1.1 2004/05/10 12:34:14 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.57-r1.ebuild,v 1.2 2004/05/12 12:27:26 kugelfang Exp $
inherit flag-o-matic
@@ -13,6 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha ~sparc ~amd64"
IUSE="emacs static readline zlib tetex hdf5 mpi"
+#IUSE="emacs static readline zlib tetex hdf5 mpi" NOTE: Already added to use.local.desc.
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2-r3
@@ -22,6 +23,7 @@ DEPEND="virtual/glibc
zlib? ( sys-libs/zlib )
hdf5? ( dev-libs/hdf5 )
tetex? ( virtual/tetex )"
+# blas? ( virtual/blas )" NOTE: Blas-* is not fully done.
# NOTE: octave supports blas/lapack from intel but this is not open
# source nor is it free (as in beer OR speech) Check out...
@@ -38,6 +40,17 @@ src_compile() {
use hdf5 || myconf="${myconf} --without-hdf5"
use mpi || myconf="${myconf} --without-mpi"
+ # NOTE: We need gcc to be emerge with USE="f77"
+ /usr/bin/which g77 > /dev/null 2>&1
+ if [ $? != 0 ]; then
+ ewarn "GNU Fortran Compiler g77 is missing. This is no problem"
+ ewarn "as long as you have a Fortran Compiler that will be"
+ ewarn "detected by ./configure. If you have no other compiler"
+ ewarn "installed, ./configure _will_ fail. In this case, add"
+ ewarn "\"f77\" to your USE-flags and remerge gcc."
+ sleep 20
+ fi
+
# NOTE: This version actually works with gcc-3.x
./configure ${myconf} --prefix=/usr \
--sysconfdir=/etc \