summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-03-16 10:17:28 +0000
committerRoy Marples <uberlord@gentoo.org>2007-03-16 10:17:28 +0000
commitfcb7e00330ad7b161f8a2e61539eac27e3fa0f4b (patch)
tree40b4be3fbc980d954d2dd82bf88b5ac2e61acb78 /app-shells/dash
parentversion bump (diff)
downloadgentoo-2-fcb7e00330ad7b161f8a2e61539eac27e3fa0f4b.tar.gz
gentoo-2-fcb7e00330ad7b161f8a2e61539eac27e3fa0f4b.tar.bz2
gentoo-2-fcb7e00330ad7b161f8a2e61539eac27e3fa0f4b.zip
Drop the depend on yacc as we work fine with bison.
Stop using the versionator eclass. (Portage version: 2.1.2.2)
Diffstat (limited to 'app-shells/dash')
-rw-r--r--app-shells/dash/ChangeLog6
-rw-r--r--app-shells/dash/dash-0.5.3.7.ebuild19
2 files changed, 15 insertions, 10 deletions
diff --git a/app-shells/dash/ChangeLog b/app-shells/dash/ChangeLog
index f7ebd8c80f34..bf23c5559ca8 100644
--- a/app-shells/dash/ChangeLog
+++ b/app-shells/dash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/dash
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.36 2007/03/15 22:01:18 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.37 2007/03/16 10:17:28 uberlord Exp $
+
+ 16 Mar 2007; Roy Marples <uberlord@gentoo.org> dash-0.5.3.7.ebuild:
+ Drop the depend on yacc as we work fine with bison.
+ Stop using the versionator eclass.
*dash-0.5.3.7 (15 Mar 2007)
diff --git a/app-shells/dash/dash-0.5.3.7.ebuild b/app-shells/dash/dash-0.5.3.7.ebuild
index 78b10b102ccf..0316d0404909 100644
--- a/app-shells/dash/dash-0.5.3.7.ebuild
+++ b/app-shells/dash/dash-0.5.3.7.ebuild
@@ -1,31 +1,32 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.3.7.ebuild,v 1.2 2007/03/16 07:55:04 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.3.7.ebuild,v 1.3 2007/03/16 10:17:28 uberlord Exp $
-inherit eutils versionator flag-o-matic toolchain-funcs
+inherit eutils flag-o-matic toolchain-funcs
-DEB_P="${PN}_$(replace_version_separator 3 '-')"
-MY_P2="${DEB_P%-*}"
-MY_P="${MY_P2/_/-}"
+DEB_PV=${PV%.*}
+DEB_PATCH=${PV##*.}
+DEB_PF="${PN}_${DEB_PV}-${DEB_PATCH}"
+MY_P="${PN}-${DEB_PV}"
DESCRIPTION="Debian-version of NetBSD's lightweight bourne shell"
HOMEPAGE="http://ftp.debian.org/debian/pool/main/d/dash/"
-SRC_URI="mirror://debian/pool/main/d/dash/${MY_P2}.orig.tar.gz \
- mirror://debian/pool/main/d/dash/${DEB_P}.diff.gz"
+SRC_URI="mirror://debian/pool/main/d/dash/${PN}_${DEB_PV}.orig.tar.gz \
+ mirror://debian/pool/main/d/dash/${DEB_PF}.diff.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="static"
-DEPEND="dev-util/yacc"
+DEPEND=""
S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${WORKDIR}/${DEB_P}".diff
+ epatch "${WORKDIR}/${DEB_PF}".diff
# Below patch sorts the builtincmd structure correctly when LC_ALL isn't C
epatch "${FILESDIR}/${MY_P}"-sort-locale.patch