summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2005-11-20 17:06:55 +0000
committerFabian Groffen <grobian@gentoo.org>2005-11-20 17:06:55 +0000
commit26269d216beaeb3f0c525a956559c5c977dc579f (patch)
treeadb466fd627431725170b98de4b70acff8a89678 /app-shells/tcsh/tcsh-6.14-r2.ebuild
parentAdded move for webapp-config (diff)
downloadgentoo-2-26269d216beaeb3f0c525a956559c5c977dc579f.tar.gz
gentoo-2-26269d216beaeb3f0c525a956559c5c977dc579f.tar.bz2
gentoo-2-26269d216beaeb3f0c525a956559c5c977dc579f.zip
Fix for bug #104763: now scripts from /etc/profile.d are not being sourced for non-interactive shells. Moved unused legacy scripts to example dir instead of installing them and polluting the filesystem.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'app-shells/tcsh/tcsh-6.14-r2.ebuild')
-rw-r--r--app-shells/tcsh/tcsh-6.14-r2.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/app-shells/tcsh/tcsh-6.14-r2.ebuild b/app-shells/tcsh/tcsh-6.14-r2.ebuild
new file mode 100644
index 000000000000..d9d1d2f79e5d
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.14-r2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.14-r2.ebuild,v 1.1 2005/11/20 17:06:55 grobian Exp $
+
+inherit eutils
+
+MY_P="${P}.00"
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+HOMEPAGE="http://www.tcsh.org/"
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/${MY_P}.tar.gz
+ mirror://gentoo/${P}-conffiles.tar.bz2"
+# note: starting from this version the various files scattered around
+# the place in ${FILESDIR} are now stored in a versioned tarball
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~mips"
+IUSE="perl"
+
+DEPEND="virtual/libc
+ >=sys-libs/ncurses-5.1
+ perl? ( dev-lang/perl )"
+
+S="${WORKDIR}/${MY_P}"
+
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}/${P}"-r2.patch
+}
+
+src_compile() {
+ econf --prefix=/ || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR="${D}" install install.man || die
+
+ if use perl ; then
+ perl tcsh.man2html || die
+ dohtml tcsh.html/*.html
+ fi
+
+ insinto /etc
+ doins \
+ "${WORKDIR}"/gentoo/csh.cshrc \
+ "${WORKDIR}"/gentoo/csh.login
+
+ insinto /etc/skel
+
+ insinto /etc/profile.d
+ doins \
+ "${WORKDIR}"/gentoo/tcsh-bindkey.csh \
+ "${WORKDIR}"/gentoo/tcsh-settings.csh
+
+ dodoc FAQ Fixes NewThings Ported README WishList Y2K
+
+ docinto examples
+ dodoc \
+ "${WORKDIR}"/gentoo/tcsh-aliases \
+ "${WORKDIR}"/gentoo/tcsh-complete \
+ "${WORKDIR}"/gentoo/tcsh-gentoo_legacy \
+ "${WORKDIR}"/gentoo/tcsh.config .tcsh.config
+}
+
+pkg_postinst() {
+ # add csh -> tcsh symlink only if csh is not yet there
+ [ ! -e /bin/csh ] && dosym /bin/tcsh /bin/csh
+
+ while read line; do einfo "${line}"; done <<EOF
+The default behaviour of tcsh has significantly changed starting from
+version 6.14-r1. In contrast to previous ebuilds, the amount of
+customisation to the default shell's behaviour has been reduced to a
+bare minimum (a customised prompt).
+If you rely on the customisations provided by previous ebuilds, you will
+have to copy over the relevant (now commented out) parts to your own
+~/.tcshrc. Please check all tcsh-* files in
+/usr/share/tcsh-6.14-r2/example and include their behaviour in your own
+configuration files.
+The tcsh-complete file is not any longer sourced by the default system
+scripts.
+EOF
+}