summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-03 21:54:17 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-03 21:54:17 +0000
commit3737c91763c4be14b2b657f194194ede93a6c403 (patch)
tree2bde3e53e342ec2f5b7ea557a163a206e101dc76 /app-shells/tcsh
parentRevbump and remove old. Properly apply java patch (bug #468494) and make free... (diff)
downloadgentoo-2-3737c91763c4be14b2b657f194194ede93a6c403.tar.gz
gentoo-2-3737c91763c4be14b2b657f194194ede93a6c403.tar.bz2
gentoo-2-3737c91763c4be14b2b657f194194ede93a6c403.zip
app-shells/tcsh: Add fix for compilation with ncurses[tinfo], #459484
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'app-shells/tcsh')
-rw-r--r--app-shells/tcsh/ChangeLog8
-rw-r--r--app-shells/tcsh/metadata.xml16
-rw-r--r--app-shells/tcsh/tcsh-6.18.01-r1.ebuild95
3 files changed, 110 insertions, 9 deletions
diff --git a/app-shells/tcsh/ChangeLog b/app-shells/tcsh/ChangeLog
index cffa9a66aab0..ffbbcc8c0bf5 100644
--- a/app-shells/tcsh/ChangeLog
+++ b/app-shells/tcsh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/tcsh
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.122 2013/05/01 11:12:38 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.123 2013/05/03 21:54:17 jlec Exp $
+
+*tcsh-6.18.01-r1 (03 May 2013)
+
+ 03 May 2013; Justin Lecher <jlec@gentoo.org> +tcsh-6.18.01-r1.ebuild,
+ metadata.xml:
+ Add fix for compilation with ncurses[tinfo], #459484
01 May 2013; Agostino Sarubbo <ago@gentoo.org> tcsh-6.18.01.ebuild:
Stable for sh, wrt bug #466834
diff --git a/app-shells/tcsh/metadata.xml b/app-shells/tcsh/metadata.xml
index 3d2b8a524ea4..bbb6c66303b6 100644
--- a/app-shells/tcsh/metadata.xml
+++ b/app-shells/tcsh/metadata.xml
@@ -1,18 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>grobian@gentoo.org</email>
- <name>Fabian Groffen</name>
- </maintainer>
- <longdescription>
+ <maintainer>
+ <email>grobian@gentoo.org</email>
+ <name>Fabian Groffen</name>
+ </maintainer>
+ <longdescription>
Tcsh is an enhanced, but completely compatible version of the Berkeley
UNIX C shell (csh). It is a command language interpreter usable both as
an interactive login shell and a shell script command processor. It
includes a command-line editor, programmable word completion, spelling
correction, a history mechanism, job control and a C-like syntax.
</longdescription>
- <use>
- <flag name='catalogs'>Add support for NLS catalogs</flag>
- </use>
+ <use>
+ <flag name="catalogs">Add support for NLS catalogs</flag>
+ </use>
</pkgmetadata>
diff --git a/app-shells/tcsh/tcsh-6.18.01-r1.ebuild b/app-shells/tcsh/tcsh-6.18.01-r1.ebuild
new file mode 100644
index 000000000000..f38a2b0a5ed3
--- /dev/null
+++ b/app-shells/tcsh/tcsh-6.18.01-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.18.01-r1.ebuild,v 1.1 2013/05/03 21:54:17 jlec Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic autotools prefix
+
+CONFVER="1.9"
+
+DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
+HOMEPAGE="http://www.tcsh.org/"
+SRC_URI="ftp://ftp.astron.com/pub/tcsh/${P}.tar.gz
+ http://www.gentoo.org/~grobian/distfiles/tcsh-gentoo-patches-r${CONFVER}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls doc"
+RESTRICT="test"
+
+# we need gettext because we run autoconf (AM_ICONV)
+RDEPEND=">=sys-libs/ncurses-5.1
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? ( dev-lang/perl )"
+
+CONFDIR=${WORKDIR}/tcsh-gentoo-patches-r${CONFVER}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-6.14.00-debian-dircolors.patch # bug #120792
+ epatch "${FILESDIR}"/${PN}-6.14-makefile.patch # bug #151951
+ epatch "${FILESDIR}"/${PN}-6.14-use-ncurses.patch
+
+ sed \
+ -e "s:\(ncurses\):\1 tinfo:g" \
+ -i configure.in || die
+
+ eautoreconf
+
+ # fix gencat usage
+ sed -i -e 's/cat \$\^ \$> | \$(GENCAT) \$@/rm -f $@; $(GENCAT) $@ $> $^/' \
+ nls/Makefile.in || die
+
+ # unify ECHO behaviour
+ echo "#undef ECHO_STYLE" >> config_f.h
+ echo "#define ECHO_STYLE BOTH_ECHO" >> config_f.h
+
+ eprefixify "${CONFDIR}"/*
+ # activate the right default PATH
+ if [[ -z ${EPREFIX} ]] ; then
+ sed -i \
+ -e 's/^#MAIN//' -e '/^#PREFIX/d' \
+ "${CONFDIR}"/csh.login || die
+ else
+ sed -i \
+ -e 's/^#PREFIX//' -e '/^#MAIN/d' \
+ "${CONFDIR}"/csh.login || die
+ fi
+}
+
+src_configure() {
+ # make tcsh look and live along the lines of the prefix
+ append-cppflags -D_PATH_DOTCSHRC="'"'"${EPREFIX}/etc/csh.cshrc"'"'"
+ append-cppflags -D_PATH_DOTLOGIN="'"'"${EPREFIX}/etc/csh.login"'"'"
+ append-cppflags -D_PATH_DOTLOGOUT="'"'"${EPREFIX}/etc/csh.logout"'"'"
+ append-cppflags -D_PATH_USRBIN="'"'"${EPREFIX}/usr/bin"'"'"
+ append-cppflags -D_PATH_BIN="'"'"${EPREFIX}/bin"'"'"
+
+ econf \
+ --prefix="${EPREFIX:-/}" \
+ --datarootdir='${prefix}/usr/share' \
+ $(use_enable nls) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.man || die
+
+ if use doc ; then
+ perl tcsh.man2html tcsh.man || die
+ dohtml tcsh.html/*.html
+ fi
+
+ insinto /etc
+ doins \
+ "${CONFDIR}"/csh.cshrc \
+ "${CONFDIR}"/csh.login
+
+ dodoc FAQ Fixes NewThings Ported README WishList Y2K
+
+ # bug #119703: add csh -> tcsh symlink
+ dosym /bin/tcsh /bin/csh
+}