summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-17 14:31:29 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-17 14:31:29 +0000
commit66d83b00a018a967c11ee2caab752daea7f6a593 (patch)
tree989efe923e3c224ee006d91f3d9a619fc2da4dbc /app-shells/tcsh
parentAdded IUSE. (diff)
downloadgentoo-2-66d83b00a018a967c11ee2caab752daea7f6a593.tar.gz
gentoo-2-66d83b00a018a967c11ee2caab752daea7f6a593.tar.bz2
gentoo-2-66d83b00a018a967c11ee2caab752daea7f6a593.zip
lintool
Diffstat (limited to 'app-shells/tcsh')
-rw-r--r--app-shells/tcsh/tcsh-6.10-r3.ebuild23
1 files changed, 9 insertions, 14 deletions
diff --git a/app-shells/tcsh/tcsh-6.10-r3.ebuild b/app-shells/tcsh/tcsh-6.10-r3.ebuild
index bf168d71a823..1e6099aa79ab 100644
--- a/app-shells/tcsh/tcsh-6.10-r3.ebuild
+++ b/app-shells/tcsh/tcsh-6.10-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.10-r3.ebuild,v 1.7 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.10-r3.ebuild,v 1.8 2002/10/17 14:31:29 vapier Exp $
IUSE="perl"
@@ -12,20 +12,19 @@ SRC_URI="ftp://ftp.gw.com/pub/unix/tcsh/${P}.tar.gz
HOMEPAGE="http://www.tcsh.org/"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.1
- perl? ( sys-devel/perl )"
+ perl? ( sys-devel/perl )"
SLOT="0"
KEYWORDS="x86 ppc sparc sparc64"
LICENSE="BSD"
src_unpack() {
- unpack ${A}
- cd ${S}
- patch -p0 < ${FILESDIR}/${P}-tc.os.h-gentoo.diff
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-tc.os.h-gentoo.diff
}
src_compile() {
-
./configure \
--prefix=/ \
--mandir=/usr/share/man \
@@ -38,17 +37,13 @@ src_compile() {
src_install() {
make DESTDIR=${D} install install.man || die
- if [ "`use perl`" ]
- then
- perl tcsh.man2html || die
- dohtml tcsh.html/*.html
- fi
+ if [ "`use perl`" ]; then
+ perl tcsh.man2html || die
+ dohtml tcsh.html/*.html
+ fi
dosym tcsh /bin/csh
dodoc FAQ Fixes NewThings Ported README WishList Y2K
insinto /etc
doins ${FILESDIR}/csh.cshrc ${FILESDIR}/csh.login
}
-
-
-