summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-03-08 11:48:40 +0000
committerFabian Groffen <grobian@gentoo.org>2012-03-08 11:48:40 +0000
commitbe7675b5628a7907f9f82e9dffc1b9b6737af66e (patch)
tree8fc4eb6375cc35479f011b6b8044e81fd9f08a4d /app-shells/tcsh
parentx86 stable wrt bug #400025 (diff)
downloadgentoo-2-be7675b5628a7907f9f82e9dffc1b9b6737af66e.tar.gz
gentoo-2-be7675b5628a7907f9f82e9dffc1b9b6737af66e.tar.bz2
gentoo-2-be7675b5628a7907f9f82e9dffc1b9b6737af66e.zip
Fix complaints from append-flags, drop old
(Portage version: 2.2.01.20271-prefix/cvs/SunOS i386)
Diffstat (limited to 'app-shells/tcsh')
-rw-r--r--app-shells/tcsh/ChangeLog6
-rw-r--r--app-shells/tcsh/tcsh-6.16.ebuild91
-rw-r--r--app-shells/tcsh/tcsh-6.18.01.ebuild12
3 files changed, 11 insertions, 98 deletions
diff --git a/app-shells/tcsh/ChangeLog b/app-shells/tcsh/ChangeLog
index c339e1471e4d..23c489eccdf1 100644
--- a/app-shells/tcsh/ChangeLog
+++ b/app-shells/tcsh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/tcsh
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.111 2012/03/02 20:52:14 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/ChangeLog,v 1.112 2012/03/08 11:48:40 grobian Exp $
+
+ 08 Mar 2012; Fabian Groffen <grobian@gentoo.org> -tcsh-6.16.ebuild,
+ tcsh-6.18.01.ebuild:
+ Fix complaints from append-flags, drop old
02 Mar 2012; Brent Baude <ranger@gentoo.org> tcsh-6.17-r1.ebuild:
Marking tcsh-6.17-r1 ppc64 for bug 389013
diff --git a/app-shells/tcsh/tcsh-6.16.ebuild b/app-shells/tcsh/tcsh-6.16.ebuild
deleted file mode 100644
index 14e1f2e096d0..000000000000
--- a/app-shells/tcsh/tcsh-6.16.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.16.ebuild,v 1.12 2011/04/22 07:17:44 grobian Exp $
-
-EAPI=3
-
-inherit eutils flag-o-matic autotools prefix
-
-CONFVER="1.8"
-
-MY_P="${P}.00"
-DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
-HOMEPAGE="http://www.tcsh.org/"
-SRC_URI="ftp://ftp.astron.com/pub/tcsh/old/${MY_P}.tar.gz
- http://www.gentoo.org/~grobian/distfiles/tcsh-gentoo-patches-r${CONFVER}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="perl catalogs"
-RESTRICT="test"
-
-# we need gettext because we run autoconf
-RDEPEND=">=sys-libs/ncurses-5.1
- virtual/libiconv"
-DEPEND="${RDEPEND}
- sys-devel/gettext
- perl? ( dev-lang/perl )"
-
-S=${WORKDIR}/${MY_P}
-CONFDIR=${WORKDIR}/tcsh-gentoo-patches-r${CONFVER}
-
-src_prepare() {
- epatch "${FILESDIR}/${MY_P/16/14}"-debian-dircolors.patch # bug #120792
- epatch "${FILESDIR}"/${PN}-6.14-makefile.patch # bug #151951
- epatch "${FILESDIR}"/${PN}-6.14-use-ncurses.patch
- eautoreconf
-
- if use catalogs ; then
- einfo "enabling NLS catalogs support..."
- sed -i -e "s/#undef NLS_CATALOGS/#define NLS_CATALOGS/" \
- config_f.h || die
- eend $?
- fi
-
- # unify ECHO behaviour
- echo "#undef ECHO_STYLE" >> config_f.h
- echo "#define ECHO_STYLE BOTH_ECHO" >> config_f.h
-
- eprefixify "${CONFDIR}"/*
- # activate the right default PATH
- if [[ -z ${EPREFIX} ]] ; then
- sed -i \
- -e 's/^#MAIN//' -e '/^#PREFIX/d' \
- "${CONFDIR}"/csh.login || die
- else
- sed -i \
- -e 's/^#PREFIX//' -e '/^#MAIN/d' \
- "${CONFDIR}"/csh.login || die
- fi
-}
-
-src_configure() {
- # make tcsh look and live along the lines of the prefix
- append-flags -D_PATH_DOTCSHRC="'"'"${EPREFIX}/etc/csh.cshrc"'"'"
- append-flags -D_PATH_DOTLOGIN="'"'"${EPREFIX}/etc/csh.login"'"'"
- append-flags -D_PATH_DOTLOGOUT="'"'"${EPREFIX}/etc/csh.logout"'"'"
- append-flags -D_PATH_USRBIN="'"'"${EPREFIX}/usr/bin"'"'"
- append-flags -D_PATH_BIN="'"'"${EPREFIX}/bin"'"'"
-
- econf --prefix="${EPREFIX:-/}" || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install install.man || die
-
- if use perl ; then
- perl tcsh.man2html tcsh.man || die
- dohtml tcsh.html/*.html
- fi
-
- insinto /etc
- doins \
- "${CONFDIR}"/csh.cshrc \
- "${CONFDIR}"/csh.login
-
- dodoc FAQ Fixes NewThings Ported README WishList Y2K
-
- # bug #119703: add csh -> tcsh symlink
- dosym /bin/tcsh /bin/csh
-}
diff --git a/app-shells/tcsh/tcsh-6.18.01.ebuild b/app-shells/tcsh/tcsh-6.18.01.ebuild
index 5553eabc6cef..1df7ef91147b 100644
--- a/app-shells/tcsh/tcsh-6.18.01.ebuild
+++ b/app-shells/tcsh/tcsh-6.18.01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.18.01.ebuild,v 1.1 2012/03/01 16:30:48 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.18.01.ebuild,v 1.2 2012/03/08 11:48:40 grobian Exp $
EAPI="3"
@@ -57,11 +57,11 @@ src_prepare() {
src_configure() {
# make tcsh look and live along the lines of the prefix
- append-flags -D_PATH_DOTCSHRC="'"'"${EPREFIX}/etc/csh.cshrc"'"'"
- append-flags -D_PATH_DOTLOGIN="'"'"${EPREFIX}/etc/csh.login"'"'"
- append-flags -D_PATH_DOTLOGOUT="'"'"${EPREFIX}/etc/csh.logout"'"'"
- append-flags -D_PATH_USRBIN="'"'"${EPREFIX}/usr/bin"'"'"
- append-flags -D_PATH_BIN="'"'"${EPREFIX}/bin"'"'"
+ append-cppflags -D_PATH_DOTCSHRC="'"'"${EPREFIX}/etc/csh.cshrc"'"'"
+ append-cppflags -D_PATH_DOTLOGIN="'"'"${EPREFIX}/etc/csh.login"'"'"
+ append-cppflags -D_PATH_DOTLOGOUT="'"'"${EPREFIX}/etc/csh.logout"'"'"
+ append-cppflags -D_PATH_USRBIN="'"'"${EPREFIX}/usr/bin"'"'"
+ append-cppflags -D_PATH_BIN="'"'"${EPREFIX}/bin"'"'"
econf \
--prefix="${EPREFIX:-/}" \