summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2007-05-07 06:51:11 +0000
committerMamoru Komachi <usata@gentoo.org>2007-05-07 06:51:11 +0000
commit889640d7d6614650c5bc6260cc315c31f3984659 (patch)
tree14c26065c3a1d78241374e45f00e6bef1ca93cb8 /app-shells/zsh
parentadd cross-compile workaround for linux targets #177061 (diff)
downloadgentoo-2-889640d7d6614650c5bc6260cc315c31f3984659.tar.gz
gentoo-2-889640d7d6614650c5bc6260cc315c31f3984659.tar.bz2
gentoo-2-889640d7d6614650c5bc6260cc315c31f3984659.zip
Set nullglob to kill a warning when there are no scripts in /etc/profile.d. See bug #176994.
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/ChangeLog7
-rw-r--r--app-shells/zsh/files/digest-zsh-4.3.2-r16
-rw-r--r--app-shells/zsh/files/zprofile8
-rw-r--r--app-shells/zsh/zsh-4.3.2-r1.ebuild149
4 files changed, 12 insertions, 158 deletions
diff --git a/app-shells/zsh/ChangeLog b/app-shells/zsh/ChangeLog
index 2b8b23bbc253..986f3cc0ba2a 100644
--- a/app-shells/zsh/ChangeLog
+++ b/app-shells/zsh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/zsh
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.111 2007/05/01 11:32:31 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/ChangeLog,v 1.112 2007/05/07 06:51:11 usata Exp $
+
+ 07 May 2007; Mamoru KOMACHI <usata@gentoo.org> files/zprofile,
+ -zsh-4.3.2-r1.ebuild:
+ Set nullglob to kill a warning when there are no scripts in /etc/profile.d.
+ See bug #176994.
01 May 2007; Markus Rothe <corsair@gentoo.org> ChangeLog:
Stable on ppc64
diff --git a/app-shells/zsh/files/digest-zsh-4.3.2-r1 b/app-shells/zsh/files/digest-zsh-4.3.2-r1
deleted file mode 100644
index 5acb23db53a4..000000000000
--- a/app-shells/zsh/files/digest-zsh-4.3.2-r1
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 69d1ab9d179d7d16eb0251a0a60e0457 zsh-4.3.2-doc.tar.bz2 2207375
-RMD160 2f9bffc5faac847fa53f16ecf3f6f34fed6462ff zsh-4.3.2-doc.tar.bz2 2207375
-SHA256 f8d21d1afa4ad3e59d8ccf835eb378ca39b6c894400ad8cd67f4bce796d0c14f zsh-4.3.2-doc.tar.bz2 2207375
-MD5 e13fc4bb338fbb27ef7508a474310c8f zsh-4.3.2.tar.bz2 2263544
-RMD160 2bb4431db21cffdb2da4751c0fdaeca5efd0b61e zsh-4.3.2.tar.bz2 2263544
-SHA256 ca0e27cc99115294be8323afa50027da56ad937fa2d99cabcd2a26039181dfd3 zsh-4.3.2.tar.bz2 2263544
diff --git a/app-shells/zsh/files/zprofile b/app-shells/zsh/files/zprofile
index 69cae0b39ff0..bec0e52fd3b4 100644
--- a/app-shells/zsh/files/zprofile
+++ b/app-shells/zsh/files/zprofile
@@ -1,5 +1,5 @@
# /etc/zsh/zprofile
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/files/zprofile,v 1.3 2007/04/30 16:26:06 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/files/zprofile,v 1.4 2007/05/07 06:51:11 usata Exp $
# Load environment settings from profile.env, which is created by
# env-update from the files in /etc/env.d
@@ -31,9 +31,13 @@ unset ROOTPATH
[ -z "$EDITOR" ] && EDITOR="/bin/nano"
export EDITOR
+shopts=$-
+setopt nullglob
for sh in /etc/profile.d/*.sh ; do
if [ -r "$sh" ] ; then
. "$sh"
fi
done
-unset sh
+unsetopt nullglob
+set -$shopts
+unset sh shopts
diff --git a/app-shells/zsh/zsh-4.3.2-r1.ebuild b/app-shells/zsh/zsh-4.3.2-r1.ebuild
deleted file mode 100644
index d5a0ffafad80..000000000000
--- a/app-shells/zsh/zsh-4.3.2-r1.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/zsh-4.3.2-r1.ebuild,v 1.8 2007/02/27 16:59:15 grobian Exp $
-
-inherit eutils multilib
-
-DESCRIPTION="UNIX Shell similar to the Korn shell"
-HOMEPAGE="http://www.zsh.org/"
-SRC_URI="ftp://ftp.zsh.org/pub/${P}.tar.bz2
- doc? ( ftp://ftp.zsh.org/pub/${P}-doc.tar.bz2 )"
-
-LICENSE="ZSH"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="maildir ncurses static doc pcre caps unicode"
-
-RDEPEND="pcre? ( >=dev-libs/libpcre-3.9 )
- caps? ( sys-libs/libcap )
- ncurses? ( >=sys-libs/ncurses-5.1 )"
-DEPEND="sys-apps/groff
- >=sys-apps/sed-4
- ${RDEPEND}"
-
-src_unpack() {
- unpack ${P}.tar.bz2
- use doc && unpack ${P}-doc.tar.bz2
- cd ${S}
- epatch ${FILESDIR}/${PN}-init.d-gentoo.diff
- cd ${S}/Doc
- ln -sf . man1
- # fix zshall problem with soelim
- soelim zshall.1 > zshall.1.soelim
- mv zshall.1.soelim zshall.1
-}
-
-src_compile() {
- local myconf
-
- use static && myconf="${myconf} --disable-dynamic" \
- && LDFLAGS="${LDFLAGS} -static"
-
- econf \
- --bindir=/bin \
- --libdir=/usr/$(get_libdir) \
- --enable-etcdir=/etc/zsh \
- --enable-zshenv=/etc/zsh/zshenv \
- --enable-zlogin=/etc/zsh/zlogin \
- --enable-zlogout=/etc/zsh/zlogout \
- --enable-zprofile=/etc/zsh/zprofile \
- --enable-zshrc=/etc/zsh/zshrc \
- --enable-fndir=/usr/share/zsh/${PV%_*}/functions \
- --enable-site-fndir=/usr/share/zsh/site-functions \
- --enable-function-subdirs \
- --enable-ldflags="${LDFLAGS}" \
- --with-tcsetpgrp \
- $(use_with ncurses curses-terminfo) \
- $(use_enable maildir maildir-support) \
- $(use_enable pcre) \
- $(use_enable caps) \
- $(use_enable unicode multibyte) \
- ${myconf} || die "configure failed"
-
- if use static ; then
- # compile all modules statically, see Bug #27392
- sed -i -e "s/link=no/link=static/g" \
- -e "s/load=no/load=yes/g" \
- config.modules || die
- else
- # avoid linking to libs in /usr/lib, see Bug #27064
- sed -i -e "/LIBS/s%-lpcre%/usr/$(get_libdir)/libpcre.a%" \
- Makefile || die
- fi
-
- # emake still b0rks
- emake -j1 || die "make failed"
-}
-
-src_test() {
- for f in /dev/pt* ; do
- addpredict $f
- done
- make check || die "make check failed"
-}
-
-src_install() {
- einstall \
- bindir=${D}/bin \
- libdir=${D}/usr/$(get_libdir) \
- fndir=${D}/usr/share/zsh/${PV%_*}/functions \
- sitefndir=${D}/usr/share/zsh/site-functions \
- scriptdir=${D}/usr/share/zsh/${PV%_*}/scripts \
- install.bin install.man install.modules \
- install.info install.fns || die "make install failed"
-
- insinto /etc/zsh
- doins ${FILESDIR}/zprofile
-
- keepdir /usr/share/zsh/site-functions
- insinto /usr/share/zsh/${PV%_*}/functions/Prompts
- doins ${FILESDIR}/prompt_gentoo_setup || die
-
- # install miscellaneous scripts; bug #54520
- sed -i -e "s:/usr/local:/usr:g" {Util,Misc}/* || "sed failed"
- insinto /usr/share/zsh/${PV%_*}/Util
- doins Util/* || die "doins Util scripts failed"
- insinto /usr/share/zsh/${PV%_*}/Misc
- doins Misc/* || die "doins Misc scripts failed"
-
- dodoc ChangeLog* META-FAQ README INSTALL LICENCE config.modules
-
- if use doc ; then
- dohtml Doc/*
- insinto /usr/share/doc/${PF}
- doins Doc/zsh.{dvi,pdf}
- fi
-
- docinto StartupFiles
- dodoc StartupFiles/z*
-}
-
-pkg_preinst() {
- # Our zprofile file does the job of the old zshenv file
- # Move the old version into a zprofile script so the normal
- # etc-update process will handle any changes.
- if [ -f /etc/zsh/zshenv -a ! -f /etc/zsh/zprofile ]; then
- mv /etc/zsh/zshenv /etc/zsh/zprofile
- fi
-}
-
-pkg_postinst() {
- elog
- elog "If you want to enable Portage completions and Gentoo prompt,"
- elog "emerge app-shells/zsh-completion and add"
- elog " autoload -U compinit promptinit"
- elog " compinit"
- elog " promptinit; prompt gentoo"
- elog "to your ~/.zshrc"
- elog
- elog "Also, if you want to enable cache for the completions, add"
- elog " zstyle ':completion::complete:*' use-cache 1"
- elog "to your ~/.zshrc"
- elog
- # see Bug 26776
- ewarn
- ewarn "If you are upgrading from zsh-4.0.x you may need to"
- ewarn "remove all your old ~/.zcompdump files in order to use"
- ewarn "completion. For more info see zcompsys manpage."
- ewarn
-}