summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-01-16 11:20:02 +0000
committerJeroen Roovers <jer@gentoo.org>2015-01-16 11:20:02 +0000
commit341992d1a6244f31c5aa0946dd953ed1b5ff62f3 (patch)
treec0aeefedc5fef0eb9c8d9f3ede6c2071d5f6eb1b /app-shells
parentalpha/ia64/s390/sh/sparc stable wrt #526032 (diff)
downloadgentoo-2-341992d1a6244f31c5aa0946dd953ed1b5ff62f3.tar.gz
gentoo-2-341992d1a6244f31c5aa0946dd953ed1b5ff62f3.tar.bz2
gentoo-2-341992d1a6244f31c5aa0946dd953ed1b5ff62f3.zip
Remove unneeded dependency on sys-libs/ncurses.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/esh/ChangeLog7
-rw-r--r--app-shells/esh/esh-0.8.5-r2.ebuild24
2 files changed, 16 insertions, 15 deletions
diff --git a/app-shells/esh/ChangeLog b/app-shells/esh/ChangeLog
index 9ddac6a9c840..6f81bc5036ff 100644
--- a/app-shells/esh/ChangeLog
+++ b/app-shells/esh/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-shells/esh
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/ChangeLog,v 1.29 2012/09/07 13:28:02 johu Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/ChangeLog,v 1.30 2015/01/16 11:20:02 jer Exp $
+
+ 16 Jan 2015; Jeroen Roovers <jer@gentoo.org> esh-0.8.5-r2.ebuild:
+ Remove unneeded dependency on sys-libs/ncurses.
07 Sep 2012; Johannes Huber <johu@gentoo.org> -esh-0.8.5-r1.ebuild:
Remove old.
diff --git a/app-shells/esh/esh-0.8.5-r2.ebuild b/app-shells/esh/esh-0.8.5-r2.ebuild
index 297f20176e6c..2ae349f3e3ca 100644
--- a/app-shells/esh/esh-0.8.5-r2.ebuild
+++ b/app-shells/esh/esh-0.8.5-r2.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8.5-r2.ebuild,v 1.4 2012/09/07 13:26:57 johu Exp $
-
-EAPI="2"
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8.5-r2.ebuild,v 1.5 2015/01/16 11:20:02 jer Exp $
+EAPI=5
inherit flag-o-matic toolchain-funcs
DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
@@ -15,37 +14,36 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="debug"
-DEPEND=">=sys-libs/ncurses-5.1
- >=sys-libs/readline-4.1"
+DEPEND=">=sys-libs/readline-4.1"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}"
src_prepare() {
+ emake clean
+
sed -i \
-e 's|-g ||' \
-e 's|-DMEM_DEBUG ||' \
-e 's|^CFLAGS|&+|g' \
- -e 's|^LIB=|LIB= -lncurses |' \
-e 's|$(CC) |&$(CFLAGS) $(LDFLAGS) |g' \
-e 's:-ltermcap::' \
- Makefile || die "sed Makefile"
- }
+ Makefile || die
+}
+
src_compile() {
# For some reason, this tarball has binary files in it for x86.
# Make clean so we can rebuild for our arch and optimization.
- emake clean
use debug && append-flags -DMEM_DEBUG
emake \
CC="$(tc-getCC)" \
- LDFLAGS="${LDFLAGS}" \
- || die "emake failed"
+ LDFLAGS="${LDFLAGS}"
}
src_install() {
- dobin esh || die
+ dobin esh
doinfo doc/esh.info
dodoc CHANGELOG CREDITS GC_README HEADER READLINE-HACKS TODO
dohtml doc/*.html