summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-04-06 06:21:41 +0000
committerJonathan Callen <abcd@gentoo.org>2010-04-06 06:21:41 +0000
commit6b1b84d1b94793df3544024f0034e0234f6ecaae (patch)
treea715a3a7d49684866dc7c6ceda6fcefb717d1369 /app-shells
parentVersion bump which incorporates libsubversion patch. (diff)
downloadgentoo-2-6b1b84d1b94793df3544024f0034e0234f6ecaae.tar.gz
gentoo-2-6b1b84d1b94793df3544024f0034e0234f6ecaae.tar.bz2
gentoo-2-6b1b84d1b94793df3544024f0034e0234f6ecaae.zip
Bump to EAPI=3, add prefix keywords, patches
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fish/ChangeLog9
-rw-r--r--app-shells/fish/files/fish-1.22.3-gettext.patch11
-rw-r--r--app-shells/fish/files/fish-1.23.0-gentoo-alt.patch78
-rw-r--r--app-shells/fish/fish-1.23.0.ebuild44
4 files changed, 124 insertions, 18 deletions
diff --git a/app-shells/fish/ChangeLog b/app-shells/fish/ChangeLog
index bae67b80cac8..c8b010fd2074 100644
--- a/app-shells/fish/ChangeLog
+++ b/app-shells/fish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/fish
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.40 2009/11/03 15:27:55 vostorga Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.41 2010/04/06 06:21:41 abcd Exp $
+
+ 06 Apr 2010; Jonathan Callen <abcd@gentoo.org>
+ +files/fish-1.22.3-gettext.patch, fish-1.23.0.ebuild,
+ +files/fish-1.23.0-gentoo-alt.patch:
+ Bump to EAPI=3, add prefix keywords, patches
03 Nov 2009; Víctor Ostorga <vostorga@gentoo.org> fish-1.23.0.ebuild:
Removing doxygen DEPEND, bug #172586
diff --git a/app-shells/fish/files/fish-1.22.3-gettext.patch b/app-shells/fish/files/fish-1.22.3-gettext.patch
new file mode 100644
index 000000000000..6ac7f9d891ad
--- /dev/null
+++ b/app-shells/fish/files/fish-1.22.3-gettext.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2007-10-02 20:43:22.949337380 +0200
++++ configure.ac 2007-10-02 20:43:28.819055940 +0200
+@@ -210,6 +210,8 @@
+ )
+
+ if test x$local_gettext != xno; then
++ AM_GNU_GETTEXT
++ LIBS="$LIBS $LIBINTL"
+ AC_DEFINE([USE_GETTEXT],[1],[Perform string translations with gettext])
+ fi
+
diff --git a/app-shells/fish/files/fish-1.23.0-gentoo-alt.patch b/app-shells/fish/files/fish-1.23.0-gentoo-alt.patch
new file mode 100644
index 000000000000..088beb4ebc64
--- /dev/null
+++ b/app-shells/fish/files/fish-1.23.0-gentoo-alt.patch
@@ -0,0 +1,78 @@
+* Remove Darwin cruft, remove some Solaris misdetection crap, add
+ AM_ICONV instead of weird iconv check that not suprisingly fails on
+ Darwin.
+
+--- configure.ac
++++ configure.ac
+@@ -91,45 +91,6 @@
+
+
+ #
+-# Detect directories which may contain additional headers, libraries
+-# and commands. This needs to be done early - before Autoconf starts
+-# to mess with CFLAGS and all the other environemnt variables.
+-#
+-# This mostly helps OS X users, since fink usually installs out of
+-# tree and doesn't update CFLAGS.
+-#
+-
+-for i in /usr/pkg /sw /opt /opt/local; do
+-
+- AC_MSG_CHECKING([for $i/include include directory])
+- if test -d $i/include; then
+- AC_MSG_RESULT(yes)
+- CPPFLAGS="$CPPFLAGS -I$i/include/"
+- CFLAGS="$CFLAGS -I$i/include/"
+- else
+- AC_MSG_RESULT(no)
+- fi
+-
+- AC_MSG_CHECKING([for $i/lib library directory])
+- if test -d $i/lib; then
+- AC_MSG_RESULT(yes)
+- LDFLAGS="$LDFLAGS -L$i/lib/ -R$i/lib/"
+- else
+- AC_MSG_RESULT(no)
+- fi
+-
+- AC_MSG_CHECKING([for $i/bin command directory])
+- if test -d $i/bin; then
+- AC_MSG_RESULT(yes)
+- optbindirs="$optbindirs $i/bin"
+- else
+- AC_MSG_RESULT(no)
+- fi
+-
+-done
+-
+-
+-#
+ # Tell autoconf to create config.h header
+ #
+ AC_CONFIG_HEADERS(config.h)
+@@ -153,10 +114,7 @@
+ # Set up various programs needed for install
+ #
+
+-# Here we look for c99 before cc as Sun Studio compiler supports c99
+-# through the c99 binary.
+-
+-AC_PROG_CC([gcc c99 cc])
++AC_PROG_CC
+ AC_PROG_CPP
+ AC_PROG_INSTALL
+
+@@ -520,9 +445,8 @@
+ AC_SEARCH_LIBS( gettext, intl,,)
+ fi
+
+-
+-AC_SEARCH_LIBS( iconv_open, iconv, , [AC_MSG_ERROR([Could not find an iconv implementation, needed to build fish])] )
+-LIBS_FISH=$LIBS
+-LIBS=$LIBS_COMMON
++AM_ICONV
++LIBS_FISH="$LIBS $LIBICONV"
++LIBS="$LIBS_COMMON $LIBICONV"
+
+ #
+ # Check for libraries needed by fish_indent.
diff --git a/app-shells/fish/fish-1.23.0.ebuild b/app-shells/fish/fish-1.23.0.ebuild
index 5c58f9abd2c5..fa4a3871c2f6 100644
--- a/app-shells/fish/fish-1.23.0.ebuild
+++ b/app-shells/fish/fish-1.23.0.ebuild
@@ -1,34 +1,46 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-1.23.0.ebuild,v 1.5 2009/11/03 15:27:55 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-1.23.0.ebuild,v 1.6 2010/04/06 06:21:41 abcd Exp $
-inherit base
+EAPI="3"
+
+inherit base autotools
DESCRIPTION="fish is the Friendly Interactive SHell"
HOMEPAGE="http://fishshell.org/"
SRC_URI="http://fishshell.org/files/${PV}/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE="X"
-RDEPEND="sys-libs/ncurses
+
+DEPEND="sys-libs/ncurses
sys-devel/bc
www-client/htmlview
X? ( x11-misc/xsel )"
-DEPEND="${RDEPEND}"
+RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${P}-glibc-2.8.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-glibc-2.8.patch"
+ "${FILESDIR}/${PN}-1.22.3-gettext.patch"
+ "${FILESDIR}/${P}-gentoo-alt.patch"
+)
+
+src_configure() {
+ base_src_configure
+
+ eautoreconf
+}
-src_compile() {
+src_configure() {
# Set things up for fish to be a default shell.
# It has to be in /bin in case /usr is unavailable.
# Also, all of its utilities have to be in /bin.
econf \
- docdir=/usr/share/doc/${PF} \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
--without-xsel \
- --bindir=/bin \
- || die "econf failed"
- emake || die "emake failed"
+ --bindir="${EPREFIX}"/bin
}
src_install() {
@@ -37,11 +49,11 @@ src_install() {
pkg_postinst() {
elog
- elog "To use ${PN} as your default shell, you need to add /bin/${PN}"
- elog "to /etc/shells."
+ elog "To use ${PN} as your default shell, you need to add ${EPREFIX}/bin/${PN}"
+ elog "to ${EPREFIX}/etc/shells."
elog
- ewarn "Many files moved to ${ROOT}usr/share/fish/completions from /etc/fish.d/."
- ewarn "Delete everything in ${ROOT}etc/fish.d/ except fish_interactive.fish."
+ ewarn "Many files moved to ${EROOT}usr/share/fish/completions from ${EROOT}etc/fish.d/."
+ ewarn "Delete everything in ${EROOT}etc/fish.d/ except fish_interactive.fish."
ewarn "Otherwise, fish won't notice updates to the installed files,"
ewarn "because the ones in /etc will override the new ones in /usr."
echo