summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-11-02 16:37:17 +0000
committerRoy Marples <uberlord@gentoo.org>2006-11-02 16:37:17 +0000
commitc044f58af1a35185ee789286aca3944cd17b52ac (patch)
tree3a1c725cb89729be5d0e8dfc2bd65b65232194aa /app-shells
parentVersion bump to 1.3 (diff)
downloadgentoo-2-c044f58af1a35185ee789286aca3944cd17b52ac.tar.gz
gentoo-2-c044f58af1a35185ee789286aca3944cd17b52ac.tar.bz2
gentoo-2-c044f58af1a35185ee789286aca3944cd17b52ac.zip
Add a patch to fix process substitution on BSD.
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog8
-rw-r--r--app-shells/bash/bash-3.2_p3-r1.ebuild143
-rw-r--r--app-shells/bash/files/bash-3.2-process-subst.patch10
-rw-r--r--app-shells/bash/files/digest-bash-3.2_p3-r112
4 files changed, 172 insertions, 1 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 09eb50961427..f2bb5a7db918 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.122 2006/10/31 20:21:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.123 2006/11/02 16:37:17 uberlord Exp $
+
+*bash-3.2_p3-r1 (02 Nov 2006)
+
+ 02 Nov 2006; Roy Marples <uberlord@gentoo.org>
+ +files/bash-3.2-process-subst.patch, +bash-3.2_p3-r1.ebuild:
+ Add a patch to fix process substitution on BSD.
*bash-3.2_p3 (31 Oct 2006)
diff --git a/app-shells/bash/bash-3.2_p3-r1.ebuild b/app-shells/bash/bash-3.2_p3-r1.ebuild
new file mode 100644
index 000000000000..ac9a3f8d8cd8
--- /dev/null
+++ b/app-shells/bash/bash-3.2_p3-r1.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.2_p3-r1.ebuild,v 1.1 2006/11/02 16:37:17 uberlord Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+# Official patchlevel
+# See ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+READLINE_VER=5.2
+READLINE_PLEVEL=0
+
+DESCRIPTION="The standard GNU Bourne again shell"
+HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+# Hit the GNU mirrors before hitting Chet's site
+# printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
+# ${MY_PV} ${MY_PV/\.} ${i}
+SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz
+ ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz
+ $(for ((i=1; i<=PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
+ ${MY_PV} ${MY_PV/\.} ${i}
+ done)
+ $(for ((i=1; i<=READLINE_PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${READLINE_VER} ${READLINE_VER/\.} ${i}
+ printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${READLINE_VER} ${READLINE_VER/\.} ${i}
+ done)"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="afs bashlogger nls vanilla"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.1-gentoo.patch
+
+ # Fix process substitution on BSD.
+ epatch "${FILESDIR}"/${PN}-3.2-process-subst.patch
+
+ # Include official patches
+ local i
+ for ((i=1; i<=PLEVEL; i++)); do
+ epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
+ done
+ cd lib/readline
+ for ((i=1; i<=READLINE_PLEVEL; i++)); do
+ epatch "${DISTDIR}"/readline${READLINE_VER/\.}-$(printf '%03d' ${i})
+ done
+ cd ../..
+
+ if ! use vanilla ; then
+ epatch "${FILESDIR}"/${PN}-3.2-ulimit.patch
+ # Don't barf on handled signals in scripts
+ epatch "${FILESDIR}"/${PN}-3.0-trap-fg-signals.patch
+ epatch "${FILESDIR}"/${PN}-3.2-dev-fd-test-as-user.patch #131875
+ # Log bash commands to syslog #91327
+ if use bashlogger ; then
+ echo
+ ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
+ ewarn "This will log ALL output you enter into the shell, you have been warned."
+ ebeep
+ epause
+ epatch "${FILESDIR}"/${PN}-3.1-bash-logger.patch
+ fi
+ fi
+
+ epatch "${FILESDIR}"/${PN}-3.0-configs.patch
+}
+
+src_compile() {
+ filter-flags -malign-double
+
+ local myconf=
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #myconf="${myconf} $(use_with !readline installed-readline)"
+ myconf="${myconf} --without-installed-readline"
+
+ # Don't even think about building this statically without
+ # reading Bug 7714 first. If you still build it statically,
+ # don't come crying to use with bugs ;).
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ use nls || myconf="${myconf} --disable-nls"
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses
+ myconf="${myconf} --with-curses"
+
+ econf \
+ $(use_with afs) \
+ --disable-profiling \
+ --without-gnu-malloc \
+ ${myconf} || die
+ emake -j1 || die "make failed" # see bug 102426
+}
+
+src_install() {
+ einstall || die
+
+ dodir /bin
+ mv "${D}"/usr/bin/bash "${D}"/bin/
+ [[ ${USERLAND} != "BSD" ]] && dosym bash /bin/sh
+ dosym bash /bin/rbash
+
+ insinto /etc/bash
+ doins "${FILESDIR}"/{bashrc,bash_logout}
+ insinto /etc/skel
+ for f in bash{_logout,_profile,rc} ; do
+ newins "${FILESDIR}"/dot-${f} .${f}
+ done
+
+ sed -i -e "s:#${USERLAND}#@::" "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
+ sed -i -e '/#@/d' "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
+
+ doman doc/*.1
+ dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
+ dosym bash.info.gz /usr/share/info/bashref.info.gz
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/etc/bashrc ]] && [[ ! -d ${ROOT}/etc/bash ]] ; then
+ mkdir -p "${ROOT}"/etc/bash
+ mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
+ fi
+
+ # our bash_logout is just a place holder so dont
+ # force users to go through etc-update all the time
+ if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
+ rm -f "${D}"/etc/bash/bash_logout
+ fi
+}
diff --git a/app-shells/bash/files/bash-3.2-process-subst.patch b/app-shells/bash/files/bash-3.2-process-subst.patch
new file mode 100644
index 000000000000..cdc50fb29e06
--- /dev/null
+++ b/app-shells/bash/files/bash-3.2-process-subst.patch
@@ -0,0 +1,10 @@
+--- execute_cmd.c 2006-11-01 18:32:36 +0000
++++ execute_cmd.c 2006-11-01 18:32:42 +0000
+@@ -2672,6 +2672,7 @@
+
+ do_piping (pipe_in, pipe_out);
+
++ subshell_environment = 0;
+ if (async)
+ subshell_environment |= SUBSHELL_ASYNC;
+ if (pipe_in != NO_PIPE || pipe_out != NO_PIPE)
diff --git a/app-shells/bash/files/digest-bash-3.2_p3-r1 b/app-shells/bash/files/digest-bash-3.2_p3-r1
new file mode 100644
index 000000000000..e81ab95a3188
--- /dev/null
+++ b/app-shells/bash/files/digest-bash-3.2_p3-r1
@@ -0,0 +1,12 @@
+MD5 00bfa16d58e034e3c2aa27f390390d30 bash-3.2.tar.gz 2529838
+RMD160 a73f790817d98be375a36def567737498e33aaf1 bash-3.2.tar.gz 2529838
+SHA256 26c99025b59e30779300b68adb764f824974d267a4d7cc1b347d14a2393f9fb4 bash-3.2.tar.gz 2529838
+MD5 d8e10c754f477e3f3a581af566b89301 bash32-001 1539
+RMD160 633f6eb6b2b48345234c442b835abb94d10e0dad bash32-001 1539
+SHA256 beda60ce6186fafa36cd0a98db9ced42cff68daee4342cca73167fb0f2f43eaa bash32-001 1539
+MD5 d38a5288b2f0ea6c9ac76b66cc74ef7d bash32-002 1524
+RMD160 5d0f0dab859197784b15c683d54e7a505a8434c3 bash32-002 1524
+SHA256 a0ca49a3c47678ad074c990bdc871fcec680749b7f04f2def6527f04c589c40a bash32-002 1524
+MD5 0b90d37911827d8cb95f3b4353cc225e bash32-003 4599
+RMD160 efdcb4f8d6c800b5a3dab7bae37f95861bf186d8 bash32-003 4599
+SHA256 7ec9e5e7e402e43b12bfd3a9237f4f171029fc7f58e59335abf3ccb455a5a84d bash32-003 4599